[Bug 208243] USE_APACHE=24+ doesn't work

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 208243] USE_APACHE=24+ doesn't work

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=208243

            Bug ID: 208243
           Summary: USE_APACHE=24+ doesn't work
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Ports Framework
          Assignee: [hidden email]
          Reporter: [hidden email]
                CC: [hidden email]

If you have DEFAULT_VERSIONS=apache=2.2 and a port with USE_APACHE=24+, it
decides 22 is ok, and tries to build with it.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-apache
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 208243] USE_APACHE=24+ doesn't work

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=208243

Bernard Spil <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]
             Status|New                         |In Progress

--- Comment #1 from Bernard Spil <[hidden email]> ---
Confirmed. Trying to merge this into the USES work

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-apache
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 208243] USE_APACHE=24+ doesn't work

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=208243

--- Comment #2 from Bernard Spil <[hidden email]> ---
Backing out on including it in USES work. Will be added post-migration

See: https://reviews.freebsd.org/D12308

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-apache
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 208243] USE_APACHE=24+ doesn't work

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=208243

--- Comment #3 from Jochen Neumeister <[hidden email]> ---
can we close here?

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-apache
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 208243] USE_APACHE=24+ doesn't work

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=208243

Bernard Spil <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|In Progress                 |Closed
         Resolution|---                         |FIXED

--- Comment #4 from Bernard Spil <[hidden email]> ---
Just tested with new Mk/Uses/apache.mk

In /etc/make.conf

> DEFAULT_VERSIONS=       apache=2.2
then build www/mod_authnz_external24 which contains

> USES=           apache:2.4
this pulls in www/apache24

> $ make build-depends-list
> /usr/ports/ports-mgmt/pkg
> /usr/ports/www/apache24

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-apache
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 208243] USE_APACHE=24+ doesn't work

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=208243

Mathieu Arnold <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|Closed                      |Open
         Resolution|FIXED                       |---

--- Comment #5 from Mathieu Arnold <[hidden email]> ---
This is about (translated from the original problem) apache:2.4+

If apache:2.4+ works, I'm fine with closing it.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-apache
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 208243] USE_APACHE=24+ doesn't work

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=208243

--- Comment #6 from Bernard Spil <[hidden email]> ---
Hi mat,

Checking if I'm missing something here...

If in /etc/make.conf the user sets

> DEFAULT_VERSIONS=       apache=2.2
and the port sets

> USES=           apache:2.4+
it depends on www/apache24 not www/apache22.

If apache22 is already installed it fails in Mk/Uses/apache.mk

===>  ap24-mod_md-devel-1.1.10_3 is marked as broken: : Error from apache.mk.
Apache 2.2 is installed and port requires 2.4.
*** Error code 1

Should we add an additional error for the case where no Apache is installed,
DEFAULT_VERSIONS is 2.2 and the port requests 2.4+?

Cheers, Bernard.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-apache
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 208243] USE_APACHE=24+ doesn't work

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=208243

Mathieu Arnold <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|Open                        |Closed
         Resolution|---                         |Overcome By Events

--- Comment #7 from Mathieu Arnold <[hidden email]> ---
seems like nobody cared, and apache 2.2 has been removed anyway.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-apache
To unsubscribe, send any mail to "[hidden email]"