[Bug 210312] emulators/linux_base-c6: installation fails if linux.ko not loaded

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 210312] emulators/linux_base-c6: installation fails if linux.ko not loaded

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=210312

            Bug ID: 210312
           Summary: emulators/linux_base-c6: installation fails if
                    linux.ko not loaded
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: [hidden email]
          Reporter: [hidden email]
          Assignee: [hidden email]
             Flags: maintainer-feedback?([hidden email])

Attempting to update my packages failed with:

% sudo pkg upgrade
...
[10/19] Upgrading linux_base-c6 from 6.7_2 to 6.7_3...
sysctl: unknown oid 'compat.linux.osrelease'
linuxulator is not (kld)loaded, exiting
pkg: PRE-INSTALL script failed
%

It should be possible to upgrade the package w/o the linux kernel module
loaded.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-emulation
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

maintainer-feedback requested: [Bug 210312] emulators/linux_base-c6: installation fails if linux.ko not loaded

bugzilla-noreply
Ed Maste <[hidden email]> has reassigned Bugzilla Automation
<[hidden email]>'s request for maintainer-feedback to
[hidden email]:
Bug 210312: emulators/linux_base-c6: installation fails if linux.ko not loaded
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=210312



--- Description ---
Attempting to update my packages failed with:

% sudo pkg upgrade
...
[10/19] Upgrading linux_base-c6 from 6.7_2 to 6.7_3...
sysctl: unknown oid 'compat.linux.osrelease'
linuxulator is not (kld)loaded, exiting
pkg: PRE-INSTALL script failed
%

It should be possible to upgrade the package w/o the linux kernel module
loaded.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-emulation
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 210312] emulators/linux_base-c6: installation fails if linux.ko not loaded

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=210312

Ed Maste <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #1 from Ed Maste <[hidden email]> ---
Hrm, I suspect this started happening after r415233.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-emulation
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 210312] emulators/linux_base-c6: installation fails if linux.ko not loaded

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=210312

Tijl Coosemans <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #2 from Tijl Coosemans <[hidden email]> ---
Linux support is needed to run /compat/linux/sbin/ldconfig to update
/compat/linux/etc/ld.so.cache.  There are other linux packages that run other
tools during installation.  Kernel linux support is required when installing
linux packages.  We cannot do much about that.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-emulation
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 210312] emulators/linux_base-c6: installation fails if linux.ko not loaded

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=210312

--- Comment #3 from Ed Maste <[hidden email]> ---
There are things we *could* do:

- We could have some infrastructure that linux_base hooks into, in order to
prevent the installation from starting rather than having it fail 75% of the
way through (or prompt the user to kldload linux)
- For this specific case (ld.so.cache) we could have a FreeBSD port of Linux
ldconfig
- We could queue post-install actions, and run them later

It may well be that requiring linux.ko to be loaded for pkg installation is the
only reasonable approach. But we provide a terrible user experience by aborting
the installation part way through, and will need to find some way to address
that.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-emulation
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 210312] emulators/linux_base-c6: installation fails if linux.ko not loaded

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=210312

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Assignee|[hidden email]       |[hidden email]
             Status|New                         |Closed
                 CC|                            |[hidden email]
         Resolution|---                         |Overcome By Events

--- Comment #4 from [hidden email] ---
We have version 6.10
This is surely out-of-date. So I am closing here.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-emulation
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 210312] emulators/linux_base-c6: installation fails if linux.ko not loaded

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=210312

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Assignee|[hidden email]   |[hidden email]
             Status|Closed                      |Open
         Resolution|Overcome By Events          |---

--- Comment #6 from [hidden email] ---
Reopen,

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-emulation
To unsubscribe, send any mail to "[hidden email]"