[Bug 212812] www/chromium: tabs "hang" 10% of the time

classic Classic list List threaded Threaded
35 messages Options
12
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

            Bug ID: 212812
           Summary: www/chromium: tabs "hang" 10% of the time
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: [hidden email]
          Reporter: [hidden email]
             Flags: maintainer-feedback?([hidden email])
          Assignee: [hidden email]

Since the upgrade few weeks ago, opening a tab and loading the page can result
in the tab "hanging".  This occurs when loading a page.  The effect is that the
page contents cannot be scrolled, the page is completely unresponsive, and the
"spinner" continues spinning - just like when loading.  After a while the "page
is unresponsive" popup pops up.  Choosing to kill the page and reloading it
usually works.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

maintainer-feedback requested: [Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
Edward Tomasz Napierala <[hidden email]> has reassigned Bugzilla Automation
<[hidden email]>'s request for maintainer-feedback to
[hidden email]:
Bug 212812: www/chromium: tabs "hang" 10% of the time
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812



--- Description ---
Since the upgrade few weeks ago, opening a tab and loading the page can result
in the tab "hanging".  This occurs when loading a page.  The effect is that the
page contents cannot be scrolled, the page is completely unresponsive, and the
"spinner" continues spinning - just like when loading. After a while the "page
is unresponsive" popup pops up.  Choosing to kill the page and reloading it
usually works.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #1 from [hidden email] ---
Confirming that I see the same hanging tab behavior on 10.3-RELEASE p7, with
chromium-52.0.2743.116 built from source from ports on 2016-08-13.

This behavior is a significant work stopper for me: as I open an increasing
number of tabs (~15 or so), the chance of a tab's hanging increases to in
excess of 75% (and greater the longer the tab is open and interacted with).

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: [Bug 212812] www/chromium: tabs "hang" 10% of the time

clutton-3
On Mon, 2016-09-19 at 10:28 +0000, [hidden email] wrote:
> https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812
>
> [hidden email] changed:
>

It's not simple to fix because good hardware is required to do the
debugging. Ideally > 64G of ram. Then I could have everything in tmpfs,
+20Gb binary +20Gb that binary under debugger +whatever debugger might
need more. Or > 32G just for debugging purpose, having project on
ordinary FS. May be someone could give me an access to such an
equipment?

Also, I would love to have more distcc hosts to do what I'm about to
finish now: GYP->GN migration, that would decrease the waiting time for
me. And it would be much simpler to do component debugging with that GN
build tool. Having 3 hosts now, compilation time is about 6 hours for
me.

I would very much appreciate any help regarding the computation power.

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

Thomas Zander <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Severity|Affects Only Me             |Affects Many People
                 CC|                            |[hidden email]

--- Comment #2 from Thomas Zander <[hidden email]> ---
This is indeed becoming worse with every build. With 52.0.2743.116 on stable/11
amd64 it even often hangs when opening the very first tab. My first thought was
because of extensions, but I can happily reproduce the problem with the
official package and a newly created profile. Any ideas?

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

--- Comment #3 from Edward Tomasz Napierala <[hidden email]> ---
I wonder if this didn't happen before because of older Chromium, or because of
the older FreeBSD.  In other words - does it also happen with current Chromium,
but eg FreeBSD 10.2 or 10.1?

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

Carlos J. Puga Medina <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #4 from Carlos J. Puga Medina <[hidden email]> ---
It should be fixed after chromium update to 54.0.2840.50.

I'm testing it now and chromium works fine at the moment.

% pkg info chromium
chromium-54.0.2840.50
Name           : chromium
Version        : 54.0.2840.50
Installed on   : Fri Oct 28 00:42:29 2016 CEST
Origin         : www/chromium
Architecture   : freebsd:10:x86:64
Prefix         : /usr/local
Categories     : www
Licenses       : MPL and LGPL21 and BSD3CLAUSE
Maintainer     : [hidden email]
WWW            : http://www.chromium.org/Home
Comment        : Google web browser based on WebKit
Options        :
        CODECS         : on
        DEBUG          : off
        DRIVER         : off
        GCONF          : on
        KERBEROS       : on
        PULSEAUDIO     : off
        TEST           : off
Shared Libs required:
        libgtk-x11-2.0.so.0
        libexpat.so.1
        libXext.so.6
        libxslt.so.1
        libpango-1.0.so.0
        libjpeg.so.8
        libfreetype.so.6
        libFLAC.so.8
        libcairo.so.2
        libxml2.so.2
        libXtst.so.6
        libwebp.so.6
        libatk-1.0.so.0
        libcups.so.2
        libgmodule-2.0.so.0
        libXcomposite.so.1
        libXss.so.1
        libgdk_pixbuf-2.0.so.0
        libgio-2.0.so.0
        libXfixes.so.3
        libwebpdemux.so.2
        libnss3.so
        libnssutil3.so
        libnspr4.so
        libgobject-2.0.so.0
        libgconf-2.so.4
        libharfbuzz.so.0
        libglib-2.0.so.0
        libX11.so.6
        libdbus-1.so.3
        libXdamage.so.1
        libXrender.so.1
        libgdk-x11-2.0.so.0
        libXcursor.so.1
        libXrandr.so.2
        libsnappy.so.1
        libfontconfig.so.1
        libsmime3.so
        libXi.so.6
        libpangocairo-1.0.so.0
Annotations    :
        cpe            : cpe:2.3:a:google:chrome:54.0.2840.50:::::freebsd10:x64
Flat size      : 175MiB
Description    :
Chromium is an open-source browser project that aims to build a safer,
faster, and more stable way for all users to experience the web.

The Chromium website contains design documents, architecture overviews,
testing information, and more to help you learn to build and work with
the Chromium source code.

WWW: http://www.chromium.org/Home


Note that we're working to commit the update into the ports tree.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

Ori Bernstein <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #5 from Ori Bernstein <[hidden email]> ---
Also happens for me on FreeBSD 11, Version 54.0.2840.90 (64-bit). This was not
a problem on 51.0.2704. I skipped 52.0.x because of rendering issues.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

--- Comment #6 from [hidden email] ---
FWIW, I'm running chromium 54.0.2840.100 on amd64 (built from
https://github.com/gliaskos/freebsd-chromium as of last night) on FreeBSD
11.0-RELEASE, and I've just had a tab hang for me in exactly the same way it
did in the most recent version of the port.

Same symptoms reported in this bug: "spinner keeps spinning," eventually a
dialog saying that the page is unresponsive pops up.

-Brad

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

--- Comment #7 from Jonathan Chen <[hidden email]> ---
On an updated ports tree, r426611 2016-11-21 07:49:58 +1300, my build of
chromium current loads partially on facebook.com before stopping with a "page
is unresponsive" result.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

--- Comment #8 from Carlos J. Puga Medina <[hidden email]> ---
Probably, it's a good idea to remove .config/chromium folder after a fresh
install.

I had a lot of unresponsive pages and partly this fixed my problem.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

--- Comment #9 from Jonathan Chen <[hidden email]> ---
I've updated to chromium 54.x, and this appears to be a lot better than the
52.x series. So far, the "hang" rate has been reduced to just once a day..

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

--- Comment #10 from Ori Bernstein <[hidden email]> ---
Seems to be an issue talking to the render thread.

If it helps, I have an nvidia gpu.

$ bt
#0  _umtx_op_err () at /usr/src/lib/libthr/arch/amd64/amd64/_umtx_op_err.S:37
#1  0x0000000807e58aa6 in _thr_umtx_timedwait_uint (mtx=0x808072ed0,
id=<optimized out>, clockid=<optimized out>, abstime=<optimized out>, shared=0)
at /usr/src/lib/libthr/thread/thr_umtx.c:
#2  0x0000000807e62510 in cond_wait_user (abstime=0x0, cancel=1, cvp=<optimized
out>, mp=<optimized out>) at /usr/src/lib/libthr/thread/thr_cond.c:294
#3  cond_wait_common (cond=<optimized out>, mutex=<optimized out>, abstime=0x0,
cancel=1) at /usr/src/lib/libthr/thread/thr_cond.c:354
#4  0x0000000005790c28 in mojo::edk::Waiter::Wait(unsigned long, unsigned
long*) ()
#5  0x0000000005775f8d in mojo::edk::Core::WaitManyInternal(unsigned int
const*, unsigned int const*, unsigned int, unsigned long, unsigned int*,
mojo::edk::HandleSignalsState*) ()
#6  0x0000000005775c7e in mojo::edk::Core::Wait(unsigned int, unsigned int,
unsigned long, MojoHandleSignalsState*) ()
#7  0x00000000054ba9c9 in mojo::SyncHandleRegistry::WatchAllHandles(bool
const**, unsigned long) ()
#8  0x00000000054af362 in
IPC::SyncChannel::WaitForReply(mojo::SyncHandleRegistry*,
IPC::SyncChannel::SyncContext*, bool) ()
#9  0x00000000054aeeb4 in IPC::SyncChannel::Send(IPC::Message*) ()
#10 0x00000000063e0212 in non-virtual thunk to
gpu::GpuChannel::Send(IPC::Message*) ()
#11 0x0000000007865b86 in content::RenderThreadImpl::Send(IPC::Message*) ()
#12 0x00000000044f076d in
extensions::RuntimeCustomBindings::OpenChannelToExtension(v8::FunctionCallbackInfo<v8::Value>
const&) ()
#13 0x00000000044ecdd6 in
extensions::ObjectBackedNativeHandler::Router(v8::FunctionCallbackInfo<v8::Value>
const&) ()
#14 0x00000000039cb1dc in v8::internal::FunctionCallbackArguments::Call(void
(*)(v8::FunctionCallbackInfo<v8::Value> const&)) ()
#15 0x0000000003a2fdb0 in v8::internal::MaybeHandle<v8::internal::Object>
v8::internal::(anonymous
namespace)::HandleApiCallHelper<false>(v8::internal::Isolate*,
v8::internal::Handle<v8::int
rguments) ()
#16 0x0000000003a2f33d in
v8::internal::Builtin_Impl_HandleApiCall(v8::internal::BuiltinArguments,
v8::internal::Isolate*) ()
#17 0x0000390c31e063a7 in ?? ()
#18 0x0000000003efe480 in ?? ()
#19 0x0000390c31e062e1 in ?? ()
#20 0x00007fffffff9300 in ?? ()
#21 0x0000000300000000 in ?? ()
#22 0x00007fffffff9398 in ?? ()
#23 0x0000390c31f25eca in ?? ()
#24 0x0000021a05f04311 in ?? ()
#25 0x0000084188e290c9 in ?? ()
#26 0x0000000700000000 in ?? ()
#27 0x0000021a05f04421 in ?? ()
#28 0x00000d783b0fefc1 in ?? ()
#29 0x00001309bce09cd9 in ?? ()
#30 0x00001309bce10901 in ?? ()
#31 0x0000084188e290c9 in ?? ()
#32 0x0000021a05f04311 in ?? ()
#33 0x0000021a05f04421 in ?? ()
#34 0x00000d783b0fefc1 in ?? ()
#35 0x00001309bce151c9 in ?? ()
#36 0x00001309bce12189 in ?? ()
#37 0x00007fffffff93d8 in ?? ()
#38 0x0000390c31e4a7c3 in ?? ()
#39 0x000007f92d31c559 in ?? ()
#40 0x00001309bce09cd9 in ?? ()
#41 0x00001309bce12cb1 in ?? ()
#42 0x0000032935db3661 in ?? ()
#43 0x0000390c31e4a6e1 in ?? ()
#44 0x0000000c00000000 in ?? ()
#45 0x00007fffffff9440 in ?? ()
#46 0x0000390c31e2aa81 in ?? ()
#47 0x0000000000000000 in ?? ()

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #11 from [hidden email] ---
confirm thi

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

--- Comment #12 from [hidden email] ---
There is similar bug report
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=211036

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

--- Comment #13 from [hidden email] ---
I'm getting such behaviour quiet often even on chromium-54.0.2840.100
.config/chromium was deleted 10 minutes ago.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

Petr Fischer <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #14 from Petr Fischer <[hidden email]> ---
Hangs confirmed in chromium-55.0.2883.87 (11.0-RELEASE)

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

--- Comment #15 from rick <[hidden email]> ---
confirm +1
chromium-55.0.2883.87
FreeBSD 12.0-CURRENT amd64

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

--- Comment #16 from rick <[hidden email]> ---
confirmed in
chromium-56.0.2924.87
FreeBSD 12.0-CURRENT amd64
(of course with rm -rf ~/.config/chromium ~/.cache/chromium)

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 212812] www/chromium: tabs "hang" 10% of the time

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212812

--- Comment #17 from Jonathan Chen <[hidden email]> ---
Still happens with chromium-56.0.2924.87, 11-STABLE/amd64

It's easy enough to reproduce when loading Facebook.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
12