[Bug 216748] RTL8188CUS usb wifi adapter not working with CURRENT on i386 (not tested on other arch)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 216748] RTL8188CUS usb wifi adapter not working with CURRENT on i386 (not tested on other arch)

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=216748

            Bug ID: 216748
           Summary: RTL8188CUS usb wifi adapter not working with CURRENT
                    on i386 (not tested on other arch)
           Product: Base System
           Version: CURRENT
          Hardware: i386
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: usb
          Assignee: [hidden email]
          Reporter: [hidden email]
                CC: [hidden email]
                CC: [hidden email]

Hello,
I am trying to make work a TPlink TL WN725N NANO, that have a chip RTL8188CUS
the adaptor works on 11-STABLE  but not on 12-CURRENT. I put some traces in the
code, it finds the adaptor, but does NOT call the firmware-get code
the code calls ieee80211_ifattach from start to return but the interface DOES
Not show wlan0  the word LZT is a "TRACE"  I put on the code that shows the
function and the source line
Note that the attach code is called, than the ieee80211_ifattach is also colled
and exit but the interface wlan0 does not show available.
Any help would be very welcome. as I need to make an access point using the
device

some files:
/boot/loader.conf
legal.realtek.license_ack=1


===========================
dmesg after iserting the device:
ugen1.2: <vendor 0x0bda product 0x8176> at usbus1
rtwn0 on uhub0
rtwn0: <vendor 0x0bda product 0x8176, class 0/0, rev 2.00/2.00, addr 2> on
usbus1
LZT function:rtwn_usb_attach[344] name is rtwn0
LZT rtwn_attach[171]
rtwn0: MAC/BB RTL8188CUS, RF 6052 1T1R
LZT ieee80211_ifattach[331] ENTER
LZT ieee80211_ifattach[373] EXIT
LZT rtwn_attach[312] OKKKKKKKKKK
LZT function:rtwn_usb_attach[370] ATTACH
ugen1.2: <vendor 0x0bda product 0x8176> at usbus1 (disconnected)
rtwn0: at uhub0, port 5, addr 2 (disconnected)
rtwn0: detached

--
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-i386
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 216748] RTL8188CUS usb wifi adapter not working with CURRENT on i386 (not tested on other arch)

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=216748

Mark Linimon <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|[hidden email]    |[hidden email]
                   |                            |g

--
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-i386
To unsubscribe, send any mail to "[hidden email]"