[Bug 219448] www/chromium uses its own embedded copy of FreeType

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 219448] www/chromium uses its own embedded copy of FreeType

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=219448

            Bug ID: 219448
           Summary: www/chromium uses its own embedded copy of FreeType
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: [hidden email]
          Reporter: [hidden email]
             Flags: maintainer-feedback?([hidden email])
          Assignee: [hidden email]

I was wondering why font rendering looked a bit off in Chromium. It turned out
that Chromium is using an embedded copy of FreeType coming from PDFium.

Setting "pdfium_bundle_freetype" in "./third_party/pdfium/pdfium.gni" to
"false" and rebuilding fixed this for me. Currently the condition is set to
"!is_linux".

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

maintainer-feedback requested: [Bug 219448] www/chromium uses its own embedded copy of FreeType

bugzilla-noreply
Jan Kokemüller <[hidden email]> has reassigned Bugzilla Automation
<[hidden email]>'s request for maintainer-feedback to
[hidden email]:
Bug 219448: www/chromium uses its own embedded copy of FreeType
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=219448



--- Description ---
I was wondering why font rendering looked a bit off in Chromium. It turned out
that Chromium is using an embedded copy of FreeType coming from PDFium.

Setting "pdfium_bundle_freetype" in "./third_party/pdfium/pdfium.gni" to
"false" and rebuilding fixed this for me. Currently the condition is set to
"!is_linux".
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 219448] www/chromium uses its own embedded copy of FreeType

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=219448

Carlos J. Puga Medina <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Assignee|[hidden email]        |[hidden email]
             Status|New                         |Open
                 CC|                            |[hidden email]

--- Comment #1 from Carlos J. Puga Medina <[hidden email]> ---
Created attachment 182799
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=182799&action=edit
patch

- Don't use the PDFium bundle freetype

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"