[Bug 227553] editors/openoffice-4 editors/openoffice-devel: fails to build with boost 1.67

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 227553] editors/openoffice-4 editors/openoffice-devel: fails to build with boost 1.67

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227553

            Bug ID: 227553
           Summary: editors/openoffice-4 editors/openoffice-devel: fails
                    to build with boost 1.67
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Keywords: needs-patch
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: [hidden email]
          Reporter: [hidden email]
            Blocks: 227427
             Flags: maintainer-feedback?([hidden email])
          Assignee: [hidden email]

After bug 227427 lands this port will end up BROKEN. Can you help?

$ fetch -qo- 'https://reviews.freebsd.org/D15030?download=true' | patch -Efsp0
-d /usr/ports
$ make all deinstall install clean -C/usr/ports/devel/boost-jam
$ make all deinstall install clean -C/usr/ports/devel/boost-libs
$ make all deinstall install clean -C/usr/ports/devel/boost-python-libs
$ make -C/usr/ports/editors/openoffice-4
[...]
basegfx/source/range/b2drangeclipper.cxx:754:40: error: no member named 'prior'
in namespace 'boost'
                    rList.erase(boost::prior(aIter.base())));
                                ~~~~~~~^

build log: https://ptpb.pw/J48y https://ptpb.pw/i8UD
regressed by: https://github.com/boostorg/utility/commit/b74f49f1e56e


Referenced Bugs:

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227427
[Bug 227427] devel/boost-all: Update to 1.67.0
--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

maintainer-feedback requested: [Bug 227553] editors/openoffice-4 editors/openoffice-devel: fails to build with boost 1.67

bugzilla-noreply
Bugzilla Automation <[hidden email]> has asked freebsd-office mailing
list <[hidden email]> for maintainer-feedback:
Bug 227553: editors/openoffice-4 editors/openoffice-devel: fails to build with
boost 1.67
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227553



--- Description ---
After bug 227427 lands this port will end up BROKEN. Can you help?

$ fetch -qo- 'https://reviews.freebsd.org/D15030?download=true' | patch -Efsp0
-d /usr/ports
$ make all deinstall install clean -C/usr/ports/devel/boost-jam
$ make all deinstall install clean -C/usr/ports/devel/boost-libs
$ make all deinstall install clean -C/usr/ports/devel/boost-python-libs
$ make -C/usr/ports/editors/openoffice-4
[...]
basegfx/source/range/b2drangeclipper.cxx:754:40: error: no member named 'prior'
in namespace 'boost'
                    rList.erase(boost::prior(aIter.base())));
                                ~~~~~~~^

build log: https://ptpb.pw/J48y https://ptpb.pw/i8UD
regressed by: https://github.com/boostorg/utility/commit/b74f49f1e56e
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 227553] editors/openoffice-4 and editors/openoffice-devel: fail to build with boost 1.67

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227553

Jan Beich <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|editors/openoffice-4        |editors/openoffice-4 and
                   |editors/openoffice-devel:   |editors/openoffice-devel:
                   |fails to build with boost   |fail to build with boost
                   |1.67                        |1.67

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 227553] editors/openoffice-4 and editors/openoffice-devel: fail to build with boost 1.67

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227553

--- Comment #1 from Pedro F. Giffuni <[hidden email]> ---
(In reply to Jan Beich from comment #0)
The release notes say:
____
Utility:
Breaking change: <boost/utility.hpp> header no longer includes boost::next and
boost::prior as they have been moved to the iterator module. Instead include
<boost/next_prior.hpp>. Other uses of <boost/utility.hpp> are discouraged, it's
better to use the header for the specific functionality instead.

____

So a simple replacement should work.

s a side note: I am not sure how to upstream this since upstream still carries
a very old boost version to accompany the older MSVC compiler.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 227553] editors/openoffice-4 and editors/openoffice-devel: fail to build with boost 1.67

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227553

Don Lewis <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #2 from Don Lewis <[hidden email]> ---
Something like this should work:

#include <boost/version.h>
#if BOOST_VERSION < 106700
#include <boost/utility.hpp>
#else
#include <boost/next_prior.hpp>
#endif

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 227553] editors/openoffice-4 and editors/openoffice-devel: fail to build with boost 1.67

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227553

Don Lewis <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|New                         |In Progress
           Assignee|[hidden email]          |[hidden email]

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"