[Bug 230160] linuxulator doesn't implement madvise(MADV_DONTNEED) and any MADV_ flags with values >= 8 correctly

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Bug 230160] linuxulator doesn't implement madvise(MADV_DONTNEED) and any MADV_ flags with values >= 8 correctly

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=230160

--- Comment #7 from Bill Sorenson <[hidden email]> ---
(In reply to David Chisnall from comment #6)
I'm aware they have different use cases. My main point is that if we are going
to adopt a Linux-MADV_DONTNEED equivalent we use Illumos' MADV_PURGE rather
than invent a new argument.

I don't object to adding MADV_PURGE or MADV_ZERO for Linux compatibility but to
me it seems like it would usually be better to call munmap() directly than to
use some bizarre madvise() semantics to simulate it although admittedly I don't
know the specifics.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-emulation
To unsubscribe, send any mail to "[hidden email]"