[Bug 230494] devel/gdb: Mark BROKEN with Python 3.7.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Bug 230494] devel/gdb: Mark BROKEN with Python 3.7.

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=230494

Kubilay Kocak <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|New                         |Open
              Flags|                            |merge-quarterly?
           Keywords|                            |easy, needs-qa
                 CC|                            |[hidden email],
                   |                            |[hidden email]

--- Comment #2 from Kubilay Kocak <[hidden email]> ---
If gdb (upstream) doesn't yet target/support Python 3.7, the gdb ports should
be set to 'X-3.6' until it does , rather than being set to BROKEN.

Python ports should declare only those versions that the software explicitly
supports.

Granted in most cases most newer versions of Python are backward/forward
compatible, but it pays for maintainers to be as explicit as possible, as often
as possible, without reducing choice.

--
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-python
To unsubscribe, send any mail to "[hidden email]"