[Bug 231273] editors/libreoffice fails to build with Python-2.7

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 231273] editors/libreoffice fails to build with Python-2.7

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=231273

            Bug ID: 231273
           Summary: editors/libreoffice fails to build with Python-2.7
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: [hidden email]
          Reporter: [hidden email]
          Assignee: [hidden email]
             Flags: maintainer-feedback?([hidden email])

The error:

[...]
/spare/usr/ports/editors/libreoffice/work/libreoffice-6.0.5.2/pyuno/source/module/pyuno_util.cxx:45:5:
error: static_assert failed "bad assumption"
    static_assert(sizeof (wchar_t) == Py_UNICODE_SIZE, "bad assumption");
    ^             ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/spare/usr/ports/editors/libreoffice/work/libreoffice-6.0.5.2/pyuno/source/module/pyuno_util.cxx:46:18:
error: no matching function for call to 'PyUnicodeUCS2_FromUnicode'
    ret = PyRef( PyUnicode_FromUnicode( reinterpret_cast<wchar_t const
*>(str.getStr()), str.getLength() ), SAL_NO_ACQUIRE );
                 ^~~~~~~~~~~~~~~~~~~~~
/opt/include/python2.7/unicodeobject.h:196:32: note: expanded from macro
'PyUnicode_FromUnicode'
# define PyUnicode_FromUnicode PyUnicodeUCS2_FromUnicode
                               ^~~~~~~~~~~~~~~~~~~~~~~~~
/opt/include/python2.7/unicodeobject.h:464:23: note: candidate function not
viable: no known conversion from 'const wchar_t *' to 'const Py_UNICODE *' (aka
'const unsigned short *') for 1st argument
PyAPI_FUNC(PyObject*) PyUnicode_FromUnicode(
                      ^
/opt/include/python2.7/unicodeobject.h:196:32: note: expanded from macro
'PyUnicode_FromUnicode'
# define PyUnicode_FromUnicode PyUnicodeUCS2_FromUnicode
                               ^
7 warnings and 2 errors generated.
[...]

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

maintainer-feedback requested: [Bug 231273] editors/libreoffice fails to build with Python-2.7

bugzilla-noreply
Bugzilla Automation <[hidden email]> has asked freebsd-office mailing
list <[hidden email]> for maintainer-feedback:
Bug 231273: editors/libreoffice fails to build with Python-2.7
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=231273



--- Description ---
The error:

[...]
/spare/usr/ports/editors/libreoffice/work/libreoffice-6.0.5.2/pyuno/source/modu
le/pyuno_util.cxx:45:5:
error: static_assert failed "bad assumption"
    static_assert(sizeof (wchar_t) == Py_UNICODE_SIZE, "bad assumption");
    ^  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/spare/usr/ports/editors/libreoffice/work/libreoffice-6.0.5.2/pyuno/source/modu
le/pyuno_util.cxx:46:18:
error: no matching function for call to 'PyUnicodeUCS2_FromUnicode'
    ret = PyRef( PyUnicode_FromUnicode( reinterpret_cast<wchar_t const
*>(str.getStr()), str.getLength() ), SAL_NO_ACQUIRE );
                 ^~~~~~~~~~~~~~~~~~~~~
/opt/include/python2.7/unicodeobject.h:196:32: note: expanded from macro
'PyUnicode_FromUnicode'
# define PyUnicode_FromUnicode PyUnicodeUCS2_FromUnicode
                               ^~~~~~~~~~~~~~~~~~~~~~~~~
/opt/include/python2.7/unicodeobject.h:464:23: note: candidate function not
viable: no known conversion from 'const wchar_t *' to 'const Py_UNICODE *' (aka
'const unsigned short *') for 1st argument
PyAPI_FUNC(PyObject*) PyUnicode_FromUnicode(
                      ^
/opt/include/python2.7/unicodeobject.h:196:32: note: expanded from macro
'PyUnicode_FromUnicode'
# define PyUnicode_FromUnicode PyUnicodeUCS2_FromUnicode
                               ^
7 warnings and 2 errors generated.
[...]
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 231273] editors/libreoffice fails to build with Python-2.7

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=231273

Jan Beich <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Keywords|                            |needs-qa

--- Comment #1 from Jan Beich <[hidden email]> ---
USES=python still defaults to lang/python27, and libreoffice builds fine on the
package cluster. Can you provide more details?

http://beefy5.nyi.freebsd.org/data/104i386-default/479225/logs/libreoffice-6.0.5_4.log
http://beefy6.nyi.freebsd.org/data/104amd64-default/479225/logs/libreoffice-6.0.5_4.log
http://beefy9.nyi.freebsd.org/data/111amd64-default/479225/logs/libreoffice-6.0.5_4.log
http://beefy10.nyi.freebsd.org/data/111i386-default/479225/logs/libreoffice-6.0.5_4.log
http://www.ipv6proxy.net/go.php?u=http://beefy11.nyi.freebsd.org/data/head-i386-default/p479265_s338539/logs/libreoffice-6.0.5_4.log
http://www.ipv6proxy.net/go.php?u=http://beefy12.nyi.freebsd.org/data/head-amd64-default/p479265_s338539/logs/libreoffice-6.0.5_4.log

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 231273] editors/libreoffice fails to build with Python-2.7

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=231273

--- Comment #2 from Mikhail Teterin <[hidden email]> ---
Could it because I have the UCS2 option enabled in lang/python27 -- instead of
UCS4, which is the default?

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"