[Bug 232996] graphics/gimp-app build broken: "../../tools/invert-svg" Segmentation fault

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 232996] graphics/gimp-app build broken: "../../tools/invert-svg" Segmentation fault

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=232996

            Bug ID: 232996
           Summary: graphics/gimp-app build broken:
                    "../../tools/invert-svg" Segmentation fault
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: [hidden email]
          Reporter: [hidden email]
          Assignee: [hidden email]
             Flags: maintainer-feedback?([hidden email])

Created attachment 198982
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=198982&action=edit
1. poudriere testport

The "invert-svg" tool run during creation of Symbolic-Inverted theme segfaults.

As far as I get, this tool is using gegl, and so this crash could be related to
graphics/gegl and openmp:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=232990

Happens for both gegl 0.4.8_1 and 0.4.12.

I made a patch to fix the build by removing that theme.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

maintainer-feedback requested: [Bug 232996] graphics/gimp-app build broken: "../../tools/invert-svg" Segmentation fault

bugzilla-noreply
Bugzilla Automation <[hidden email]> has asked freebsd-gnome mailing list
<[hidden email]> for maintainer-feedback:
Bug 232996: graphics/gimp-app build broken: "../../tools/invert-svg"
Segmentation fault
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=232996



--- Description ---
The "invert-svg" tool run during creation of Symbolic-Inverted theme segfaults.

As far as I get, this tool is using gegl, and so this crash could be related to
graphics/gegl and openmp:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=232990

Happens for both gegl 0.4.8_1 and 0.4.12.

I made a patch to fix the build by removing that theme.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 232996] graphics/gimp-app build broken: "../../tools/invert-svg" Segmentation fault

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=232996

--- Comment #1 from Michael Danilov <[hidden email]> ---
Created attachment 198984
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=198984&action=edit
2. disable Symbolic-Inverted in graphics/gimp-app

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 232996] graphics/gimp-app build broken: "../../tools/invert-svg" Segmentation fault

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=232996

--- Comment #2 from Michael Danilov <[hidden email]> ---
Hey is anyone alive on this bug tracker anymore?

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 232996] graphics/gimp-app build broken: "../../tools/invert-svg" Segmentation fault

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=232996

kunda <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #3 from kunda <[hidden email]> ---
Please test with latest gimp port 2.10.12

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 232996] graphics/gimp-app build broken: "../../tools/invert-svg" Segmentation fault

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=232996

Mark Linimon <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #198984|gimp-app.svndif             |gimp-app.diff
           filename|                            |

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"