[Bug 235277] www/apache24: py36-certbot failing after updating apache24

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 235277] www/apache24: py36-certbot failing after updating apache24

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=235277

            Bug ID: 235277
           Summary: www/apache24: py36-certbot failing after updating
                    apache24
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: [hidden email]
          Reporter: [hidden email]
             Flags: maintainer-feedback?([hidden email])
          Assignee: [hidden email]

Created attachment 201477
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=201477&action=edit
Letsencrypt log file

Name           : apache24
Version        : 2.4.38

Name           : py36-certbot
Version        : 0.30.2_2,1

Name           : py36-certbot-apache
Version        : 0.30.2

uname -a
FreeBSD scorpio.seibercom.net 12.0-RELEASE-p2 FreeBSD 12.0-RELEASE-p2 GENERIC
amd64

freebsd-version
12.0-RELEASE-p2

After updating apache24 on my system, the certbot is now issuing an error when
I attempt to run it either via cron or from the command line. This is the
command line output:


Saving debug log to /var/log/letsencrypt/letsencrypt.log

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Processing /usr/local/etc/letsencrypt/renewal/seibercom.net.conf
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Cert is due for renewal, auto-renewing...
Could not choose appropriate plugin: The apache plugin is not working; there
may be problems with your existing configuration.
The error was: NoInstallationError('Cannot find Apache executable apache2ctl',)
Attempting to renew cert (seibercom.net) from
/usr/local/etc/letsencrypt/renewal/seibercom.net.conf produced an unexpected
error: The apache plugin is not working; there may be problems with your
existing configuration.
The error was: NoInstallationError('Cannot find Apache executable
apache2ctl',). Skipping.
All renewal attempts failed. The following certs could not be renewed:
  /usr/local/etc/letsencrypt/live/seibercom.net/fullchain.pem (failure)

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

All renewal attempts failed. The following certs could not be renewed:
  /usr/local/etc/letsencrypt/live/seibercom.net/fullchain.pem (failure)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1 renew failure(s), 0 parse failure(s)

I have attached the letsencrypt log file. The configuration has been working
correctly for several months, so I am confident that it is correct.

In the "letsencrypt" log, there is an entry:
certbot.errors.NoInstallationError: Cannot find Apache executable apache2ctl
Apparently a file is missing from apache24 that was there before.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-apache
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

maintainer-feedback requested: [Bug 235277] www/apache24: py36-certbot failing after updating apache24

bugzilla-noreply
Bugzilla Automation <[hidden email]> has asked freebsd-apache mailing
list <[hidden email]> for maintainer-feedback:
Bug 235277: www/apache24: py36-certbot failing after updating apache24
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=235277



--- Description ---
Name       : apache24
Version        : 2.4.38

Name       : py36-certbot
Version        : 0.30.2_2,1

Name       : py36-certbot-apache
Version        : 0.30.2

uname -a
FreeBSD scorpio.seibercom.net 12.0-RELEASE-p2 FreeBSD 12.0-RELEASE-p2 GENERIC
amd64

freebsd-version
12.0-RELEASE-p2

After updating apache24 on my system, the certbot is now issuing an error when
I attempt to run it either via cron or from the command line. This is the
command line output:


Saving debug log to /var/log/letsencrypt/letsencrypt.log

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Processing /usr/local/etc/letsencrypt/renewal/seibercom.net.conf
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Cert is due for renewal, auto-renewing...
Could not choose appropriate plugin: The apache plugin is not working; there
may be problems with your existing configuration.
The error was: NoInstallationError('Cannot find Apache executable apache2ctl',)
Attempting to renew cert (seibercom.net) from
/usr/local/etc/letsencrypt/renewal/seibercom.net.conf produced an unexpected
error: The apache plugin is not working; there may be problems with your
existing configuration.
The error was: NoInstallationError('Cannot find Apache executable
apache2ctl',). Skipping.
All renewal attempts failed. The following certs could not be renewed:
  /usr/local/etc/letsencrypt/live/seibercom.net/fullchain.pem (failure)

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

All renewal attempts failed. The following certs could not be renewed:
  /usr/local/etc/letsencrypt/live/seibercom.net/fullchain.pem (failure)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1 renew failure(s), 0 parse failure(s)

I have attached the letsencrypt log file. The configuration has been working
correctly for several months, so I am confident that it is correct.

In the "letsencrypt" log, there is an entry:
certbot.errors.NoInstallationError: Cannot find Apache executable apache2ctl
Apparently a file is missing from apache24 that was there before.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-apache
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 235277] www/apache24: py36-certbot failing after updating apache24

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=235277

Jochen Neumeister <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Assignee|[hidden email]          |[hidden email]
                 CC|                            |[hidden email]

--- Comment #1 from Jochen Neumeister <[hidden email]> ---
Give the PR to python@

The Port needs a replace for /usr/bin/apache2ctl

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-apache
To unsubscribe, send any mail to "[hidden email]"