[Bug 235863] file loss when adding faulty entry in a jail's /etc/fstab.foo after removing jail

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Bug 235863] file loss when adding faulty entry in a jail's /etc/fstab.foo after removing jail

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=235863

--- Comment #1 from leaveemptyfordefault <[hidden email]> ---
Follow up: reproducing the original bug, I am now able to do a recovery.
In both original bug report and this follow-up, zfs was used.
Using the same /etc/jail.conf, and a similar /etc/fstab.foo,
getting the zfs fileset lost again, here's how it can be recovered:

# mkdir /recovery                                  # an arbitrary recovery dir
# zfs set mountpoint=/recovery  zroot/j/foo.d
# cd /recovery
# ls
#                                                  # nothing recovered
# zfs set mountpoint="legacy" zroot/j/foo.d        # possibly a needed step
# zfs list | grep foo
zroot/j/foo.d   71.7M   428M  71.7M  legacy        # zfs still lists usage
# zfs set mountpoint="/zroot/j/foo.d" zroot/j/foo.d  #point zfs to org
mountpoint
# cd /zroot/j/foo.d
# ls -1
foo.etc   foo.root  foo.homedir   foo.tmp          # files recovered

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-jail
To unsubscribe, send any mail to "[hidden email]"