[Bug 235999] www/chromium: Make java optional in version 72.0.3626.119 and later

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 235999] www/chromium: Make java optional in version 72.0.3626.119 and later

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=235999

            Bug ID: 235999
           Summary: www/chromium: Make java optional in version
                    72.0.3626.119 and later
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Some People
          Priority: ---
         Component: Individual Port(s)
          Assignee: [hidden email]
          Reporter: [hidden email]
          Assignee: [hidden email]
             Flags: maintainer-feedback?([hidden email])

After update to 72.0.3626.119 chromium started requiring java/openjdk8 which
unconditionally require print/cups. This make chromium's config option CUPS
irrelevant. It would be nice to have java dependency optional for people who
don't want "better javascript with java".

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

maintainer-feedback requested: [Bug 235999] www/chromium: Make java optional in version 72.0.3626.119 and later

bugzilla-noreply
Bugzilla Automation <[hidden email]> has asked freebsd-chromium mailing
list <[hidden email]> for maintainer-feedback:
Bug 235999: www/chromium: Make java optional in version 72.0.3626.119 and later
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=235999



--- Description ---
After update to 72.0.3626.119 chromium started requiring java/openjdk8 which
unconditionally require print/cups. This make chromium's config option CUPS
irrelevant. It would be nice to have java dependency optional for people who
don't want "better javascript with java".
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 235999] www/chromium: Make java optional in version 72.0.3626.119 and later

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=235999

Oleh Hushchenkov <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Severity|Affects Some People         |Affects Only Me

--- Comment #1 from Oleh Hushchenkov <[hidden email]> ---
Ok, as I see it's build dependencies. But, however, it would be nice to have
java dependency optional. Or even better avoid it completely.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 235999] www/chromium: Make java optional in version 72.0.3626.119 and later

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=235999

Carlos J. Puga Medina <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #2 from Carlos J. Puga Medina <[hidden email]> ---
That's not possible because now chromium needs openjdk8 dependency to build.
Chromium uses f'in Java to use the closure compiler which creates "better
javascript".

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 235999] www/chromium: Make java optional in version 72.0.3626.119 and later

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=235999

Oleh Hushchenkov <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|New                         |Closed
         Resolution|---                         |Works As Intended

--- Comment #3 from Oleh Hushchenkov <[hidden email]> ---
I see. Upstream is upstream.

Thanks for clarifying!

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"