[Bug 237168] audio/mumble and audio/audacity open record sound device second time error

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 237168] audio/mumble and audio/audacity open record sound device second time error

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=237168

            Bug ID: 237168
           Summary: audio/mumble and audio/audacity open record sound
                    device second time error
           Product: Ports & Packages
           Version: Latest
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Some People
          Priority: ---
         Component: Individual Port(s)
          Assignee: [hidden email]
          Reporter: [hidden email]
                CC: [hidden email], [hidden email]
                CC: [hidden email], [hidden email]

I didn't found a report so i write my first my first here.

Reference:

https://github.com/mumble-voip/mumble/issues/3278

Explanation:

If a audio Program with playing and recording at once works until the same
record device is opened a second time. The playing device works but the
recording device not.

In audio/mumble the device could be opened second time if just open Preferences
change some things and push the apply or OK button.

I know i write that bug in "Ports & Packages" but i believe it has nothing to
do with that packages and it is a Sound-server bug. I use audio/mumble heavily
and i did discovered that audio/audacity has the same bug so that's why i think
its a Sound-Server (OSS) bug.

Workaround:

I got to workaround that issue with using audio/jack & audio/qjackctl. That way
the bug is pushed away to jack so that jack got the problem and not the used
program in that case audio/mumble or others. I know that the audio program has
to support jack but it works that way for me. Jack has some nice routing
abilities.

audio/jack support in FreeBSD seems to be disabled by default in other ports so
it has to be enabled while building the port.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-ports-bugs
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 237168] audio/mumble and audio/audacity open record sound device second time error

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=237168

Chris W. <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                URL|                            |https://github.com/mumble-v
                   |                            |oip/mumble/issues/3278

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-ports-bugs
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 237168] audio/mumble and audio/audacity open record sound device second time error

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=237168

VVD <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #1 from VVD <[hidden email]> ---
(In reply to Chris W. from comment #0)
Check 1.3.0 release: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=240402

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-ports-bugs
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 237168] audio/mumble and audio/audacity open record sound device second time error

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=237168

--- Comment #2 from Chris W. <[hidden email]> ---
(In reply to VVD from comment #1)

Thankyou.

I have it running with audio/jack and audio/qjackctl.
With that i can workaround this bug.

I think that it is a basesys sound problem. I am no expert in this but maybe it
is not OSS4 in mumble? The Linux people no longer want to support OSS.

Anyway i use JACK and works for me.

I don't know how it works with other audio software, but my focus is on mumble.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-ports-bugs
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 237168] audio/mumble and audio/audacity open record sound device second time error

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=237168

--- Comment #3 from VVD <[hidden email]> ---
My patch have JACK option.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-ports-bugs
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 237168] audio/mumble and audio/audacity open record sound device second time error

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=237168

--- Comment #4 from Chris W. <[hidden email]> ---
(In reply to VVD from comment #3)

Yeah, i have tested your patch.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-ports-bugs
To unsubscribe, send any mail to "[hidden email]"