[Bug 241104] rubygem-sassc package problem

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 241104] rubygem-sassc package problem

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=241104

            Bug ID: 241104
           Summary: rubygem-sassc package problem
           Product: Ports & Packages
           Version: Latest
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: [hidden email]
          Reporter: [hidden email]
                CC: [hidden email]

Created attachment 208143
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=208143&action=edit
original error output

Hi,

I think that something wrong with creating package of rubygem-sassc port.
Originally I run into troubles with GitLab (unicorn, to be exact) which ceased
to launch after update (I use packages). Unicorn's log says (full outout of
this error in the attachment):

/usr/local/lib/ruby/gems/2.6/gems/ffi-1.11.1/lib/ffi/library.rb:112: [BUG]
Illegal instruction at 0x000000080c9890ff
ruby 2.6.5p114 (2019-10-01 revision 67812) [amd64-freebsd12]

After some investigation and googling I found out that error happens on trying
to open libsass.so library (by dlopen call, as I understand) and did some
experiments.

At firts, I checked it with dltest:

# dltest /usr/local/lib/ruby/gems/2.6/gems/sassc-2.2.1/lib/sassc/libsass.so
Illegal instruction (core dumped)

Then I reinstalled rubygem-sassc from port and check it again:

# dltest /usr/local/lib/ruby/gems/2.6/gems/sassc-2.2.1/lib/sassc/libsass.so
SUCCESS: Loaded
/usr/local/lib/ruby/gems/2.6/gems/sassc-2.2.1/lib/sassc/libsass.so

GitLab launched correctly and work without errors after this.

After that I saved "good" libsass.so, reinstalled rubygem-sassc as package
again and tryed to launch GitLab - without success. Then I replaced original
libsass.so by previously saved and tryed to launch GitLab again - it launched
an worked correctly.

My system:

# uname -a
FreeBSD felix 12.0-RELEASE-p10 FreeBSD 12.0-RELEASE-p10 r353051 MYKERNEL  amd64

# cat /usr/local/etc/pkg/repos/FreeBSD.conf
FreeBSD: {
  url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest"
}

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-ports-bugs
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 241104] textproc/rubygem-sassc package problem

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=241104

Walter Schwarzenfeld <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]
           Assignee|[hidden email]      |[hidden email]
              Flags|                            |maintainer-feedback?(sunpoe
                   |                            |[hidden email])
             Status|New                         |Open
            Summary|rubygem-sassc package       |textproc/rubygem-sassc
                   |problem                     |package problem

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-ports-bugs
To unsubscribe, send any mail to "[hidden email]"