[Bug 242467] security/libpwquality: update to 1.4.2 (and more)

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 242467] security/libpwquality: update to 1.4.2 (and more)

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242467

            Bug ID: 242467
           Summary: security/libpwquality: update to 1.4.2 (and more)
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: [hidden email]
          Reporter: [hidden email]
          Assignee: [hidden email]
             Flags: maintainer-feedback?([hidden email])

Created attachment 209745
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=209745&action=edit
Update to 1.4.2 (and more)

1.4.2 is available for a while now.  Excerpt from NEWS:

- Release 1.4.2 (10/31/2019)

* Fix regression in handling retry, enforce_for_root, and
  local_users_only options introduced with the previous
  release.

- Release 1.4.1 (9/17/2019)

* pam_pwquality: Abort the retry loop if user requests it.
* Allow setting retry, enforce_for_root, and local_users_only options
  in the pwquality.conf config file.
* Fix uninitialized memory in word distance calculations.
* Fix possible one byte buffer underflow when parsing the config file.
* Return default cracklib dictionary path if not overriden.
* Update translations from Zanata.

While I am at it, I added LICENSE stuff and OPTIONized NLS.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

maintainer-feedback requested: [Bug 242467] security/libpwquality: update to 1.4.2 (and more)

bugzilla-noreply
Bugzilla Automation <[hidden email]> has asked freebsd-gnome mailing list
<[hidden email]> for maintainer-feedback:
Bug 242467: security/libpwquality: update to 1.4.2 (and more)
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242467



--- Description ---
1.4.2 is available for a while now.  Excerpt from NEWS:

- Release 1.4.2 (10/31/2019)

* Fix regression in handling retry, enforce_for_root, and
  local_users_only options introduced with the previous
  release.

- Release 1.4.1 (9/17/2019)

* pam_pwquality: Abort the retry loop if user requests it.
* Allow setting retry, enforce_for_root, and local_users_only options
  in the pwquality.conf config file.
* Fix uninitialized memory in word distance calculations.
* Fix possible one byte buffer underflow when parsing the config file.
* Return default cracklib dictionary path if not overriden.
* Update translations from Zanata.

While I am at it, I added LICENSE stuff and OPTIONized NLS.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 242467] security/libpwquality: update to 1.4.2 (and more)

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242467

--- Comment #1 from Ting-Wei Lan <[hidden email]> ---
Comment on attachment 209745
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=209745
Update to 1.4.2 (and more)


>+LICENSE= GPLv2+ LIBPWQUALITY
>+LICENSE_COMB= dual
>+LICENSE_NAME_LIBPWQUALITY= The libpwquality license
>+LICENSE_FILE_LIBPWQUALITY= ${WRKSRC}/COPYING
>+LICENSE_PERMS_LIBPWQUALITY= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept

The libpwquality license of looks like BSD 3-clause license. Why it is marked
as no-dist-sell and no-pkg-sell?

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 242467] security/libpwquality: update to 1.4.2 (and more)

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242467

--- Comment #2 from Jung-uk Kim <[hidden email]> ---
(In reply to Ting-Wei Lan from comment #1)
Oops, copy-and-pasto.  Will fix.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 242467] security/libpwquality: update to 1.4.2 (and more)

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242467

Jung-uk Kim <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #209745|0                           |1
        is obsolete|                            |

--- Comment #3 from Jung-uk Kim <[hidden email]> ---
Created attachment 209803
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=209803&action=edit
Update to 1.4.2 and more (v2)

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 242467] security/libpwquality: update to 1.4.2 (and more)

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242467

--- Comment #4 from Ting-Wei Lan <[hidden email]> ---
Comment on attachment 209803
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=209803
Update to 1.4.2 and more (v2)

>+LICENSE= GPLv2+ LIBPWQUALITY
>+LICENSE_COMB= dual
>+LICENSE_NAME_LIBPWQUALITY= The libpwquality license
>+LICENSE_FILE_LIBPWQUALITY= ${WRKSRC}/COPYING
>+LICENSE_PERMS_LIBPWQUALITY= dist-mirror pkg-mirror auto-accept

Removing no-dist-sell and no-pkg-sell changes nothing. Not listing a permission
means it is disallowed. I think you have to add dist-sell and pkg-sell to the
list.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 242467] security/libpwquality: update to 1.4.2 (and more)

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242467

Jung-uk Kim <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #209803|0                           |1
        is obsolete|                            |

--- Comment #5 from Jung-uk Kim <[hidden email]> ---
Created attachment 209879
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=209879&action=edit
Update to 1.4.2 and more (v3)

(In reply to Ting-Wei Lan from comment #4)
Done.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 242467] security/libpwquality: update to 1.4.2 (and more)

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242467

Ting-Wei Lan <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #6 from Ting-Wei Lan <[hidden email]> ---
Comment on attachment 209879
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=209879
Update to 1.4.2 and more (v3)

The license permissions looks correct now.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 242467] security/libpwquality: update to 1.4.2 (and more)

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242467

--- Comment #7 from Jung-uk Kim <[hidden email]> ---
Ping...  Any thoughts?

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 242467] security/libpwquality: update to 1.4.2 (and more)

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242467

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |daniel.engberg.lists@pyret.
                   |                            |net, [hidden email]

--- Comment #8 from [hidden email] ---
Koop, is this something you can have a look at?

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 242467] security/libpwquality: update to 1.4.2 (and more)

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242467

--- Comment #9 from [hidden email] ---
Poudriere testport OK 12.1-RELEASE (AMD64)

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 242467] security/libpwquality: update to 1.4.2 (and more)

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242467

Li-Wen Hsu <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|New                         |Closed
         Resolution|---                         |FIXED
                 CC|                            |[hidden email]

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 242467] security/libpwquality: update to 1.4.2 (and more)

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242467

--- Comment #10 from [hidden email] ---
A commit references this bug:

Author: lwhsu
Date: Wed Jul  1 13:28:12 UTC 2020
New revision: 540960
URL: https://svnweb.freebsd.org/changeset/ports/540960

Log:
  Update to 1.4.2

  Added LICENSE stuff and OPTIONized NLS.

  PR:           242467
  Submitted by: jkim

Changes:
  head/security/libpwquality/Makefile
  head/security/libpwquality/distinfo
  head/security/libpwquality/pkg-plist

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"