[Bug 247444] editors/libreoffice 6.4.4 print output garbled

classic Classic list List threaded Threaded
51 messages Options
123
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice 6.4.4 print output garbled

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

            Bug ID: 247444
           Summary: editors/libreoffice 6.4.4 print output garbled
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: [hidden email]
          Reporter: [hidden email]
             Flags: maintainer-feedback?([hidden email])
          Assignee: [hidden email]

Created attachment 215824
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=215824&action=edit
printout example

12.1-STABLE r362185 GENERIC  amd64
libreoffice-6.4.4_2 built from ports, all ports updated May 19
cups-2.2.13
cups-filters-1.27.5
cups-pdf-3.0.1

LANGUAGE=
LC_CTYPE=sv_SE.UTF-8

OPTIONS_FILE_SET+=CUPS
OPTIONS_FILE_UNSET+=DOCS
OPTIONS_FILE_UNSET+=GNOME
OPTIONS_FILE_UNSET+=GTK3
OPTIONS_FILE_SET+=JAVA
OPTIONS_FILE_SET+=KF5
OPTIONS_FILE_SET+=MMEDIA
OPTIONS_FILE_UNSET+=PGSQL
OPTIONS_FILE_SET+=QT5
OPTIONS_FILE_UNSET+=SDK
OPTIONS_FILE_SET+=TEST
OPTIONS_FILE_SET+=WEBDAV

Since update from 6.3.4_5, output is just a few characters in random places
over the printed page.

Regardless of printer type
Export to pdf produces a blank page
Printing from other apps is fine

Did,
portmaster -d -f -t /usr/ports/editors/libreoffice
ie. rebuilt all dependencies from sctratch just to make sure there was not any
problems there.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

maintainer-feedback requested: [Bug 247444] editors/libreoffice 6.4.4 print output garbled

bugzilla-noreply
Bugzilla Automation <[hidden email]> has asked freebsd-office mailing
list <[hidden email]> for maintainer-feedback:
Bug 247444: editors/libreoffice 6.4.4 print output garbled
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444



--- Description ---
12.1-STABLE r362185 GENERIC  amd64
libreoffice-6.4.4_2 built from ports, all ports updated May 19
cups-2.2.13
cups-filters-1.27.5
cups-pdf-3.0.1

LANGUAGE=
LC_CTYPE=sv_SE.UTF-8

OPTIONS_FILE_SET+=CUPS
OPTIONS_FILE_UNSET+=DOCS
OPTIONS_FILE_UNSET+=GNOME
OPTIONS_FILE_UNSET+=GTK3
OPTIONS_FILE_SET+=JAVA
OPTIONS_FILE_SET+=KF5
OPTIONS_FILE_SET+=MMEDIA
OPTIONS_FILE_UNSET+=PGSQL
OPTIONS_FILE_SET+=QT5
OPTIONS_FILE_UNSET+=SDK
OPTIONS_FILE_SET+=TEST
OPTIONS_FILE_SET+=WEBDAV

Since update from 6.3.4_5, output is just a few characters in random places
over the printed page.

Regardless of printer type
Export to pdf produces a blank page
Printing from other apps is fine

Did,
portmaster -d -f -t /usr/ports/editors/libreoffice
ie. rebuilt all dependencies from sctratch just to make sure there was not any
problems there.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

Lewis Cook <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|editors/libreoffice 6.4.4   |editors/libreoffice:
                   |print output garbled        |Erroneous print output in
                   |                            |6.4.4
             Status|New                         |Open
           Keywords|                            |needs-qa
                 CC|                            |[hidden email]

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

--- Comment #1 from Rainer Hurling <[hidden email]> ---
Same problem on 13.0-CURRENT amd64 r362466.

LANG=de_DE.UTF-8
LC_CTYPE=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
LC_COLLATE=C
LC_NUMERIC=de_DE.UTF-8
LC_MONETARY=de_DE.UTF-8


Ports options are:

CUPS=on: CUPS printing system support
DOCS=on: Build and/or install documentation
GNOME=off: GNOME desktop environment support
GTK3=off: GTK+ 3 GUI toolkit support (broken visual style)
JAVA=on: Add Java support (XML filters, macros, DB connections)
KF5=on: KF5/Qt5 GUI toolkit support (implies QT5)
MMEDIA=off: Enable multimedia backend for Impress
PGSQL=off: Build with PostgreSQL-SDBC driver
QT5=on: Qt5 GUI toolkit support (default visual style)
SDK=off: Build with SDK
TEST=off: Run all regression tests
WEBDAV=off: Enable WebDAV protocol

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

Dima Panov <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #2 from Dima Panov <[hidden email]> ---
Created attachment 215858
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=215858&action=edit
export to pdf

Folks, cannot reproduce with poudriere-built packages:(

LANG=ru_RU.UTF-8

Export to pdf produce a valid file
Print to pdf is also fine.

cups-2.2.13                    Common UNIX Printing System
cups-filters-1.27.4_1          Additional backends, filters and other software
for CUPS
cups-pdf-3.0.1                 Virtual printer for CUPS to produce PDF files

Name           : libreoffice
Version        : 6.4.4
Installed on   : Mon Jun 22 05:28:01 2020 +10
Architecture   : FreeBSD:12:amd64
Options        :
        CUPS           : on
        DOCS           : off
        GNOME          : off
        GTK3           : off
        JAVA           : on
        KF5            : on
        MMEDIA         : on
        PGSQL          : off
        QT5            : on
        SDK            : off
        TEST           : off
        WEBDAV         : on

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

Lewis Cook <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #3 from Lewis Cook <[hidden email]> ---
*** Bug 247479 has been marked as a duplicate of this bug. ***

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

--- Comment #4 from [hidden email] ---
I DO have the same issue -- both with locally built 6.4.4 and with official
package 6.4.4.2.
My local packages are ALL from my local repository built with Synth. Very
unlikely that it missed any dependencies.

The official pre-built packages, for the purity of experiment, are all
installed into a separate clean installation, for a newly created user, using
`pkg install` from repo. Missing dependencies are also unlikely, as well as
possible "foreign" user settings.

I must add that PS printing works all right. So, going to Tools > Options >
Print and unchecking the box for 'using PDF as default job format' creates
valid PS output.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

--- Comment #5 from [hidden email] ---
(In reply to Dima Panov from comment #2)
Do you mean creating your PDF files using CUPS-PDF?
I'm talking about creating PDF files using PDF icon in libreoffice interface.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

--- Comment #6 from [hidden email] ---
Oh, and this problem seems to only concern the text. While exporting to PDF
graphics and tables are exported all right. Only text is missing.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

--- Comment #7 from Dima Panov <[hidden email]> ---
(In reply to bergerkos from comment #5)
nope, I meant "export as pdf" -- button and via menu
same for print -- print to file - as pdf

as u can see on screenshot -- text is not garbled, all cyrillic and latin chars
on place

I have an idea. Try to set a global MM_CHARSET=UTF-8 for profile.

my ~/.login_conf:

me:\
        :charset=UTF-8:\
        :lang=en_GB.UTF-8:\
        :tc=default:

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

--- Comment #8 from [hidden email] ---
(In reply to Dima Panov from comment #7)
Unfortunately, this doesn't change anything.

Now I wonder which poppler version you are using. Maybe it's different from
mine? And it's poppler that's responsible for PDF rendering, isn't it.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

rob2g2 <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #9 from rob2g2 <[hidden email]> ---
same problem here on 12.1, installed via pkg (latest). Export to PDF or print
to file produces a small file without any text, tables are present.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

Jason W. Bacon <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #10 from Jason W. Bacon <[hidden email]> ---
My attempts to print to laserjet, print to PDF, or export to PDF all produce
blank pages.  Exporting to PNG works fine.

Running libreoffice from a terminal doesn't produce much output, but here it
is:

FreeBSD coral.acadix  bacon ~ 1003: libreoffice
MESA-LOADER: failed to retrieve device information
QKqueueFileSystemWatcherEngine::addPaths: open: No such file or directory

Everything installed via latest packages

FreeBSD coral.acadix.biz 12.1-RELEASE-p6 FreeBSD 12.1-RELEASE-p6 GENERIC  amd64

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

[hidden email] changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #11 from [hidden email] ---
I have the same issue, using 12-stable r360999 latest ports tree, built on
poudriere. same problem exists on a fresh 12.1-R-p6 with quarterly packages.

Make a txt file, allow it to be saved in the default odt format, click the PDF
button to export to PDF, a file is created but with no text. If you do the same
with a textfile a couple of pages long, the empty PDF will also be a couple of
pages long.

The system views PDF files not created with libreoffice just fine. On another
machine (linux mint 18.04) this has libreoffice5 and it exports to PDF fine.

I think it's a libreoffice6 problem as libreoffice has always been able to
export to PDF (and epub) natively.

It's been reported affecting ubuntu 20.04 and derivatives as well:

https://ask.libreoffice.org/en/question/242188/cannot-print-anything-exporting-to-pdf-produces-blank-pdf-lubuntu-2004/

https://ask.libreoffice.org/en/question/241673/export-or-print-to-pdf-no-text/

the fix there seems to be to purge then reinstall, that infers ubuntu have
updated their libreoffice package. How new is the libreoffice6 in ports?

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

--- Comment #12 from [hidden email] ---
seems the problem started ahppening after the upgrade 6.3.6_1 -> 6.4.4

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

Tijl Coosemans <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #13 from Tijl Coosemans <[hidden email]> ---
What desktop are you using and what VCL is libreoffice using (Help->About
Libreoffice)?

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

--- Comment #14 from [hidden email] ---
xfce4-wm-4.14.2
+ a lot of Qt5/KDE stuff

Version: 6.4.4.2
Build ID: FreeBSD ports 6.4.4
CPU threads: 12; OS: FreeBSD 12.1; UI render: default; VCL: qt5;
Locale: sv-SE (sv_SE.UTF-8); UI-Language: en-US
Calc: threaded

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

--- Comment #15 from Tijl Coosemans <[hidden email]> ---
What is the output of "env | grep DESKTOP" and "env | grep SAL"?

Try one of the following:

env SAL_USE_VCLPLUGIN=gen libreoffice
env SAL_USE_VCLPLUGIN=kf5 libreoffice

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

--- Comment #16 from [hidden email] ---
DESKTOP_SESSION=xfce
XDG_CURRENT_DESKTOP=XFCE

env SAL_USE_VCLPLUGIN=gen libreoffice
env SAL_USE_VCLPLUGIN=kf5 libreoffice

Both produces a correct pdf

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247444] editors/libreoffice: Erroneous print output in 6.4.4

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444

--- Comment #17 from [hidden email] ---
(In reply to Tijl Coosemans from comment #13)
Hi,

I'm using windowmaker-0.95.8_2 and the VCL is qt5 (qt5-core is 5.14.2_3)

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
123