[Bug 247868] x11-toolkits/gtk30: wrong atk version?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 247868] x11-toolkits/gtk30: wrong atk version?

bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247868

            Bug ID: 247868
           Summary: x11-toolkits/gtk30: wrong atk version?
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: [hidden email]
          Reporter: [hidden email]
          Assignee: [hidden email]
             Flags: maintainer-feedback?([hidden email])

I don't know where the problem is, I'm trying to build games/veloren and it
fails:

Caused by:
  process didn't exit successfully:
`/usr/ports/games/veloren/work/target/release/build/gtk-sys-ce5fecb6dcc1a8c4/build-script-build`
(exit code: 1)
--- stderr
`"pkg-config" "--libs" "--cflags" "gtk+-3.0" "gtk+-3.0 >= 3.4"` did not exit
successfully: exit code: 1
--- stdout


--- stderr
Package dependency requirement 'atk >= 2.33.3' could not be satisfied.
Package 'atk' has version '2.28.1', required version is '>= 2.33.3'
Package dependency requirement 'atk >= 2.33.3' could not be satisfied.
Package 'atk' has version '2.28.1', required version is '>= 2.33.3'

pkg info | grep atk
at-spi2-atk-2.34.2             Assisted Technology Provider module for GTK+
atk-2.28.1                     GNOME accessibility toolkit (ATK)


maybe dep in gnome.mk needs to be changed:
atk_LIB_DEPENDS=        libatk-1.0.so:accessibility/atk

libatk-1.0.so.0.22810.1 (atk 2.28) vs libatk-1.0.so.0.23609.1 (atk 2.36)

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

maintainer-feedback requested: [Bug 247868] x11-toolkits/gtk30: wrong atk version?

bugzilla-noreply
Bugzilla Automation <[hidden email]> has asked freebsd-gnome (Nobody)
<[hidden email]> for maintainer-feedback:
Bug 247868: x11-toolkits/gtk30: wrong atk version?
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247868



--- Description ---
I don't know where the problem is, I'm trying to build games/veloren and it
fails:

Caused by:
  process didn't exit successfully:
`/usr/ports/games/veloren/work/target/release/build/gtk-sys-ce5fecb6dcc1a8c4/bu
ild-script-build`
(exit code: 1)
--- stderr
`"pkg-config" "--libs" "--cflags" "gtk+-3.0" "gtk+-3.0 >= 3.4"` did not exit
successfully: exit code: 1
--- stdout


--- stderr
Package dependency requirement 'atk >= 2.33.3' could not be satisfied.
Package 'atk' has version '2.28.1', required version is '>= 2.33.3'
Package dependency requirement 'atk >= 2.33.3' could not be satisfied.
Package 'atk' has version '2.28.1', required version is '>= 2.33.3'

pkg info | grep atk
at-spi2-atk-2.34.2       Assisted Technology Provider module for GTK+
atk-2.28.1       GNOME accessibility toolkit (ATK)


maybe dep in gnome.mk needs to be changed:
atk_LIB_DEPENDS= libatk-1.0.so:accessibility/atk

libatk-1.0.so.0.22810.1 (atk 2.28) vs libatk-1.0.so.0.23609.1 (atk 2.36)
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247868] x11-toolkits/gtk30: wrong atk version?

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247868

--- Comment #1 from Jan Beich <[hidden email]> ---
(In reply to Mikael Urankar from comment #0)
> atk-2.28.1                     GNOME accessibility toolkit (ATK)

Did you upgrade after ports r538495? veloren-0.6 built fine[1] with atk-2.28
but after ports r541028 even /quarterly has atk-2.36.

[1]
http://beefy6.nyi.freebsd.org/data/latest-per-pkg/veloren/0.6.0/121amd64-default.log

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247868] x11-toolkits/gtk30: wrong atk version?

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247868

--- Comment #2 from Mikael Urankar <[hidden email]> ---
(In reply to Jan Beich from comment #1)
I'm at Revision: 541740, I don't upgrade my packages very often, only when the
ports infrastructure tell me to do so which was not the case here.
It's on aarch64 fwiw.

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

[Bug 247868] x11-toolkits/gtk30: wrong atk version?

bugzilla-noreply
In reply to this post by bugzilla-noreply
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247868

Mikael Urankar <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|New                         |Closed
         Resolution|---                         |Works As Intended

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"