Build fails for xchat during configure

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Build fails for xchat during configure

Kashif Shah
HI Gnome Maintainer,

I received the following configuration error when attempting to build xchat
from ports.  Attached is the config log requested and list of installed
packages.

Best regards,
Kashif

configure: error: Package requirements (atk >= 2.15.4) were not met:

Package dependency requirement 'atk >= 2.15.4' could not be satisfied.
Package 'atk' has version '2.14.0', required version is '>= 2.15.4'

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables ATK_CFLAGS
and ATK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
===>  Script "configure" failed unexpectedly.
Please report the problem to [hidden email] [maintainer] and attach the
"/usr/ports/accessibility/at-spi2-atk/work/at-spi2-atk-2.16.0/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"

installed-packages.txt (85K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Build fails for xchat during configure

Koop Mast-2
On Sun, 2015-08-16 at 12:38 -0500, Kashif Shah wrote:

> HI Gnome Maintainer,
>
> I received the following configuration error when attempting to build
> xchat
> from ports.  Attached is the config log requested and list of
> installed
> packages.
>
> Best regards,
> Kashif

Hi,

The config.log attachement didn't make it, but this point to that your
installed ports are too old. You can use portmaster to upgrade them or
use the pkg tool to upgrade your installed ports with binary packages.

-Koop


> configure: error: Package requirements (atk >= 2.15.4) were not met:
>
> Package dependency requirement 'atk >= 2.15.4' could not be
> satisfied.
> Package 'atk' has version '2.14.0', required version is '>= 2.15.4'
>
> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> installed software in a non-standard prefix.
>
> Alternatively, you may set the environment variables ATK_CFLAGS
> and ATK_LIBS to avoid the need to call pkg-config.
> See the pkg-config man page for more details.
> ===>  Script "configure" failed unexpectedly.
> Please report the problem to [hidden email] [maintainer] and
> attach the
> "/usr/ports/accessibility/at-spi2-atk/work/at-spi2-atk
> -2.16.0/config.log"
> including the output of the failure of your make command. Also, it
> might be
> a good idea to provide an overview of all packages installed on your
> system
> (e.g. a /usr/local/sbin/pkg-static info -g -Ea).
> *** Error code 1
> _______________________________________________
> [hidden email] mailing list
> https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
> To unsubscribe, send any mail to "
> [hidden email]"

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"