Can not get BeoPlay A1 speaker to pair properly

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Can not get BeoPlay A1 speaker to pair properly

thomas masper
Hello list,

I'm trying to get a BeoPlay A1 speaker working in A2DP mode as
described in the following freebsd bug:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203745

The issue I'm facing is that the speaker seems not to pair correctly,
I switch on the device, put it in pair mode (the blue LED start
blinking) then I'm running the script published at
https://reviews.freebsd.org/D3778
to perform the pairing process.

Content of /etc/bluetooth/hcsecd.conf:

device {
             bdaddr 00:12:6f:b9:db:66;
             name "Beoplay A1";
             key nokey;
             pin nopin;
}

The script run without error but the blue LED on the speaker go on
blinking (when pairing with iPhone after the pairing is done the LED
immediately turn white color and stop blinking and the speaker emit a
short beep).
I used the same script to pair a mouse and a keyboard and pairing got
successful.

I also tried to follow the instruction in the freebsd handbook (30.5.
Bluetooth) with the same result, no pairing.
I tried with several PIN ("0000", "1234") but also this result with no pairing.

I have hcidump file (both -x and -R) recorded during the script
execution if needed.

I'm running
FreeBSD 12.0-CURRENT #1 r323445M: Mon Sep 11 19:53:14 CEST 2017
/usr/obj/usr/src/sys/GENERIC  amd64

The speaker works fine in Linux.

Regards,

thomas masper
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-bluetooth
To unsubscribe, send any mail to "[hidden email]"