Eclipse 4.5 (Mars) on FreeBSD.

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Eclipse 4.5 (Mars) on FreeBSD.

Achilleas Mantzios
Hello, fellow BSD'ers,

I have seen this : https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203689
Have there been any news on this? Anyone tried the submitted patch?

--
Achilleas Mantzios
IT DEV Lead
IT DEPT
Dynacom Tankers Mgmt

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-eclipse
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse 4.5 (Mars) on FreeBSD.

Michael Zhilin
Hi,

I haven't tried yet, because eclipse returns error:

[mizhka@gidrarium ~]$ eclipse

(<unknown>:14193): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x
and GTK+ 3 in the same process is not supported
[mizhka@gidrarium ~]$ pkg info eclipse
eclipse-4.5
Name           : eclipse
Version        : 4.5
Installed on   : Wed Nov 11 18:54:02 MSK 2015
Origin         : java/eclipse
Architecture   : freebsd:10:x86:64
Prefix         : /usr/local
Categories     : devel java
Licenses       : EPL
Maintainer     : [hidden email]
WWW            : http://www.eclipse.org/
Comment        : Eclipse Mars
Options        :
FULL_SDK       : on
PLATFORM       : off
PLATFORM_SDK   : off
SWT_GTK3_SUPPORT: off
Annotations    :
repo_type      : binary
repository     : myrepo
Flat size      : 214MiB
Description    :
The Eclipse Platform is an open extensible IDE for anything and yet
nothing in particular. The Eclipse Platform provides building blocks
and a foundation for constructing and running integrated software-
development tools. The Eclipse Platform allows tool builders to
independently develop tools that integrate with other people's tools
so seamlessly you can't tell where one tool ends and another starts.

WWW: http://www.eclipse.org/

I suppose that it's my personal problem, but not sure. I'm going to update
my packages to latest version.

Thanks!

On Wed, Nov 11, 2015 at 5:35 PM, Achilleas Mantzios <
[hidden email]> wrote:

> Hello, fellow BSD'ers,
>
> I have seen this :
> https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203689
> Have there been any news on this? Anyone tried the submitted patch?
>
> --
> Achilleas Mantzios
> IT DEV Lead
> IT DEPT
> Dynacom Tankers Mgmt
>
> _______________________________________________
> [hidden email] mailing list
> https://lists.freebsd.org/mailman/listinfo/freebsd-java
> To unsubscribe, send any mail to "[hidden email]"
>
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-eclipse
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse 4.5 (Mars) on FreeBSD.

Jimmy Kelley
By default, the FreeBSD Eclipse port is built without Gtk3 support.
However, Eclipse still tries to use the Gtk3 libraries if it detects
them on your system.

The 'fix' is to set an environment variable:

SWT_GTK3=0

Jimmy Kelley
FreeBSD Eclipse port maintainer

On Wed, Nov 11, 2015 at 07:00:35PM +0300, Michael Zhilin wrote:

> Hi,
>
> I haven't tried yet, because eclipse returns error:
>
> [mizhka@gidrarium ~]$ eclipse
>
> (<unknown>:14193): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x
> and GTK+ 3 in the same process is not supported
> [mizhka@gidrarium ~]$ pkg info eclipse
> eclipse-4.5
> Name           : eclipse
> Version        : 4.5
> Installed on   : Wed Nov 11 18:54:02 MSK 2015
> Origin         : java/eclipse
> Architecture   : freebsd:10:x86:64
> Prefix         : /usr/local
> Categories     : devel java
> Licenses       : EPL
> Maintainer     : [hidden email]
> WWW            : http://www.eclipse.org/
> Comment        : Eclipse Mars
> Options        :
> FULL_SDK       : on
> PLATFORM       : off
> PLATFORM_SDK   : off
> SWT_GTK3_SUPPORT: off
> Annotations    :
> repo_type      : binary
> repository     : myrepo
> Flat size      : 214MiB
> Description    :
> The Eclipse Platform is an open extensible IDE for anything and yet
> nothing in particular. The Eclipse Platform provides building blocks
> and a foundation for constructing and running integrated software-
> development tools. The Eclipse Platform allows tool builders to
> independently develop tools that integrate with other people's tools
> so seamlessly you can't tell where one tool ends and another starts.
>
> WWW: http://www.eclipse.org/
>
> I suppose that it's my personal problem, but not sure. I'm going to update
> my packages to latest version.
>
> Thanks!
>
> On Wed, Nov 11, 2015 at 5:35 PM, Achilleas Mantzios <
> [hidden email]> wrote:
>
> > Hello, fellow BSD'ers,
> >
> > I have seen this :
> > https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203689
> > Have there been any news on this? Anyone tried the submitted patch?
> >
> > --
> > Achilleas Mantzios
> > IT DEV Lead
> > IT DEPT
> > Dynacom Tankers Mgmt
> >
> > _______________________________________________
> > [hidden email] mailing list
> > https://lists.freebsd.org/mailman/listinfo/freebsd-java
> > To unsubscribe, send any mail to "[hidden email]"
> >
> _______________________________________________
> [hidden email] mailing list
> https://lists.freebsd.org/mailman/listinfo/freebsd-eclipse
> To unsubscribe, send any mail to "[hidden email]"
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-eclipse
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse 4.5 (Mars) on FreeBSD.

Achilleas Mantzios
On 11/11/2015 19:06, Jimmy Kelley wrote:
> By default, the FreeBSD Eclipse port is built without Gtk3 support.
> However, Eclipse still tries to use the Gtk3 libraries if it detects
> them on your system.
>
> The 'fix' is to set an environment variable:
>
> SWT_GTK3=0

Thank you Jimmy,
any plans for an official port soon?

Any potential gotchas to watch out for? (unrepairable workspace, etc...)

>
> Jimmy Kelley
> FreeBSD Eclipse port maintainer
>
> On Wed, Nov 11, 2015 at 07:00:35PM +0300, Michael Zhilin wrote:
>> Hi,
>>
>> I haven't tried yet, because eclipse returns error:
>>
>> [mizhka@gidrarium ~]$ eclipse
>>
>> (<unknown>:14193): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x
>> and GTK+ 3 in the same process is not supported
>> [mizhka@gidrarium ~]$ pkg info eclipse
>> eclipse-4.5
>> Name           : eclipse
>> Version        : 4.5
>> Installed on   : Wed Nov 11 18:54:02 MSK 2015
>> Origin         : java/eclipse
>> Architecture   : freebsd:10:x86:64
>> Prefix         : /usr/local
>> Categories     : devel java
>> Licenses       : EPL
>> Maintainer     : [hidden email]
>> WWW            : http://www.eclipse.org/
>> Comment        : Eclipse Mars
>> Options        :
>> FULL_SDK       : on
>> PLATFORM       : off
>> PLATFORM_SDK   : off
>> SWT_GTK3_SUPPORT: off
>> Annotations    :
>> repo_type      : binary
>> repository     : myrepo
>> Flat size      : 214MiB
>> Description    :
>> The Eclipse Platform is an open extensible IDE for anything and yet
>> nothing in particular. The Eclipse Platform provides building blocks
>> and a foundation for constructing and running integrated software-
>> development tools. The Eclipse Platform allows tool builders to
>> independently develop tools that integrate with other people's tools
>> so seamlessly you can't tell where one tool ends and another starts.
>>
>> WWW: http://www.eclipse.org/
>>
>> I suppose that it's my personal problem, but not sure. I'm going to update
>> my packages to latest version.
>>
>> Thanks!
>>
>> On Wed, Nov 11, 2015 at 5:35 PM, Achilleas Mantzios <
>> [hidden email]> wrote:
>>
>>> Hello, fellow BSD'ers,
>>>
>>> I have seen this :
>>> https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203689
>>> Have there been any news on this? Anyone tried the submitted patch?
>>>
>>> --
>>> Achilleas Mantzios
>>> IT DEV Lead
>>> IT DEPT
>>> Dynacom Tankers Mgmt
>>>
>>> _______________________________________________
>>> [hidden email] mailing list
>>> https://lists.freebsd.org/mailman/listinfo/freebsd-java
>>> To unsubscribe, send any mail to "[hidden email]"
>>>
>> _______________________________________________
>> [hidden email] mailing list
>> https://lists.freebsd.org/mailman/listinfo/freebsd-eclipse
>> To unsubscribe, send any mail to "[hidden email]"


--
Achilleas Mantzios
IT DEV Lead
IT DEPT
Dynacom Tankers Mgmt

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-eclipse
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse 4.5 (Mars) on FreeBSD.

Achilleas Mantzios
In reply to this post by Jimmy Kelley
On 11/11/2015 19:22, Michael Zhilin wrote:

> Thank you, Jimmy! It works now.
>
> It worth also to note that custom gtkrc file make eclipse UI more comfortable.
> Here is screenshot with and without gtkrc file (file is attached):
>
>
> ‚Äč
> Main advantage of custom gtkrc file is removing huge spacing between elements.
>
> Jimmy,
>   Is it possible to include gtkrc file into port?
>

Thanx for your feedback Michael.

> Thanks!
>
> On Wed, Nov 11, 2015 at 8:06 PM, Jimmy Kelley <[hidden email] <mailto:[hidden email]>> wrote:
>
>     By default, the FreeBSD Eclipse port is built without Gtk3 support.
>     However, Eclipse still tries to use the Gtk3 libraries if it detects
>     them on your system.
>
>     The 'fix' is to set an environment variable:
>
>     SWT_GTK3=0
>
>     Jimmy Kelley
>     FreeBSD Eclipse port maintainer
>
>     On Wed, Nov 11, 2015 at 07:00:35PM +0300, Michael Zhilin wrote:
>     > Hi,
>     >
>     > I haven't tried yet, because eclipse returns error:
>     >
>     > [mizhka@gidrarium ~]$ eclipse
>     >
>     > (<unknown>:14193): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x
>     > and GTK+ 3 in the same process is not supported
>     > [mizhka@gidrarium ~]$ pkg info eclipse
>     > eclipse-4.5
>     > Name           : eclipse
>     > Version        : 4.5
>     > Installed on   : Wed Nov 11 18:54:02 MSK 2015
>     > Origin         : java/eclipse
>     > Architecture   : freebsd:10:x86:64
>     > Prefix         : /usr/local
>     > Categories     : devel java
>     > Licenses       : EPL
>     > Maintainer     : [hidden email] <mailto:[hidden email]>
>     > WWW            : http://www.eclipse.org/
>     > Comment        : Eclipse Mars
>     > Options        :
>     > FULL_SDK       : on
>     > PLATFORM       : off
>     > PLATFORM_SDK   : off
>     > SWT_GTK3_SUPPORT: off
>     > Annotations    :
>     > repo_type      : binary
>     > repository     : myrepo
>     > Flat size      : 214MiB
>     > Description    :
>     > The Eclipse Platform is an open extensible IDE for anything and yet
>     > nothing in particular. The Eclipse Platform provides building blocks
>     > and a foundation for constructing and running integrated software-
>     > development tools. The Eclipse Platform allows tool builders to
>     > independently develop tools that integrate with other people's tools
>     > so seamlessly you can't tell where one tool ends and another starts.
>     >
>     > WWW: http://www.eclipse.org/
>     >
>     > I suppose that it's my personal problem, but not sure. I'm going to update
>     > my packages to latest version.
>     >
>     > Thanks!
>     >
>     > On Wed, Nov 11, 2015 at 5:35 PM, Achilleas Mantzios <
>     > [hidden email] <mailto:[hidden email]>> wrote:
>     >
>     > > Hello, fellow BSD'ers,
>     > >
>     > > I have seen this :
>     > > https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203689
>     > > Have there been any news on this? Anyone tried the submitted patch?
>     > >
>     > > --
>     > > Achilleas Mantzios
>     > > IT DEV Lead
>     > > IT DEPT
>     > > Dynacom Tankers Mgmt
>     > >
>     > > _______________________________________________
>     > > [hidden email] <mailto:[hidden email]> mailing list
>     > > https://lists.freebsd.org/mailman/listinfo/freebsd-java
>     > > To unsubscribe, send any mail to "[hidden email] <mailto:[hidden email]>"
>     > >
>     > _______________________________________________
>     > [hidden email] <mailto:[hidden email]> mailing list
>     > https://lists.freebsd.org/mailman/listinfo/freebsd-eclipse
>     > To unsubscribe, send any mail to "[hidden email] <mailto:[hidden email]>"
>
>


--
Achilleas Mantzios
IT DEV Lead
IT DEPT
Dynacom Tankers Mgmt

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-eclipse
To unsubscribe, send any mail to "[hidden email]"