Eclipse dies on amd64

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Eclipse dies on amd64

Franco Bruno Borghesi
Hi everyone.

I'm having problems with eclipse on my new amd64 installation. Eclipse hangs
for a couple of minutes and then I get a window telling me that java
crashed.

This is a random problem, and I haven't found a way to reproduce it. It just
happens.
I've tryied rebuilding eclipse, but it didn't help (used WITHOUT_CAIRO=yes).
I've attached the log files generated in my home directory. Maybe someone
could give me a hint.

Console reports:
pid 33465 (java), uid 1000: exited on signal 6 (core dumped)
pid 8299 (java), uid 1000: exited on signal 6 (core dumped)

System Detail:
*FreeBSD taz.oficina 6.0-STABLE FreeBSD 6.0-STABLE #1: Tue Nov 29 17:10:44
ART 2005 [hidden email]:/usr/obj/usr/src/sys/TAZ  amd64

*java version "1.5.0-p2"
Java(TM) 2 Runtime Environment, Standard Edition (build
1.5.0-p2-root_29_nov_2005_17_58)
Java HotSpot(TM) 64-Bit Server VM (build 1.5.0-p2-root_29_nov_2005_16_21,
mixed mode)

*CPU: AMD Athlon(tm) 64 Processor 3000+ (1804.10-MHz K8-class CPU)
  Origin = "AuthenticAMD"  Id = 0x20ff0  Stepping = 0
Features=0x78bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SS
E,SSE2>
  Features2=0x1<SSE3>
  AMD Features=0xe2500800<SYSCALL,NX,MMX+,<b25>,LM,3DNow+,3DNow>
real memory  = 1073414144 (1023 MB)
avail memory = 1025736704 (978 MB)


Thanks in advance.

_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-java
To unsubscribe, send any mail to "[hidden email]"

hs_err_pid33465.log (14K) Download Attachment
hs_err_pid8299.log (14K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse dies on amd64

Sean McNeil
On Thu, 2005-12-01 at 16:12 -0300, Franco Bruno Borghesi wrote:

> Hi everyone.
>
> I'm having problems with eclipse on my new amd64 installation. Eclipse hangs
> for a couple of minutes and then I get a window telling me that java
> crashed.
>
> This is a random problem, and I haven't found a way to reproduce it. It just
> happens.
> I've tryied rebuilding eclipse, but it didn't help (used WITHOUT_CAIRO=yes).
> I've attached the log files generated in my home directory. Maybe someone
> could give me a hint.
>
> Console reports:
> pid 33465 (java), uid 1000: exited on signal 6 (core dumped)
> pid 8299 (java), uid 1000: exited on signal 6 (core dumped)
>
> System Detail:
> *FreeBSD taz.oficina 6.0-STABLE FreeBSD 6.0-STABLE #1: Tue Nov 29 17:10:44
> ART 2005 [hidden email]:/usr/obj/usr/src/sys/TAZ  amd64
>
> *java version "1.5.0-p2"
> Java(TM) 2 Runtime Environment, Standard Edition (build
> 1.5.0-p2-root_29_nov_2005_17_58)
> Java HotSpot(TM) 64-Bit Server VM (build 1.5.0-p2-root_29_nov_2005_16_21,
> mixed mode)

I used to have this same kind of thing happen to me until I fixed java.
Please look at the java@ mailing list.  There are two proposed solutions
in there regarding libz namespace conflicts that have been floating
around for quite a while, yet neither of these solutions have been
implemented in the port.  It is pretty crucial for eclipse as it uses
gtk extensively which relies on libz.  Take a look at:

http://lists.freebsd.org/pipermail/freebsd-java/2005-October/004570.html

Cheers,
Sean


_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-java
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse dies on amd64

Panagiotis Astithas
Sean McNeil wrote:

> On Thu, 2005-12-01 at 16:12 -0300, Franco Bruno Borghesi wrote:
>
>>Hi everyone.
>>
>>I'm having problems with eclipse on my new amd64 installation. Eclipse hangs
>>for a couple of minutes and then I get a window telling me that java
>>crashed.
>>
>>This is a random problem, and I haven't found a way to reproduce it. It just
>>happens.
>>I've tryied rebuilding eclipse, but it didn't help (used WITHOUT_CAIRO=yes).
>>I've attached the log files generated in my home directory. Maybe someone
>>could give me a hint.
>>
>>Console reports:
>>pid 33465 (java), uid 1000: exited on signal 6 (core dumped)
>>pid 8299 (java), uid 1000: exited on signal 6 (core dumped)
>>
>>System Detail:
>>*FreeBSD taz.oficina 6.0-STABLE FreeBSD 6.0-STABLE #1: Tue Nov 29 17:10:44
>>ART 2005 [hidden email]:/usr/obj/usr/src/sys/TAZ  amd64
>>
>>*java version "1.5.0-p2"
>>Java(TM) 2 Runtime Environment, Standard Edition (build
>>1.5.0-p2-root_29_nov_2005_17_58)
>>Java HotSpot(TM) 64-Bit Server VM (build 1.5.0-p2-root_29_nov_2005_16_21,
>>mixed mode)
>
>
> I used to have this same kind of thing happen to me until I fixed java.
> Please look at the java@ mailing list.  There are two proposed solutions
> in there regarding libz namespace conflicts that have been floating
> around for quite a while, yet neither of these solutions have been
> implemented in the port.  It is pretty crucial for eclipse as it uses
> gtk extensively which relies on libz.  Take a look at:
>
> http://lists.freebsd.org/pipermail/freebsd-java/2005-October/004570.html
>
> Cheers,
> Sean

FWIW, I've been running (on i386) with Mikhail's patches for the last
couple of months in my day job and I have encountered zero problems.

Cheers,
Panagiotis
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-java
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse dies on amd64

Franco Bruno Borghesi
2005/12/2, Panagiotis Astithas <[hidden email]>:

>
> Sean McNeil wrote:
> > On Thu, 2005-12-01 at 16:12 -0300, Franco Bruno Borghesi wrote:
> >
> >>Hi everyone.
> >>
> >>I'm having problems with eclipse on my new amd64 installation. Eclipse
> hangs
> >>for a couple of minutes and then I get a window telling me that java
> >>crashed.
> >>
> >>This is a random problem, and I haven't found a way to reproduce it. It
> just
> >>happens.
> >>I've tryied rebuilding eclipse, but it didn't help (used
> WITHOUT_CAIRO=yes).
> >>I've attached the log files generated in my home directory. Maybe
> someone
> >>could give me a hint.
> >>
> >>Console reports:
> >>pid 33465 (java), uid 1000: exited on signal 6 (core dumped)
> >>pid 8299 (java), uid 1000: exited on signal 6 (core dumped)
> >>
> >>System Detail:
> >>*FreeBSD taz.oficina 6.0-STABLE FreeBSD 6.0-STABLE #1: Tue Nov 29
> 17:10:44
> >>ART 2005 [hidden email]:/usr/obj/usr/src/sys/TAZ  amd64
> >>
> >>*java version "1.5.0-p2"
> >>Java(TM) 2 Runtime Environment, Standard Edition (build
> >>1.5.0-p2-root_29_nov_2005_17_58)
> >>Java HotSpot(TM) 64-Bit Server VM (build 1.5.0-p2-root_29_nov_2005_16_21
> ,
> >>mixed mode)
> >
> >
> > I used to have this same kind of thing happen to me until I fixed java.
> > Please look at the java@ mailing list.  There are two proposed solutions
> > in there regarding libz namespace conflicts that have been floating
> > around for quite a while, yet neither of these solutions have been
> > implemented in the port.  It is pretty crucial for eclipse as it uses
> > gtk extensively which relies on libz.  Take a look at:
> >
> > http://lists.freebsd.org/pipermail/freebsd-java/2005-October/004570.html
> >
> > Cheers,
> > Sean
>
> FWIW, I've been running (on i386) with Mikhail's patches for the last
> couple of months in my day job and I have encountered zero problems.
>
> Cheers,
> Panagiotis
>

I've been using unpatched jdk15 for a couple of months too on i386 (athlon
XP) and it worked without problems. This week I changed my computer to an
Atlon64 and started a fresh installation, and that's when problems started.

Yesterday I applied this patch (
http://lists.freebsd.org/pipermail/freebsd-java/2005-October/004487.html)
because the other proposed patch failed. Recompiled jdk15 and reinstaled.

Eclipse just hanged, so I will try to apply the other patch (
http://lists.freebsd.org/pipermail/freebsd-java/2005-October/004476.html)
and recompile jdk15 again.

I attached today's hs_err-pid file. Do you still think this is a
libzip.soproblem?

Thanks.

_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-java
To unsubscribe, send any mail to "[hidden email]"

hs_err_pid87808.log (17K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse dies on amd64

Sean McNeil
On Fri, 2005-12-02 at 14:16 -0300, Franco Bruno Borghesi wrote:

>
>
> 2005/12/2, Panagiotis Astithas <[hidden email]>:
>         Sean McNeil wrote:
>         > On Thu, 2005-12-01 at 16:12 -0300, Franco Bruno Borghesi
>         wrote:
>         >
>         >>Hi everyone.
>         >>
>         >>I'm having problems with eclipse on my new amd64
>         installation. Eclipse hangs
>         >>for a couple of minutes and then I get a window telling me
>         that java
>         >>crashed.
>         >>
>         >>This is a random problem, and I haven't found a way to
>         reproduce it. It just
>         >>happens.
>         >>I've tryied rebuilding eclipse, but it didn't help (used
>         WITHOUT_CAIRO=yes).
>         >>I've attached the log files generated in my home directory.
>         Maybe someone
>         >>could give me a hint.
>         >>
>         >>Console reports:
>         >>pid 33465 (java), uid 1000: exited on signal 6 (core dumped)
>         >>pid 8299 (java), uid 1000: exited on signal 6 (core dumped)
>         >>
>         >>System Detail:
>         >>*FreeBSD taz.oficina 6.0-STABLE FreeBSD 6.0-STABLE #1: Tue
>         Nov 29 17:10:44
>         >>ART 2005 [hidden email]:/usr/obj/usr/src/sys/TAZ  amd64
>         >>
>         >>*java version "1.5.0-p2"
>         >>Java(TM) 2 Runtime Environment, Standard Edition (build
>         >>1.5.0-p2-root_29_nov_2005_17_58)
>         >>Java HotSpot(TM) 64-Bit Server VM (build
>         1.5.0-p2-root_29_nov_2005_16_21,
>         >>mixed mode)
>         >
>         >
>         > I used to have this same kind of thing happen to me until I
>         fixed java.
>         > Please look at the java@ mailing list.  There are two
>         proposed solutions
>         > in there regarding libz namespace conflicts that have been
>         floating
>         > around for quite a while, yet neither of these solutions
>         have been
>         > implemented in the port.  It is pretty crucial for eclipse
>         as it uses
>         > gtk extensively which relies on libz.  Take a look at:
>         >
>         >
>         http://lists.freebsd.org/pipermail/freebsd-java/2005-October/004570.html
>         >
>         > Cheers,
>         > Sean
>        
>         FWIW, I've been running (on i386) with Mikhail's patches for
>         the last
>         couple of months in my day job and I have encountered zero
>         problems.
>        
>         Cheers,
>         Panagiotis
>
>
> I've been using unpatched jdk15 for a couple of months too on i386
> (athlon XP) and it worked without problems. This week I changed my
> computer to an Atlon64 and started a fresh installation, and that's
> when problems started.
>
> Yesterday I applied this patch
> (http://lists.freebsd.org/pipermail/freebsd-java/2005-October/004487.html) because the other proposed patch failed. Recompiled jdk15 and reinstaled.
>
> Eclipse just hanged, so I will try to apply the other patch
> (http://lists.freebsd.org/pipermail/freebsd-java/2005-October/004476.html) and recompile jdk15 again.
>
> I attached today's hs_err-pid file. Do you still think this is a
> libzip.so problem?

This is the most likely candidate, but there are also might be
incompatibilities between the i386 and amd64 versions of a workspace.
Make sure you rm -rf .eclipse and use a fresh workspace.

Another thing people have been asking is to try using the default gnome
theme.


_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-java
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse dies on amd64

Franco Bruno Borghesi
2005/12/2, Sean McNeil <[hidden email]>:

>
> On Fri, 2005-12-02 at 14:16 -0300, Franco Bruno Borghesi wrote:
> >
> >
> > 2005/12/2, Panagiotis Astithas <[hidden email]>:
> >         Sean McNeil wrote:
> >         > On Thu, 2005-12-01 at 16:12 -0300, Franco Bruno Borghesi
> >         wrote:
> >         >
> >         >>Hi everyone.
> >         >>
> >         >>I'm having problems with eclipse on my new amd64
> >         installation. Eclipse hangs
> >         >>for a couple of minutes and then I get a window telling me
> >         that java
> >         >>crashed.
> >         >>
> >         >>This is a random problem, and I haven't found a way to
> >         reproduce it. It just
> >         >>happens.
> >         >>I've tryied rebuilding eclipse, but it didn't help (used
> >         WITHOUT_CAIRO=yes).
> >         >>I've attached the log files generated in my home directory.
> >         Maybe someone
> >         >>could give me a hint.
> >         >>
> >         >>Console reports:
> >         >>pid 33465 (java), uid 1000: exited on signal 6 (core dumped)
> >         >>pid 8299 (java), uid 1000: exited on signal 6 (core dumped)
> >         >>
> >         >>System Detail:
> >         >>*FreeBSD taz.oficina 6.0-STABLE FreeBSD 6.0-STABLE #1: Tue
> >         Nov 29 17:10:44
> >         >>ART 2005 [hidden email]:/usr/obj/usr/src/sys/TAZ  amd64
> >         >>
> >         >>*java version "1.5.0-p2"
> >         >>Java(TM) 2 Runtime Environment, Standard Edition (build
> >         >>1.5.0-p2-root_29_nov_2005_17_58)
> >         >>Java HotSpot(TM) 64-Bit Server VM (build
> >         1.5.0-p2-root_29_nov_2005_16_21,
> >         >>mixed mode)
> >         >
> >         >
> >         > I used to have this same kind of thing happen to me until I
> >         fixed java.
> >         > Please look at the java@ mailing list.  There are two
> >         proposed solutions
> >         > in there regarding libz namespace conflicts that have been
> >         floating
> >         > around for quite a while, yet neither of these solutions
> >         have been
> >         > implemented in the port.  It is pretty crucial for eclipse
> >         as it uses
> >         > gtk extensively which relies on libz.  Take a look at:
> >         >
> >         >
> >
> http://lists.freebsd.org/pipermail/freebsd-java/2005-October/004570.html
> >         >
> >         > Cheers,
> >         > Sean
> >
> >         FWIW, I've been running (on i386) with Mikhail's patches for
> >         the last
> >         couple of months in my day job and I have encountered zero
> >         problems.
> >
> >         Cheers,
> >         Panagiotis
> >
> >
> > I've been using unpatched jdk15 for a couple of months too on i386
> > (athlon XP) and it worked without problems. This week I changed my
> > computer to an Atlon64 and started a fresh installation, and that's
> > when problems started.
> >
> > Yesterday I applied this patch
> > (
> http://lists.freebsd.org/pipermail/freebsd-java/2005-October/004487.html)
> because the other proposed patch failed. Recompiled jdk15 and reinstaled.
> >
> > Eclipse just hanged, so I will try to apply the other patch
> > (
> http://lists.freebsd.org/pipermail/freebsd-java/2005-October/004476.html)
> and recompile jdk15 again.
> >
> > I attached today's hs_err-pid file. Do you still think this is a
> > libzip.so problem?
>
> This is the most likely candidate, but there are also might be
> incompatibilities between the i386 and amd64 versions of a workspace.
> Make sure you rm -rf .eclipse and use a fresh workspace.
>
> Another thing people have been asking is to try using the default gnome
> theme.
>
>
>
Yes, you are right, three of the last four hs_err_pid files contained the
lines
...
# Problematic frame:
# C  [libzip.so+0x7baa]  inflateEnd+0x3a
...

I've applied the other patch and I'm rebuilding jdk15 right now. Hope it
works.

Thanks for your help Sean.
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-java
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse dies on amd64

Greg Lewis-2
In reply to this post by Sean McNeil
On Thu, Dec 01, 2005 at 11:22:09AM -0800, Sean McNeil wrote:
> I used to have this same kind of thing happen to me until I fixed java.
> Please look at the java@ mailing list.  There are two proposed solutions
> in there regarding libz namespace conflicts that have been floating
> around for quite a while, yet neither of these solutions have been
> implemented in the port.  It is pretty crucial for eclipse as it uses
> gtk extensively which relies on libz.  Take a look at:
>
> http://lists.freebsd.org/pipermail/freebsd-java/2005-October/004570.html

One of the solutions is committed.  I think the other is probably better
but I want to test it more first.

--
Greg Lewis                          Email   : [hidden email]
Eyes Beyond                         Web     : http://www.eyesbeyond.com
Information Technology              FreeBSD : [hidden email]
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-java
To unsubscribe, send any mail to "[hidden email]"