FBSD 11.2 on VMWare ESXi

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

FBSD 11.2 on VMWare ESXi

Jim Pazarena-15
My first exploration of FreeBSD on ESXi has been a bit challenging .

While my network runs fine on vmx0 , FreeBSD doesn't seem acknowledge
the existence of vmx1, vmx2, or vmx3 . But they do . I have a CentOS vm
which is happy on a different vswitch .

Is there anything special about FreeBSD 'seeing' additional vswitches ?
I am using ESXi 6.7.0 8169922 , and I just downloaded an 'update 2' of
6.7.0 .

Perhaps a re-install to this vmware update 2 will correct this . But
that's a whole lot of work .

Any tips ahead of that would be most appreciated .
--
Jim Pazarena         [hidden email]
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: FBSD 11.2 on VMWare ESXi

Jim Pazarena-15

On 2019-04-15 5:55 PM, Jim Pazarena wrote:

> My first exploration of FreeBSD on ESXi has been a bit challenging .
>
> While my network runs fine on vmx0 , FreeBSD doesn't seem acknowledge
> the existence of vmx1, vmx2, or vmx3 . But they do . I have a CentOS vm
> which is happy on a different vswitch .
>
> Is there anything special about FreeBSD 'seeing' additional vswitches ?
> I am using ESXi 6.7.0 8169922 , and I just downloaded an 'update 2' of
> 6.7.0 .
>
> Perhaps a re-install to this vmware update 2 will correct this . But
> that's a whole lot of work .
>
> Any tips ahead of that would be most appreciated .

for just a moment , I see the following on the ESXi console screen for
FreeBSD:

pcib19: Attention Button Pressed: Detaching in 5 seconds
pci5: <ACPI PCI bus> on picb19
vmx1: <NVeare VMXNET3 Ethernet Adapter> at device 0.0 on pci5
vmx1: Ethernet address: 00:0c:29:61:d0:61
vmx1: detached
pci5: detached

At this point I do not know if this is a
VMWare issue, or a
FreeBSD issue, or a
HP Server issue .

A guiding hand would be appreciated .

--
Jim Pazarena         [hidden email]
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: FBSD 11.2 on VMWare ESXi

Jim Pazarena-15
In reply to this post by Jim Pazarena-15


On 2019-04-15 8:07 PM, Jim Pazarena wrote:

>
> On 2019-04-15 5:55 PM, Jim Pazarena wrote:
>> My first exploration of FreeBSD on ESXi has been a bit challenging .
>>
>> While my network runs fine on vmx0 , FreeBSD doesn't seem acknowledge
>> the existence of vmx1, vmx2, or vmx3 . But they do . I have a CentOS
>> vm which is happy on a different vswitch .
>>
>> Is there anything special about FreeBSD 'seeing' additional vswitches ?
>> I am using ESXi 6.7.0 8169922 , and I just downloaded an 'update 2' of
>> 6.7.0 .
>>
>> Perhaps a re-install to this vmware update 2 will correct this . But
>> that's a whole lot of work .
>>
>> Any tips ahead of that would be most appreciated .

Someone responded off-list and suggested that I switch to the e1000
drive rather than the vmx driver .

It worked !

Thanks for the tip .

Jim

>
> for just a moment , I see the following on the ESXi console screen for
> FreeBSD:
>
> pcib19: Attention Button Pressed: Detaching in 5 seconds
> pci5: <ACPI PCI bus> on picb19
> vmx1: <NVeare VMXNET3 Ethernet Adapter> at device 0.0 on pci5
> vmx1: Ethernet address: 00:0c:29:61:d0:61
> vmx1: detached
> pci5: detached
>
> At this point I do not know if this is a
> VMWare issue, or a
> FreeBSD issue, or a
> HP Server issue .
>
> A guiding hand would be appreciated .
>

--
Jim Pazarena         [hidden email]
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[hidden email]"