Failed to load Xen, kernel '/boot/xen'

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Failed to load Xen, kernel '/boot/xen'

Kevin G. Eliuk-2

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-xen
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Failed to load Xen, kernel '/boot/xen'

Kevin G. Eliuk-2

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-xen
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Failed to load Xen, kernel '/boot/xen'

freebsd-xen mailing list
In reply to this post by Kevin G. Eliuk-2
On Tue, Jan 12, 2021 at 11:12:15AM -0800, Kevin G. Eliuk wrote:

It's kind of hard to tell what's going on without you providing almost
any info, but are you maybe booting using UEFI?

Roger.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-xen
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Failed to load Xen, kernel '/boot/xen'

Kevin G. Eliuk-2
On 2021-01-14 12:19 a.m., Roger Pau Monné wrote:
> On Tue, Jan 12, 2021 at 11:12:15AM -0800, Kevin G. Eliuk wrote:
>
> It's kind of hard to tell what's going on without you providing almost
> any info, but are you maybe booting using UEFI?
>
> Roger.

Booting with Legacy boot set in the BIOS.

After exhausting all could think of with BIOS settings and boot
configurations I wiped the drive and re-installed selecting encryption
in the ZFS options.  I booted and tested as shown in the handbook.

Thanks for the reply.

Regards,

Kevin Eliuk

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-xen
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Failed to load Xen, kernel '/boot/xen'

Kevin G. Eliuk-2
In reply to this post by freebsd-xen mailing list
On 2021-01-14 12:19 a.m., Roger Pau Monné wrote:
> On Tue, Jan 12, 2021 at 11:12:15AM -0800, Kevin G. Eliuk wrote:
>
> It's kind of hard to tell what's going on without you providing almost
> any info, but are you maybe booting using UEFI?
Oops a newbie mistake
> Roger.


I was able to get things working by wiping the drive and re-installing
FreeBSD 12 and selecting to encrypt the zfs file system.


Original message:

I had a working Xen Dom0 host running on a system which had been sitting
idle for a while.  I had forgotten the passphrase for the encrypted
drive so I did a reinstall to get back to work with it.

After the install and reboot I followed the instructions (multiple
times) from FreeBSD as a Xen-Host.  but every reboot I have to unset the
xen_kernel configuration because I get the following.

Loading Xen kernel
Failed to load Xen, kernel '/boot/xen'
can't load 'kernel'

I'm stumped.  Thanks for any help or suggestions for next steps.

    *# uname -a*
    FreeBSD freexen 12.2-RELEASE FreeBSD 12.2-RELEASE r366954 GENERIC  amd64
    --
    *# pkg info | grep xen*
    xen-kernel-4.14.0              Hypervisor using a microkernel design
    xen-tools-4.14.0_1             Xen management tools
    *# dmesg*
    ---<<BOOT>>---
    Copyright (c) 1992-2020 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
             The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 12.2-RELEASE r366954 GENERIC amd64
    FreeBSD clang version 10.0.1 ([hidden email]:llvm/llvm-project.git  llvmorg-10.0.1-0-gef32c611aa2)
    VT(vga): resolution 640x480
    CPU: Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz (3591.76-MHz K8-class CPU)
       Origin="GenuineIntel"  Id=0x306c3  Family=0x6  Model=0x3c  Stepping=3
       Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
       Features2=0x7ffafbff<SSE3,PCLMULQDQ,DTES64,MON,DS_CPL,VMX,SMX,EST,TM2,SSSE3,SDBG,FMA,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,TSCDLT,AESNI,XSAVE,OSXSAVE,AVX,F16C,RDRAND>
       AMD Features=0x2c000800<SYSCALL,Page1GB,RDTSCP,LM>
       AMD Features2=0x21<LAHF,ABM>
       Structured Extended Features=0x27ab<FSGSBASE,TSCADJ,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,NFPUSG>
       Structured Extended Features3=0x9c000600<MCUOPT,MD_CLEAR,IBPB,STIBP,L1DFL,SSBD>
       XSAVE Features=0x1<XSAVEOPT>
       VT-x: PAT,HLT,MTF,PAUSE,EPT,UG,VPID
       TSC: P-state invariant, performance statistics
    real memory  = 34359738368 (32768 MB)
    avail memory = 33264410624 (31723 MB)
    Event timer "LAPIC" quality 600
    ACPI APIC Table: <HPQOEM SLIC-BPC>
    FreeBSD/SMP: Multiprocessor System Detected: 8 CPUs
    FreeBSD/SMP: 1 package(s) x 4 core(s) x 2 hardware threads
    random: unblocking device.
    ioapic0 <Version 2.0> irqs 0-23 on motherboard
    Launching APs: 1 7 6 2 3 4 5
    Timecounter "TSC-low" frequency 1795880018 Hz quality 1000
    random: entropy device external interface
    kbd1 at kbdmux0
    000.000023 [4336] netmap_init               netmap: loaded module
    [ath_hal] loaded
    module_register_init: MOD_LOAD (vesa, 0xffffffff81115e40, 0) error 19
    random: registering fast source Intel Secure Key RNG
    random: fast provider: "Intel Secure Key RNG"
    nexus0
    efirtc0: <EFI Realtime Clock> on motherboard
    efirtc0: registered as a time-of-day clock, resolution 1.000000s
    vtvga0: <VT VGA driver> on motherboard
    cryptosoft0: <software crypto> on motherboard
    acpi0: <HPQOEM SLIC-BPC> on motherboard
    acpi0: Power Button (fixed)
    can't fetch resources for \134_SB_.PCI0.LPCB.LDRC - AE_AML_INVALID_RESOURCE_TYPE
    cpu0: <ACPI CPU> on acpi0
    hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
    Timecounter "HPET" frequency 14318180 Hz quality 950
    Event timer "HPET" frequency 14318180 Hz quality 550
    atrtc0: <AT realtime clock> port 0x70-0x77 irq 8 on acpi0
    atrtc0: registered as a time-of-day clock, resolution 1.000000s
    Event timer "RTC" frequency 32768 Hz quality 0
    attimer0: <AT timer> port 0x40-0x43,0x50-0x53 irq 0 on acpi0
    Timecounter "i8254" frequency 1193182 Hz quality 0
    Event timer "i8254" frequency 1193182 Hz quality 100
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
    pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
    pci0: <ACPI PCI bus> on pcib0
    vgapci0: <VGA-compatible display> port 0xf000-0xf03f mem 0xf7800000-0xf7bfffff,0xe0000000-0xefffffff irq 16 at device 2.0 on pci0
    vgapci0: Boot video device
    hdac0: <Intel Haswell HDA Controller> mem 0xf7c34000-0xf7c37fff irq 16 at device 3.0 on pci0
    xhci0: <Intel Lynx Point USB 3.0 controller> mem 0xf7c20000-0xf7c2ffff irq 16 at device 20.0 on pci0
    xhci0: 32 bytes context size, 64-bit DMA
    usbus0: waiting for BIOS to give up control
    xhci_interrupt: host controller halted
    xhci0: Port routing mask set to 0xffffffff
    usbus0 on xhci0
    usbus0: 5.0Gbps Super Speed USB v3.0
    pci0: <simple comms> at device 22.0 (no driver attached)
    uart2: <Intel Lynx Point KT Controller> port 0xf0e0-0xf0e7 mem 0xf7c3e000-0xf7c3efff irq 19 at device 22.3 on pci0
    uart2: Using 1 MSI message
    em0: <Intel(R) PRO/1000 Network Connection> port 0xf080-0xf09f mem 0xf7c00000-0xf7c1ffff,0xf7c3d000-0xf7c3dfff irq 20 at device 25.0 on pci0
    em0: Using 1024 TX descriptors and 1024 RX descriptors
    em0: Using an MSI interrupt
    em0: Ethernet address: c4:34:6b:58:35:fa
    em0: netmap queues/slots: TX 1/1024, RX 1/1024
    ehci0: <Intel Lynx Point USB 2.0 controller USB-B> mem 0xf7c3c000-0xf7c3c3ff irq 16 at device 26.0 on pci0
    usbus1: EHCI version 1.0
    usbus1 on ehci0
    usbus1: 480Mbps High Speed USB v2.0
    hdac1: <Intel Lynx Point HDA Controller> mem 0xf7c30000-0xf7c33fff irq 22 at device 27.0 on pci0
    ehci1: <Intel Lynx Point USB 2.0 controller USB-A> mem 0xf7c3b000-0xf7c3b3ff irq 23 at device 29.0 on pci0
    usbus2: EHCI version 1.0
    usbus2 on ehci1
    usbus2: 480Mbps High Speed USB v2.0
    isab0: <PCI-ISA bridge> at device 31.0 on pci0
    isa0: <ISA bus> on isab0
    ahci0: <Intel Lynx Point AHCI SATA controller> port 0xf0d0-0xf0d7,0xf0c0-0xf0c3,0xf0b0-0xf0b7,0xf0a0-0xf0a3,0xf060-0xf07f mem 0xf7c3a000-0xf7c3a7ff irq 19 at device 31.2 on pci0
    ahci0: AHCI v1.30 with 5 6Gbps ports, Port Multiplier not supported
    ahcich1: <AHCI channel> at channel 1 on ahci0
    ahcich2: <AHCI channel> at channel 2 on ahci0
    ahciem0: <AHCI enclosure management bridge> on ahci0
    acpi_button0: <Power Button> on acpi0
    acpi_tz0: <Thermal Zone> on acpi0
    acpi_tz1: <Thermal Zone> on acpi0
    atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
    atkbd0: <AT Keyboard> irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    driver bug: Unable to set devclass (class: atkbdc devname: (unknown))
    uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
    ppc0: <Parallel port> port 0x378-0x37f,0x778-0x77f irq 7 drq 1 on acpi0
    ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
    ppc0: FIFO with 16/16/8 bytes threshold
    ppbus0: <Parallel port bus> on ppc0
    lpt0: <Printer> on ppbus0
    lpt0: Interrupt-driven port
    ppi0: <Parallel I/O> on ppbus0
    orm0: <ISA Option ROM> at iomem 0xcf000-0xcffff pnpid ORM0000 on isa0
    est0: <Enhanced SpeedStep Frequency Control> on cpu0
    ZFS filesystem version: 5
    ZFS storage pool version: features support (5000)
    Timecounters tick every 1.000 msec
    hdacc0: <Intel Haswell HDA CODEC> at cad 0 on hdac0
    hdaa0: <Intel Haswell Audio Function Group> at nid 1 on hdacc0
    pcm0: <Intel Haswell (HDMI/DP 8ch)> at nid 3 on hdaa0
    hdacc1: <Realtek ALC221 HDA CODEC> at cad 0 on hdac1
    hdaa1: <Realtek ALC221 Audio Function Group> at nid 1 on hdacc1
    pcm1: <Realtek ALC221 (Analog)> at nid 23 and 27,26 on hdaa1
    pcm2: <Realtek ALC221 (Analog 2.0+HP)> at nid 20,33 on hdaa1
    ugen1.1: <Intel EHCI root HUB> at usbus1
    ugen2.1: <Intel EHCI root HUB> at usbus2
    Trying to mount root from zfs:zroot/ROOT/default []...
    Root mount waiting for: usbus0 usbus1 usbus2 CAM
    uhub0: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus1
    ugen0.1: <0x8086 XHCI root HUB> at usbus0
    uhub1: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus2
    uhub2: <0x8086 XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus0
    cd0 at ahcich1 bus 0 scbus0 target 0 lun 0
    cd0: <hp DVDRAM GTA0N HB03> Removable CD-ROM SCSI device
    cd0: Serial Number 424CP018175
    cd0: 150.000MB/s transfers (SATA 1.x, UDMA5, ATAPI 12bytes, PIO 8192bytes)
    cd0: Attempt to query device size failed: NOT READY, Medium not present - tray closed
    ses0 at ahciem0 bus 0 scbus2 target 0 lun 0
    ses0: <AHCI SGPIO Enclosure 2.00 0001> SEMB S-E-S 2.00 device
    ses0: SEMB SES Device
    ada0 at ahcich2 bus 0 scbus1 target 0 lun 0
    ada0: <WDC WD10EFRX-68FYTN0 82.00A82> ACS-2 ATA SATA 3.x device
    ada0: Serial Number WD-WCC4J4JAJLNL
    ada0: 600.000MB/s transfers (SATA 3.x, UDMA6, PIO 8192bytes)
    ada0: Command Queueing enabled
    ada0: 953869MB (1953525168 512 byte sectors)
    ada0: quirks=0x1<4K>
    ses0: pass0,cd0 in 'Slot 01', SATA Slot: scbus0 target 0
    ses0: pass1,ada0 in 'Slot 02', SATA Slot: scbus1 target 0
    uhub2: 21 ports with 21 removable, self powered
    Root mount waiting for: usbus0 usbus1 usbus2
    uhub0: 3 ports with 3 removable, self powered
    uhub1: 3 ports with 3 removable, self powered
    ugen0.2: <Logitech USB Receiver> at usbus0
    ukbd0 on uhub2
    ukbd0: <Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 1> on usbus0
    kbd2 at ukbd0
    ugen2.2: <vendor 0x8087 product 0x8000> at usbus2
    uhub3 on uhub1
    uhub3: <vendor 0x8087 product 0x8000, class 9/0, rev 2.00/0.04, addr 2> on usbus2
    ugen1.2: <vendor 0x8087 product 0x8008> at usbus1
    uhub4 on uhub0
    uhub4: <vendor 0x8087 product 0x8008, class 9/0, rev 2.00/0.04, addr 2> on usbus1
    uhub4: 6 ports with 6 removable, self powered
    Root mount waiting for: usbus2
    uhub3: 8 ports with 8 removable, self powered
    bridge0: Ethernet address: 02:cb:af:39:8b:00
    lo0: link state changed to UP
    em0: link state changed to UP
    em0: link state changed to DOWN
    bridge0: link state changed to UP
    em0: promiscuous mode enabled
    em0: link state changed to UP
    ums0 on uhub2
    ums0: <Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 1> on usbus0
    ums0: 18 buttons and [XYZT] coordinates ID=2
    Security policy loaded: MAC/ntpd (mac_ntpd)
    Waiting (max 60 seconds) for system process `vnlru' to stop... done
    Waiting (max 60 seconds) for system process `syncer' to stop...
    Syncing disks, vnodes remaining... 0 0 0 0 done
    Waiting (max 60 seconds) for system thread `bufdaemon' to stop... done
    Waiting (max 60 seconds) for system thread `bufspacedaemon-0' to stop... done
    Waiting (max 60 seconds) for system thread `bufspacedaemon-1' to stop... done
    Waiting (max 60 seconds) for system thread `bufspacedaemon-2' to stop... done
    Waiting (max 60 seconds) for system thread `bufspacedaemon-3' to stop... done
    Waiting (max 60 seconds) for system thread `bufspacedaemon-4' to stop... done
    Waiting (max 60 seconds) for system thread `bufspacedaemon-5' to stop... done
    Waiting (max 60 seconds) for system thread `bufspacedaemon-6' to stop... done
    All buffers synced.
    ---<<BOOT>>---
    Copyright (c) 1992-2020 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
             The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 12.2-RELEASE r366954 GENERIC amd64
    FreeBSD clang version 10.0.1 ([hidden email]:llvm/llvm-project.git  llvmorg-10.0.1-0-gef32c611aa2)
    VT(vga): resolution 640x480
    CPU: Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz (3591.75-MHz K8-class CPU)
       Origin="GenuineIntel"  Id=0x306c3  Family=0x6  Model=0x3c  Stepping=3
       Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
       Features2=0x7ffafbff<SSE3,PCLMULQDQ,DTES64,MON,DS_CPL,VMX,SMX,EST,TM2,SSSE3,SDBG,FMA,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,TSCDLT,AESNI,XSAVE,OSXSAVE,AVX,F16C,RDRAND>
       AMD Features=0x2c000800<SYSCALL,Page1GB,RDTSCP,LM>
       AMD Features2=0x21<LAHF,ABM>
       Structured Extended Features=0x27ab<FSGSBASE,TSCADJ,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,NFPUSG>
       Structured Extended Features3=0x9c000600<MCUOPT,MD_CLEAR,IBPB,STIBP,L1DFL,SSBD>
       XSAVE Features=0x1<XSAVEOPT>
       VT-x: PAT,HLT,MTF,PAUSE,EPT,UG,VPID
       TSC: P-state invariant, performance statistics
    real memory  = 34359738368 (32768 MB)
    avail memory = 33264410624 (31723 MB)
    Event timer "LAPIC" quality 600
    ACPI APIC Table: <HPQOEM SLIC-BPC>
    FreeBSD/SMP: Multiprocessor System Detected: 8 CPUs
    FreeBSD/SMP: 1 package(s) x 4 core(s) x 2 hardware threads
    random: unblocking device.
    ioapic0 <Version 2.0> irqs 0-23 on motherboard
    Launching APs: 1 4 5 6 3 7 2
    Timecounter "TSC-low" frequency 1795876522 Hz quality 1000
    random: entropy device external interface
    kbd1 at kbdmux0
    000.000023 [4336] netmap_init               netmap: loaded module
    [ath_hal] loaded
    module_register_init: MOD_LOAD (vesa, 0xffffffff81115e40, 0) error 19
    random: registering fast source Intel Secure Key RNG
    random: fast provider: "Intel Secure Key RNG"
    nexus0
    efirtc0: <EFI Realtime Clock> on motherboard
    efirtc0: registered as a time-of-day clock, resolution 1.000000s
    vtvga0: <VT VGA driver> on motherboard
    cryptosoft0: <software crypto> on motherboard
    acpi0: <HPQOEM SLIC-BPC> on motherboard
    acpi0: Power Button (fixed)
    can't fetch resources for \134_SB_.PCI0.LPCB.LDRC - AE_AML_INVALID_RESOURCE_TYPE
    cpu0: <ACPI CPU> on acpi0
    hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
    Timecounter "HPET" frequency 14318180 Hz quality 950
    Event timer "HPET" frequency 14318180 Hz quality 550
    atrtc0: <AT realtime clock> port 0x70-0x77 irq 8 on acpi0
    atrtc0: registered as a time-of-day clock, resolution 1.000000s
    Event timer "RTC" frequency 32768 Hz quality 0
    attimer0: <AT timer> port 0x40-0x43,0x50-0x53 irq 0 on acpi0
    Timecounter "i8254" frequency 1193182 Hz quality 0
    Event timer "i8254" frequency 1193182 Hz quality 100
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
    pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
    pci0: <ACPI PCI bus> on pcib0
    vgapci0: <VGA-compatible display> port 0xf000-0xf03f mem 0xf7800000-0xf7bfffff,0xe0000000-0xefffffff irq 16 at device 2.0 on pci0
    vgapci0: Boot video device
    hdac0: <Intel Haswell HDA Controller> mem 0xf7c34000-0xf7c37fff irq 16 at device 3.0 on pci0
    xhci0: <Intel Lynx Point USB 3.0 controller> mem 0xf7c20000-0xf7c2ffff irq 16 at device 20.0 on pci0
    xhci0: 32 bytes context size, 64-bit DMA
    usbus0: waiting for BIOS to give up control
    xhci_interrupt: host controller halted
    xhci0: Port routing mask set to 0xffffffff
    usbus0 on xhci0
    usbus0: 5.0Gbps Super Speed USB v3.0
    pci0: <simple comms> at device 22.0 (no driver attached)
    uart2: <Intel Lynx Point KT Controller> port 0xf0e0-0xf0e7 mem 0xf7c3e000-0xf7c3efff irq 19 at device 22.3 on pci0
    uart2: Using 1 MSI message
    em0: <Intel(R) PRO/1000 Network Connection> port 0xf080-0xf09f mem 0xf7c00000-0xf7c1ffff,0xf7c3d000-0xf7c3dfff irq 20 at device 25.0 on pci0
    em0: Using 1024 TX descriptors and 1024 RX descriptors
    em0: Using an MSI interrupt
    em0: Ethernet address: c4:34:6b:58:35:fa
    em0: netmap queues/slots: TX 1/1024, RX 1/1024
    ehci0: <Intel Lynx Point USB 2.0 controller USB-B> mem 0xf7c3c000-0xf7c3c3ff irq 16 at device 26.0 on pci0
    usbus1: EHCI version 1.0
    usbus1 on ehci0
    usbus1: 480Mbps High Speed USB v2.0
    hdac1: <Intel Lynx Point HDA Controller> mem 0xf7c30000-0xf7c33fff irq 22 at device 27.0 on pci0
    ehci1: <Intel Lynx Point USB 2.0 controller USB-A> mem 0xf7c3b000-0xf7c3b3ff irq 23 at device 29.0 on pci0
    usbus2: EHCI version 1.0
    usbus2 on ehci1
    usbus2: 480Mbps High Speed USB v2.0
    isab0: <PCI-ISA bridge> at device 31.0 on pci0
    isa0: <ISA bus> on isab0
    ahci0: <Intel Lynx Point AHCI SATA controller> port 0xf0d0-0xf0d7,0xf0c0-0xf0c3,0xf0b0-0xf0b7,0xf0a0-0xf0a3,0xf060-0xf07f mem 0xf7c3a000-0xf7c3a7ff irq 19 at device 31.2 on pci0
    ahci0: AHCI v1.30 with 5 6Gbps ports, Port Multiplier not supported
    ahcich1: <AHCI channel> at channel 1 on ahci0
    ahcich2: <AHCI channel> at channel 2 on ahci0
    ahciem0: <AHCI enclosure management bridge> on ahci0
    acpi_button0: <Power Button> on acpi0
    acpi_tz0: <Thermal Zone> on acpi0
    acpi_tz1: <Thermal Zone> on acpi0
    atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
    atkbd0: <AT Keyboard> irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    driver bug: Unable to set devclass (class: atkbdc devname: (unknown))
    uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
    ppc0: <Parallel port> port 0x378-0x37f,0x778-0x77f irq 7 drq 1 on acpi0
    ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
    ppc0: FIFO with 16/16/8 bytes threshold
    ppbus0: <Parallel port bus> on ppc0
    lpt0: <Printer> on ppbus0
    lpt0: Interrupt-driven port
    ppi0: <Parallel I/O> on ppbus0
    orm0: <ISA Option ROM> at iomem 0xcf000-0xcffff pnpid ORM0000 on isa0
    est0: <Enhanced SpeedStep Frequency Control> on cpu0
    ZFS filesystem version: 5
    ZFS storage pool version: features support (5000)
    Timecounters tick every 1.000 msec
    hdacc0: <Intel Haswell HDA CODEC> at cad 0 on hdac0
    hdaa0: <Intel Haswell Audio Function Group> at nid 1 on hdacc0
    pcm0: <Intel Haswell (HDMI/DP 8ch)> at nid 3 on hdaa0
    hdacc1: <Realtek ALC221 HDA CODEC> at cad 0 on hdac1
    hdaa1: <Realtek ALC221 Audio Function Group> at nid 1 on hdacc1
    pcm1: <Realtek ALC221 (Analog)> at nid 23 and 27,26 on hdaa1
    pcm2: <Realtek ALC221 (Analog 2.0+HP)> at nid 20,33 on hdaa1
    ugen0.1: <0x8086 XHCI root HUB> at usbus0
    Trying to mount root from zfs:zroot/ROOT/default []...
    Root mount waiting for: usbus0 usbus1 usbus2 CAM
    uhub0: <0x8086 XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus0
    ugen1.1: <Intel EHCI root HUB> at usbus1
    ugen2.1: <Intel EHCI root HUB> at usbus2
    uhub1: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus1
    uhub2: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus2
    ses0 at ahciem0 bus 0 scbus2 target 0 lun 0
    ses0: <AHCI SGPIO Enclosure 2.00 0001> SEMB S-E-S 2.00 device
    ses0: SEMB SES Device
    ada0 at ahcich2 bus 0 scbus1 target 0 lun 0
    ada0: <WDC WD10EFRX-68FYTN0 82.00A82> ACS-2 ATA SATA 3.x device
    ada0: Serial Number WD-WCC4J4JAJLNL
    ada0: 600.000MB/s transfers (SATA 3.x, UDMA6, PIO 8192bytes)
    ada0: Command Queueing enabled
    ada0: 953869MB (1953525168 512 byte sectors)
    ada0: quirks=0x1<4K>
    ses0: pass0,cd0 in 'Slot 01', SATA Slot: scbus0 target 0
    ses0: pass1,ada0 in 'Slot 02', SATA Slot: scbus1 target 0
    cd0 at ahcich1 bus 0 scbus0 target 0 lun 0
    cd0: <hp DVDRAM GTA0N HB03> Removable CD-ROM SCSI device
    cd0: Serial Number 424CP018175
    cd0: 150.000MB/s transfers (SATA 1.x, UDMA5, ATAPI 12bytes, PIO 8192bytes)
    cd0: Attempt to query device size failed: NOT READY, Medium not present - tray closed
    uhub0: 21 ports with 21 removable, self powered
    Root mount waiting for: usbus0 usbus1 usbus2
    uhub2: 3 ports with 3 removable, self powered
    uhub1: 3 ports with 3 removable, self powered
    ugen0.2: <Logitech USB Receiver> at usbus0
    ukbd0 on uhub0
    ukbd0: <Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 1> on usbus0
    kbd2 at ukbd0
    ugen1.2: <vendor 0x8087 product 0x8008> at usbus1
    uhub3 on uhub1
    uhub3: <vendor 0x8087 product 0x8008, class 9/0, rev 2.00/0.04, addr 2> on usbus1
    ugen2.2: <vendor 0x8087 product 0x8000> at usbus2
    uhub4 on uhub2
    uhub4: <vendor 0x8087 product 0x8000, class 9/0, rev 2.00/0.04, addr 2> on usbus2
    uhub3: 6 ports with 6 removable, self powered
    Root mount waiting for: usbus2
    uhub4: 8 ports with 8 removable, self powered
    bridge0: Ethernet address: 02:cb:af:39:8b:00
    lo0: link state changed to UP
    bridge0: link state changed to UP
    em0: promiscuous mode enabled
    em0: link state changed to UP
    ums0 on uhub0
    ums0: <Logitech USB Receiver, class 0/0, rev 2.00/29.01, addr 1> on usbus0
    ums0: 18 buttons and [XYZT] coordinates ID=2
    Security policy loaded: MAC/ntpd (mac_ntpd)
    --
    *# acpidump -t | grep -5 DMAR*
       DMAR: Length=184, Revision=1, Checksum=187,
             OEMID=INTEL, OEM Table ID=HSW, OEM Revision=0x1,
             Creator ID=INTL, Creator Revision=0x1
             Host Address Width=39
             Flags={INTR_REMAP}
    --
    *# cat /boot/loader.conf*
    kern.geom.label.disk_ident.enable="0"
    kern.geom.label.gptid.enable="0"
    opensolaris_load="YES"
    zfs_load="YES"
    xen_kernel="/boot/xen"
    xen_cmdline="iommu=debug,force dom0_mem=4096M dom0_max_vcpus=2 dom0=pvh console=com1,vga com1=115200,8n1 guest_loglvl=all loglvl=all"
    if_tap_load="YES"
    verbose_loading="YES"
    --
    *# sysrc -a*
    cloned_interfaces: bridge0
    dumpdev: AUTO
    hostname: freexen
    ifconfig_bridge0: addm em0 SYNCDHCP
    ifconfig_em0: up
    ifconfig_em0_ipv6: inet6 accept_rtadv
    ntpd_enable: YES
    ntpdate_enable: YES
    powerd_enable: YES
    sshd_enable: YES
    xen_kernel: /boot/xen
    xencommons_enable: YES
    zfs_enable: YES
    --
    # tail -2 c/sysctl.conf
    vfs.zfs.min_auto_ashift=12
    vm.max_wired=-1
    --
    *# tail -2 /etc/ttys*
    dcons   "/usr/libexec/getty std.9600"   vt100   off secure
    xc0  "/usr/libexec/getty Pc"  xterm  onifconsole secure
     

Regards, --
*Kevin Eliuk*
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-xen
To unsubscribe, send any mail to "[hidden email]"