[Fwd: Re: new error building jdk14]

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[Fwd: Re: new error building jdk14]

Richard Schilling-4

Sean McNeil wrote:

>
> For amd64, you must use java 1.5.  This is the only version available
> for that platform.  I have been using jdk1.5 for a long time now and it
> works very well for me.

I think I'll take that advice to heart.... :-)

I forced the build, thinking that the ONLY_FOR_ARCHS setting was
overlooked.  The reasoning being that the i386 code should compile fine
under gcc.  Lesson learned.....


>
> Also, you should consider moving to 6-current.  5.4 has issues with the
> linux emulation that cause building jdk1.5 a bit of a headache.  There
> are no such issues with 6-current.

Is 6-current stable enough to be used in production?  I'm having issues
getting a kernel compiled in 5.4 as well. Was kind of worried about
jumping to 6 until I knew what was wrong.

Thanks!


-- Richard

_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-java
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: [Fwd: Re: new error building jdk14]

Sean McNeil
On Fri, 2005-11-04 at 12:09 -0800, Richard Schilling wrote:

> Sean McNeil wrote:
>
> >
> > For amd64, you must use java 1.5.  This is the only version available
> > for that platform.  I have been using jdk1.5 for a long time now and it
> > works very well for me.
>
> I think I'll take that advice to heart.... :-)
>
> I forced the build, thinking that the ONLY_FOR_ARCHS setting was
> overlooked.  The reasoning being that the i386 code should compile fine
> under gcc.  Lesson learned.....
>
>
> >
> > Also, you should consider moving to 6-current.  5.4 has issues with the
> > linux emulation that cause building jdk1.5 a bit of a headache.  There
> > are no such issues with 6-current.
>
> Is 6-current stable enough to be used in production?  I'm having issues
> getting a kernel compiled in 5.4 as well. Was kind of worried about
> jumping to 6 until I knew what was wrong.

Please excuse the mistake, but it is no longer 6-current.  6-STABLE is
what I mean.

Many issues with 5.4 have been resolved in 6-STABLE.  It has been my
experience that 6 is much better on AMD64 than 5.4.  I have an Athlon 2X
on a Gigabyte motherboard that has been my primary machine for several
weeks now.  It has been very stable with the exception of TCP NFS.  I
would highly recommend the move.

Cheers,
Sean


_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-java
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: [Fwd: Re: new error building jdk14]

Greg Lewis-2
In reply to this post by Richard Schilling-4
On Fri, Nov 04, 2005 at 12:09:10PM -0800, Richard Schilling wrote:

> Sean McNeil wrote:
> >For amd64, you must use java 1.5.  This is the only version available
> >for that platform.  I have been using jdk1.5 for a long time now and it
> >works very well for me.
>
> I think I'll take that advice to heart.... :-)
>
> I forced the build, thinking that the ONLY_FOR_ARCHS setting was
> overlooked.  The reasoning being that the i386 code should compile fine
> under gcc.  Lesson learned.....

You could probably do it with a lot of messing around, but it would be
very painful.

> >Also, you should consider moving to 6-current.  5.4 has issues with the
> >linux emulation that cause building jdk1.5 a bit of a headache.  There
> >are no such issues with 6-current.
>
> Is 6-current stable enough to be used in production?  I'm having issues
> getting a kernel compiled in 5.4 as well. Was kind of worried about
> jumping to 6 until I knew what was wrong.

6.0 has just been released and is almost universally being reported as
more stable than 5.4.

--
Greg Lewis                          Email   : [hidden email]
Eyes Beyond                         Web     : http://www.eyesbeyond.com
Information Technology              FreeBSD : [hidden email]
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-java
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: [Fwd: Re: new error building jdk14]

Richard Schilling-4
In reply to this post by Sean McNeil

Sean McNeil wrote:
>

<snip>

>
> Please excuse the mistake, but it is no longer 6-current.  6-STABLE is
> what I mean.
>
> Many issues with 5.4 have been resolved in 6-STABLE.  It has been my
> experience that 6 is much better on AMD64 than 5.4.  I have an Athlon 2X
> on a Gigabyte motherboard that has been my primary machine for several
> weeks now.  It has been very stable with the exception of TCP NFS.  I
> would highly recommend the move.
>

I'm making the transition this weekend, but I have a lot of dependencies
to take into account ... it's going to continue to be painful in my
case, unfortunately.

Having trouble getting RELENG_6 to build at the moment..... :-(

Richard

> Cheers,
> Sean
>
>
>
>
>

_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-java
To unsubscribe, send any mail to "[hidden email]"