Mixer failure after MATE upgrade to 1.10.0

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Mixer failure after MATE upgrade to 1.10.0

Kevin Oberman-4
I have "successfully" completed the update to ATE-1.10.0, but I get a
startup error that the MixerAppletFactory:MixerApplet failed. I see that I
have two Mixer files,
/usr/local/share/dbus-1/services/org.mate.panel.applet.MixerAppletFactory.service
and
/usr/local/share/dbus-1/services/org.mate.panel.applet.MixerAppletFactory.service,
but "pkg which" reports that they were not found in the database.

More relevant is that I don't seem to have a mixer, now. pkg info "*mixer*"
shows no matches. I do have an applet in my panel that allows volume
adjustment, muting,  and Preferences.

Is the mixer applet gone or am does something need to be installed? I
assumed that it was a part of mate-applets.
--
Kevin Oberman, Network Engineer, Retired
E-mail: [hidden email]
PGP Fingerprint: D03FB98AFA78E3B78C1694B318AB39EF1B055683
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Mixer failure after MATE upgrade to 1.10.0

Koop Mast-2
Hey Kevin,

On 29-7-2015 0:09, Kevin Oberman wrote:
> I have "successfully" completed the update to ATE-1.10.0, but I get a
> startup error that the MixerAppletFactory:MixerApplet failed. I see that I
> have two Mixer files,
> /usr/local/share/dbus-1/services/org.mate.panel.applet.MixerAppletFactory.service
> and
> /usr/local/share/dbus-1/services/org.mate.panel.applet.MixerAppletFactory.service,
> but "pkg which" reports that they were not found in the database.

Those files seem to be leftovers and can probably removed.

> More relevant is that I don't seem to have a mixer, now. pkg info "*mixer*"
> shows no matches. I do have an applet in my panel that allows volume
> adjustment, muting,  and Preferences.
>
> Is the mixer applet gone or am does something need to be installed? I
> assumed that it was a part of mate-applets.

Could you try mate-volume-control and mate-volume-control-applet from
the mate-media package?

-Koop

> --
> Kevin Oberman, Network Engineer, Retired
> E-mail: [hidden email]
> PGP Fingerprint: D03FB98AFA78E3B78C1694B318AB39EF1B055683
> _______________________________________________
> [hidden email] mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-gnome
> To unsubscribe, send any mail to "[hidden email]"

_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Mixer failure after MATE upgrade to 1.10.0

Kevin Oberman-4
On Wed, Jul 29, 2015 at 9:34 AM, Koop Mast <[hidden email]> wrote:

> Hey Kevin,
>
> On 29-7-2015 0:09, Kevin Oberman wrote:
> > I have "successfully" completed the update to ATE-1.10.0, but I get a
> > startup error that the MixerAppletFactory:MixerApplet failed. I see that
> I
> > have two Mixer files,
> >
> /usr/local/share/dbus-1/services/org.mate.panel.applet.MixerAppletFactory.service
> > and
> >
> /usr/local/share/dbus-1/services/org.mate.panel.applet.MixerAppletFactory.service,
> > but "pkg which" reports that they were not found in the database.
>
> Those files seem to be leftovers and can probably removed.
>
> > More relevant is that I don't seem to have a mixer, now. pkg info
> "*mixer*"
> > shows no matches. I do have an applet in my panel that allows volume
> > adjustment, muting,  and Preferences.
> >
> > Is the mixer applet gone or am does something need to be installed? I
> > assumed that it was a part of mate-applets.
>
> Could you try mate-volume-control and mate-volume-control-applet from
> the mate-media package?
>
> -Koop
>

The exact error I get is:
The panel encountered a problem while loading
"MixerAppletFactory::MixerApplet".

I can run mate-volume-control but it lacks a mixer. The applet is already
running, but offers no mixer, either.

Along with the clock, battery, and hplip applets, it is in the far right
portion of the top panel and seems to be neither movable nor removable. Of
these, only the clock seem to be present in the list presented by "Add to
panel". Could my database for the panel be corrupt in some way?

In any case, I just noticed that the MixerAppletFactory files are found by
"locate", but don't exist. So they were present last Saturday when the
locateDB was updated, but must have been deleted by the mate-1.10 upgrade.
So it looks like the only mixer is the command line one (mixer(1)). I am
baffled as to why this would be eliminated.

Looks like I am probably stuck. Thanks, anyway.
--
Kevin Oberman, Network Engineer, Retired
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"