Package `xfce4-goodies` does not fully install all of its dependencies?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Package `xfce4-goodies` does not fully install all of its dependencies?

Hyun Hwang-2
Hi,

Installed `xfce4-goodies` package, but few of its [run dependencies](https://www.freshports.org/x11/xfce4-goodies/) are missing. For example, `xfce4-volumed` and `xfce4-mixer` should have been installed as part of xfce4-goodies, but:

```
hyunh@americano:~ % pkg version | grep xfce4
libxfce4menu-4.12.1_1              =
libxfce4util-4.12.1                =
xfce4-appfinder-4.12.0             =
xfce4-battery-plugin-1.1.1         =
xfce4-bsdcpufreq-plugin-0.2_1      =
xfce4-clipman-plugin-1.4.2_1       =
xfce4-conf-4.12.1                  =
xfce4-cpugraph-plugin-1.0.5_4      =
xfce4-dashboard-0.6.1_1            =
xfce4-datetime-plugin-0.7.0        =
xfce4-desktop-4.12.4               =
xfce4-dict-plugin-0.8.1            =
xfce4-diskperf-plugin-2.6.1        =
xfce4-embed-plugin-1.6.0           =
xfce4-fsguard-plugin-1.1.0         =
xfce4-genmon-plugin-4.0.1          =
xfce4-goodies-4.12_2               =
xfce4-mount-plugin-1.1.3           =
xfce4-netload-plugin-1.3.1         =
xfce4-notifyd-0.4.2                =
xfce4-panel-4.12.2                 =
xfce4-power-manager-1.6.1          =
xfce4-screenshooter-plugin-1.9.3   =
xfce4-session-4.12.1_4             =
xfce4-settings-4.12.4_2            =
xfce4-smartbookmark-plugin-0.5.0   =
xfce4-systemload-plugin-1.2.1      =
xfce4-taskmanager-1.2.1_1          =
xfce4-terminal-0.8.7.4_1           =
xfce4-time-out-plugin-1.0.2_1      =
xfce4-timer-plugin-1.7.0_1         =
xfce4-tumbler-0.2.3                =
xfce4-verve-plugin-1.1.1           =
xfce4-wavelan-plugin-0.6.0_1       =
xfce4-whiskermenu-plugin-2.3.0     =
xfce4-wm-4.12.5                    =
hyunh@americano:~ %
hyunh@americano:~ %
hyunh@americano:~ %
hyunh@americano:~ %
hyunh@americano:~ % doas pkg install xfce4-volumed xfce4-mixer
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
pkg: gstreamer1-plugins-lame has a missing dependency: lame
The following 55 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        xfce4-volumed: 0.1.13_2
        xfce4-mixer: 4.11.0_3
        gstreamer1-plugins-flac: 1.12.3
        flac: 1.3.2
        gstreamer1-plugins-faac: 1.12.3
        faac: 1.29.9.2_1
        gigolo: 0.4.2_1
        xfce4-equake-plugin: 1.3.8.1
        parole: 1.0.1
        gstreamer1-plugins-x: 1.12.3
        gstreamer1-plugins-rtmp: 1.12.3
        librtmp: 2.4.20151223
        gstreamer1-plugins-core: 1.12
        gstreamer1-plugins-pango: 1.12.3
        gstreamer1-plugins-theora: 1.12.3
        gstreamer1-plugins-resindvd: 1.12.3
        libdvdread: 6.0.0
        libdvdnav: 6.0.0
        gstreamer1-plugins-dvdread: 1.12.3
        gstreamer1-plugins-dts: 1.12.3
        libdca: 0.0.6
        gstreamer1-libav: 1.12.3_2
        gstreamer1-plugins-png: 1.12.3
        gstreamer1-plugins-mpg123: 1.12.3
        mpg123: 1.25.10
        gstreamer1-plugins-a52dec: 1.12.3
        liba52: 0.7.4_3
        gstreamer1-plugins-soup: 1.12.3
        taglib: 1.11.1_1
        gstreamer1-plugins-faad: 1.12.3
        faad2: 2.8.8,1
        xfce4-wm-themes: 4.10.0_1
        xfce4-weather-plugin: 0.9.0
        xfce4-calculator-plugin: 0.6.0
        xfce4-mailwatch-plugin: 1.2.0_8
        ristretto: 0.8.3
        thunar-vcs-plugin: 0.1.5
        subversion: 1.10.2_1
        serf: 1.3.9_3
        apr: 1.6.3.1.6.1_1
        db5: 5.3.28_7
        utf8proc: 2.1.0
        xfce4-xkb-plugin: 0.8.1
        xfce4-notes-plugin: 1.8.1
        unique: 1.1.6_7
        thunar-media-tags-plugin: 0.2.1_4
        thunar-archive-plugin: 0.3.1_4
        keybinder: 0.3.1_2
        py27-gtk2: 2.24.0_5
        py27-cairo: 1.14.1
        py27-gobject: 2.28.6_8
        libglade2: 2.6.4_9
        gstreamer-plugins: 0.10.36_11,3
        gstreamer: 0.10.36_6
        gstreamer-plugins-good: 0.10.31_3,3

Number of packages to be installed: 55

The process will require 154 MiB more space.
34 MiB to be downloaded.

Proceed with this action? [y/N]:
```

Can anyone tell me what is wrong?

Thank you,
--
Hyun Hwang
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-xfce
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Package `xfce4-goodies` does not fully install all of its dependencies?

Guido Falsi-7
On 10/10/18 23:56, Hyun Hwang wrote:
> Hi,
>
> Installed `xfce4-goodies` package, but few of its [run dependencies](https://www.freshports.org/x11/xfce4-goodies/) are missing. For example, `xfce4-volumed` and `xfce4-mixer` should have been installed as part of xfce4-goodies, but:

Some more information is needed to check this.

version of FreeBSD? Are you using latest binary packages? Quarterly? Own
repo?

Anyway I also see that plugin not being installed in a test VM, using
the latest and quarterly repository on 11.2 amd64, command 'pkg install
xfce4-goodies'

A quick look at the downloaded package content and the repo manifest
show the dependency as being registered there, so I'm not sure what's
happening.

passing -ddd to pkg for debug output shows it's discarding a bunch of
packages with lines like:

DBG(2)[758]> cannot find variable dependency xfce4-mixer

this sends me to this line in pkg sources:

https://github.com/freebsd/pkg/blob/16207928cbdbd8e950071e6067f8bc5a0a621856/libpkg/pkg_solve.c#L381

I have no idea why this is happening. I'm CCing the pkg mailing list,
just in case someone has some insight.

>
> ```
> hyunh@americano:~ % pkg version | grep xfce4
> libxfce4menu-4.12.1_1              =
> libxfce4util-4.12.1                =
> xfce4-appfinder-4.12.0             =
> xfce4-battery-plugin-1.1.1         =
> xfce4-bsdcpufreq-plugin-0.2_1      =
> xfce4-clipman-plugin-1.4.2_1       =
> xfce4-conf-4.12.1                  =
> xfce4-cpugraph-plugin-1.0.5_4      =
> xfce4-dashboard-0.6.1_1            =
> xfce4-datetime-plugin-0.7.0        =
> xfce4-desktop-4.12.4               =
> xfce4-dict-plugin-0.8.1            =
> xfce4-diskperf-plugin-2.6.1        =
> xfce4-embed-plugin-1.6.0           =
> xfce4-fsguard-plugin-1.1.0         =
> xfce4-genmon-plugin-4.0.1          =
> xfce4-goodies-4.12_2               =
> xfce4-mount-plugin-1.1.3           =
> xfce4-netload-plugin-1.3.1         =
> xfce4-notifyd-0.4.2                =
> xfce4-panel-4.12.2                 =
> xfce4-power-manager-1.6.1          =
> xfce4-screenshooter-plugin-1.9.3   =
> xfce4-session-4.12.1_4             =
> xfce4-settings-4.12.4_2            =
> xfce4-smartbookmark-plugin-0.5.0   =
> xfce4-systemload-plugin-1.2.1      =
> xfce4-taskmanager-1.2.1_1          =
> xfce4-terminal-0.8.7.4_1           =
> xfce4-time-out-plugin-1.0.2_1      =
> xfce4-timer-plugin-1.7.0_1         =
> xfce4-tumbler-0.2.3                =
> xfce4-verve-plugin-1.1.1           =
> xfce4-wavelan-plugin-0.6.0_1       =
> xfce4-whiskermenu-plugin-2.3.0     =
> xfce4-wm-4.12.5                    =
> hyunh@americano:~ %
> hyunh@americano:~ %
> hyunh@americano:~ %
> hyunh@americano:~ %
> hyunh@americano:~ % doas pkg install xfce4-volumed xfce4-mixer
> Updating FreeBSD repository catalogue...
> FreeBSD repository is up to date.
> All repositories are up to date.
> pkg: gstreamer1-plugins-lame has a missing dependency: lame

Uhm, this could be related in some way.

> The following 55 package(s) will be affected (of 0 checked):
>
> New packages to be INSTALLED:
> xfce4-volumed: 0.1.13_2
> xfce4-mixer: 4.11.0_3
> gstreamer1-plugins-flac: 1.12.3
> flac: 1.3.2
> gstreamer1-plugins-faac: 1.12.3
> faac: 1.29.9.2_1
> gigolo: 0.4.2_1
> xfce4-equake-plugin: 1.3.8.1
> parole: 1.0.1
> gstreamer1-plugins-x: 1.12.3
> gstreamer1-plugins-rtmp: 1.12.3
> librtmp: 2.4.20151223
> gstreamer1-plugins-core: 1.12
> gstreamer1-plugins-pango: 1.12.3
> gstreamer1-plugins-theora: 1.12.3
> gstreamer1-plugins-resindvd: 1.12.3
> libdvdread: 6.0.0
> libdvdnav: 6.0.0
> gstreamer1-plugins-dvdread: 1.12.3
> gstreamer1-plugins-dts: 1.12.3
> libdca: 0.0.6
> gstreamer1-libav: 1.12.3_2
> gstreamer1-plugins-png: 1.12.3
> gstreamer1-plugins-mpg123: 1.12.3
> mpg123: 1.25.10
> gstreamer1-plugins-a52dec: 1.12.3
> liba52: 0.7.4_3
> gstreamer1-plugins-soup: 1.12.3
> taglib: 1.11.1_1
> gstreamer1-plugins-faad: 1.12.3
> faad2: 2.8.8,1
> xfce4-wm-themes: 4.10.0_1
> xfce4-weather-plugin: 0.9.0
> xfce4-calculator-plugin: 0.6.0
> xfce4-mailwatch-plugin: 1.2.0_8
> ristretto: 0.8.3
> thunar-vcs-plugin: 0.1.5
> subversion: 1.10.2_1
> serf: 1.3.9_3
> apr: 1.6.3.1.6.1_1
> db5: 5.3.28_7
> utf8proc: 2.1.0
> xfce4-xkb-plugin: 0.8.1
> xfce4-notes-plugin: 1.8.1
> unique: 1.1.6_7
> thunar-media-tags-plugin: 0.2.1_4
> thunar-archive-plugin: 0.3.1_4
> keybinder: 0.3.1_2
> py27-gtk2: 2.24.0_5
> py27-cairo: 1.14.1
> py27-gobject: 2.28.6_8
> libglade2: 2.6.4_9
> gstreamer-plugins: 0.10.36_11,3
> gstreamer: 0.10.36_6
> gstreamer-plugins-good: 0.10.31_3,3
>

This list also includes other packages skipped by the previous command
not related to this one, so it looks like pkg, in this further run, is
recovering from skipping parts in the previous run

> Number of packages to be installed: 55
>
> The process will require 154 MiB more space.
> 34 MiB to be downloaded.
>
> Proceed with this action? [y/N]:
> ```
>
> Can anyone tell me what is wrong?
>
> Thank you,
>


--
Guido Falsi <[hidden email]>
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-xfce
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Package `xfce4-goodies` does not fully install all of its dependencies?

Hyun Hwang-2
Hi,

On Thursday, October 11, 2018, 9:56 AM (UTC+0200), Guido Falsi <[hidden email]> wrote:
> version of FreeBSD? Are you using latest binary packages? Quarterly? Own
> repo?

My machine is running FreeBSD 12.0-ALPHA9 r339274, with pkg pulling things from `pkg+http://pkg.freebsd.org/FreeBSD:12:amd64/latest` IIRC. Every package installed on my machine was up-to-date, including the pkg itself.

> > pkg: gstreamer1-plugins-lame has a missing dependency: lame
>
> Uhm, this could be related in some way.

Possibly? I have no idea how could this happen in pkg; it's not like I can mangle package dependencies as in Ports tree.

> This list also includes other packages skipped by the previous command
> not related to this one, so it looks like pkg, in this further run, is
> recovering from skipping parts in the previous run

Yes, only when I forced it to install those skipped ones.


Right now I do not have xfce4 installed (as I was testing DEs), but if you need more info (or possibly testing further) I probably can install another inside bhyve and do that, so tell me if so.

Thank you,
--
Hyun Hwang
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-xfce
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Package `xfce4-goodies` does not fully install all of its dependencies?

Guido Falsi-7
On 11/10/18 10:47, Hyun Hwang wrote:
> Hi,
>
> On Thursday, October 11, 2018, 9:56 AM (UTC+0200), Guido Falsi <[hidden email]> wrote:
>> version of FreeBSD? Are you using latest binary packages? Quarterly? Own
>> repo?
>
> My machine is running FreeBSD 12.0-ALPHA9 r339274, with pkg pulling things from `pkg+http://pkg.freebsd.org/FreeBSD:12:amd64/latest` IIRC. Every package installed on my machine was up-to-date, including the pkg itself.
>

At present packages for 12 could have other problems due to the OpenSSL
thing, but since I was able to reproduce this in 11.2 this is not caused
by that.

>>> pkg: gstreamer1-plugins-lame has a missing dependency: lame
>>
>> Uhm, this could be related in some way.
>
> Possibly? I have no idea how could this happen in pkg; it's not like I can mangle package dependencies as in Ports tree.
>

Not sure, But this missing dependency could be breaking the chain that
causes the other ones not to be installed. All the packages missing are
multimedia related. volumed, mixer, gigolo. So it looks reasonable.

--
Guido Falsi <[hidden email]>
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-xfce
To unsubscribe, send any mail to "[hidden email]"