Re: Dell R630 unable to detect USB, can't boot

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Dell R630 unable to detect USB, can't boot

Hans Petter Selasky-6
On 02/13/18 14:45, Hans Petter Selasky wrote:

> On 02/04/18 23:47, Lee Brown wrote:
>> Booting FreeBSD11.1-RELENG from a USB stick, loader works fine keyboard
>> allows selection, kernel loads and starts OK, gets as far as detecting
>> USB
>> devices and stops there.  imgur <https://imgur.com/a/psn0H> for a
>> screenshot.  Tried safe mode same occurrence.
>>
>> CDROM is via a USB, so that's a no go and I've not had luck booting UEFI
>> iSCSI nor PXE yet, so I'm stuck without a keyboard (no PS/2
>> connectors) or
>> essentially any boot media.
>>
>> For reference Xen 7.2 is running fine so at first blush it's not faulty
>> hardware.
>> USB3 mode on and off (ie force USB2) in the BIOS makes no difference.
>> All Firmwares current.
>>
>> Any suggestions on how to move forward with this?  I tried turning on
>> verbose mode, but I'm not sure how to capture that nor where to look.
>>
>
> Hi,
>
> USB_ERR_TIMEOUT might be an indication of a PCI IRQ issue.
>

Try to set:

hw.usb.xhci.use_polling=1

from the loader as a temporary quirk. Then try to dump information about
IRQ's like "vmstat -i" "dmesg" and so on.

--HPS

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-hardware
To unsubscribe, send any mail to "[hidden email]"