Re : Re: building gnome2 on freebsd6-stable

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re : Re: building gnome2 on freebsd6-stable

Didier Wiroth
thanks for replying.

No, I actually did not have gnome installed, as I'm running fluxbox but may be I had some sub-gnome ports installed that I didn't notice and that are responsible for the build failure.

May be I should uninstall all *gnome* ports and restart.

Best regards,
Didier

----- Message d'origine -----
De: Paul Root <[hidden email]>
Date: Samedi, Novembre 19, 2005 11:26 pm
Objet: Re: building gnome2 on freebsd6-stable

> Did you have gnome in before and you started to
> try to build it?
>
> Go to http://www.freebsd.org/gnome. There is an
> upgrade script there. I used it partially, it got
> me about half way. Turned out that I had an ethernet
> speed/duplex issue much of the time, and was having
> trouble downloading.
>
> After a day of manually downloading (ftp worked, fetch,
> which is used by the script had trouble) and restarting the
> script, I gave up on it and used portmanager. That worked
> better, but still had a couple of issues.
>
> About this time, I got the duplex issue fixed on the switch,
> and then went back to /usr/ports/x11/gnome2 and from there
> everything worked.
>
> The problem is that you'll get out of order with dependancies
> if you just start in /usr/ports/x11/gnome2.
>
>
> I'm having one problem with gnome 2.12. The screensaver won't
> start up. It complains about  not being able to contact the
> messagebus. Any help here?
>
>
>
> Didier Wiroth wrote:
> > ***********************
> > This message has been scanned by the InterScan for CSC-SSM and
> found to be free of known security risks.
> > ***********************
> >
> >
> > hi,
> >
> > I tried to build gnome2 on freebsd6 stable.
> >
> > It fails when it tries to compile gnomeapllets2, here is the output:
> > --------------START SNIP-------------
> > 12.1/drivemount/help'
> > if ! test -d es/; then mkdir es/; fi
> > if test -f "C/drivemount.xml"; then d="../"; else d=".././"; fi; \
> > (cd es/ && \
> >   `which xml2po` -e -p \
> >     ${d}es/es.po \
> >     ${d}C/drivemount.xml > drivemount.xml.tmp && \
> >     cp drivemount.xml.tmp drivemount.xml && rm -f
> drivemount.xml.tmp)> Traceback (most recent call last):
> >   File "/usr/X11R6/bin/xml2po", line 34, in ?
> >     import libxml2
> >   File "/usr/local/lib/python2.4/site-packages/libxml2.py", line
> 1, in ?
> >     import libxml2mod
> > ImportError: /usr/local/lib/python2.4/site-
> packages/libxml2mod.so: Undefined symbol "xmlParseURIRaw"
> > gmake[3]: *** [es/drivemount.xml] Error 1
> > gmake[3]: Leaving directory
> `/usr/ports/x11/gnomeapplets2/work/gnome-applets-
> 2.12.1/drivemount/help'> gmake[2]: *** [all-recursive] Error 1
> > gmake[2]: Leaving directory
> `/usr/ports/x11/gnomeapplets2/work/gnome-applets-2.12.1/drivemount'
> > gmake[1]: *** [all-recursive] Error 1
> > gmake[1]: Leaving directory
> `/usr/ports/x11/gnomeapplets2/work/gnome-applets-2.12.1'
> > gmake: *** [all] Error 2
> > *** Error code 2
> >
> > Stop in /usr/ports/x11/gnomeapplets2.
> > *** Error code 1
> >
> > Stop in /usr/ports/x11/gnome2.
> > -----------------STOP SNIP----------------------
> >
> > What can I do to solve the problem?
> >
> > thanks a lot
> > didier
> >
> > _______________________________________________
> > [hidden email] mailing list
> > http://lists.freebsd.org/mailman/listinfo/freebsd-stable
> > To unsubscribe, send any mail to "freebsd-stable-
> [hidden email]"
>

_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-stable
To unsubscribe, send any mail to "[hidden email]"