Re: svn commit: r402209 - in head: devel/appstream-glib games/aisleriot x11/gnome-terminal

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: svn commit: r402209 - in head: devel/appstream-glib games/aisleriot x11/gnome-terminal

Tomoaki AOKI
devel/appstream-glib fails configure with glib-2.0 version mismatch.

Updating devel/glib20 to sufficient version or reverting
devel/appstream-glib is required.

(snip)
> checking for GLIB... no
> configure: error: Package requirements (glib-2.0 >= 2.45.8 gio-2.0
> gobject-2.0 gthread-2.0 gio-unix-2.0 gmodule-2.0) were not met:
>
> Package dependency requirement 'glib-2.0 >= 2.45.8' could not be
> satisfied. Package 'glib-2.0' has version '2.44.1', required version is
> '>= 2.45.8'

> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> installed software in a non-standard prefix.
>
> Alternatively, you may set the environment variables GLIB_CFLAGS
> and GLIB_LIBS to avoid the need to call pkg-config.
> See the pkg-config man page for more details.
> ===>  Script "configure" failed unexpectedly.
> Please report the problem to [hidden email] [maintainer] and attach
> the
> "/usr/ports/devel/appstream-glib/work/appstream-glib-0.5.4/config.log"
> including the output of the failure of your make command. Also, it
> might be a good idea to provide an overview of all packages installed
> on your system (e.g. a /usr/local/sbin/pkg-static info -g -Ea). ***
> Error code 1
>
> Stop.
> make[1]: stopped in /usr/ports/devel/appstream-glib
> *** Error code 1
>
> Stop.
> make: stopped in /usr/ports/devel/appstream-glib
config.log is attached. (tar + xz compressed)


> Author: kwm
> Date: Sun Nov 22 00:52:13 2015
> New Revision: 402209
> URL: https://svnweb.freebsd.org/changeset/ports/402209
>
> Log:
>   Update appstream-glib to 0.5.4.
>  
>   Switch from custom code to using USES=libarchive.
>   Adjust BUILD_DEPEND lines in where needed.
>
> Modified:
>   head/devel/appstream-glib/Makefile
>   head/devel/appstream-glib/distinfo
>   head/devel/appstream-glib/pkg-plist
>   head/games/aisleriot/Makefile
>   head/x11/gnome-terminal/Makefile
>
> Modified: head/devel/appstream-glib/Makefile
> ==============================================================================
> --- head/devel/appstream-glib/Makefile Sun Nov 22 00:51:14
> 2015 (r402208) +++ head/devel/appstream-glib/Makefile Sun
> Nov 22 00:52:13 2015 (r402209) @@ -2,7 +2,7 @@
>  # $FreeBSD$
>  
>  PORTNAME= appstream-glib
> -PORTVERSION= 0.4.1
> +PORTVERSION= 0.5.4
>  CATEGORIES= devel
>  MASTER_SITES=
> http://people.freedesktop.org/~hughsient/appstream-glib/releases/
> DIST_SUBDIR= gnome3 @@ -21,7 +21,8 @@ LIB_DEPENDS=
> libsoup-2.4.so:${PORTSDIR}/ libfreetype.so:${PORTSDIR}/print/freetype2
>  RUN_DEPENDS= gcab:${PORTSDIR}/archivers/gcab
>  
> -USES= gettext gperf gmake libtool pathfix pkgconfigtar:xz
> +USES= gettext gperf gmake libarchive libtool pathfix \
> + pkgconfig tar:xz
>  USE_GNOME= gdkpixbuf2 glib20 gtk30 intlhack introspection:build \
> libxml2:build pango
>  USE_LDCONFIG= yes
> @@ -44,10 +45,6 @@ MANPAGES_USE= GNOME=libxslt:build
>  
>  .include <bsd.port.options.mk>
>  
> -.if !exists(/usr/libdata/pkgconfig/libarchive.pc)
> -LIB_DEPENDS+= libarchive.so.13:${PORTSDIR}/archivers/libarchive
> -.endif
> -
>  .if ${OSVERSION} < 1000000 && ${OPSYS} == FreeBSD
>  post-patch:
>   ${REINPLACE_CMD} -e 's|-Wtype-limits||g' \
>
(snip)


--
Tomoaki AOKI    [hidden email]

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"

config.log.txz (21K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: svn commit: r402209 - in head: devel/appstream-glib games/aisleriot x11/gnome-terminal

Koop Mast-2
On 22/11/2015 11:03, Tomoaki AOKI wrote:
> devel/appstream-glib fails configure with glib-2.0 version mismatch.
>
> Updating devel/glib20 to sufficient version or reverting
> devel/appstream-glib is required.

Yes my bad, I already reverted the aptstream-glib update.
Please update your ports tree and try again.

-Koop

>
> (snip)
>> checking for GLIB... no
>> configure: error: Package requirements (glib-2.0 >= 2.45.8 gio-2.0
>> gobject-2.0 gthread-2.0 gio-unix-2.0 gmodule-2.0) were not met:
>>
>> Package dependency requirement 'glib-2.0 >= 2.45.8' could not be
>> satisfied. Package 'glib-2.0' has version '2.44.1', required version is
>> '>= 2.45.8'
>> Consider adjusting the PKG_CONFIG_PATH environment variable if you
>> installed software in a non-standard prefix.
>>
>> Alternatively, you may set the environment variables GLIB_CFLAGS
>> and GLIB_LIBS to avoid the need to call pkg-config.
>> See the pkg-config man page for more details.
>> ===>  Script "configure" failed unexpectedly.
>> Please report the problem to [hidden email] [maintainer] and attach
>> the
>> "/usr/ports/devel/appstream-glib/work/appstream-glib-0.5.4/config.log"
>> including the output of the failure of your make command. Also, it
>> might be a good idea to provide an overview of all packages installed
>> on your system (e.g. a /usr/local/sbin/pkg-static info -g -Ea). ***
>> Error code 1
>>
>> Stop.
>> make[1]: stopped in /usr/ports/devel/appstream-glib
>> *** Error code 1
>>
>> Stop.
>> make: stopped in /usr/ports/devel/appstream-glib
> config.log is attached. (tar + xz compressed)
>
>
>> Author: kwm
>> Date: Sun Nov 22 00:52:13 2015
>> New Revision: 402209
>> URL: https://svnweb.freebsd.org/changeset/ports/402209
>>
>> Log:
>>    Update appstream-glib to 0.5.4.
>>  
>>    Switch from custom code to using USES=libarchive.
>>    Adjust BUILD_DEPEND lines in where needed.
>>
>> Modified:
>>    head/devel/appstream-glib/Makefile
>>    head/devel/appstream-glib/distinfo
>>    head/devel/appstream-glib/pkg-plist
>>    head/games/aisleriot/Makefile
>>    head/x11/gnome-terminal/Makefile
>>
>> Modified: head/devel/appstream-glib/Makefile
>> ==============================================================================
>> --- head/devel/appstream-glib/Makefile Sun Nov 22 00:51:14
>> 2015 (r402208) +++ head/devel/appstream-glib/Makefile Sun
>> Nov 22 00:52:13 2015 (r402209) @@ -2,7 +2,7 @@
>>   # $FreeBSD$
>>  
>>   PORTNAME= appstream-glib
>> -PORTVERSION= 0.4.1
>> +PORTVERSION= 0.5.4
>>   CATEGORIES= devel
>>   MASTER_SITES=
>> http://people.freedesktop.org/~hughsient/appstream-glib/releases/
>> DIST_SUBDIR= gnome3 @@ -21,7 +21,8 @@ LIB_DEPENDS=
>> libsoup-2.4.so:${PORTSDIR}/ libfreetype.so:${PORTSDIR}/print/freetype2
>>   RUN_DEPENDS= gcab:${PORTSDIR}/archivers/gcab
>>  
>> -USES= gettext gperf gmake libtool pathfix pkgconfigtar:xz
>> +USES= gettext gperf gmake libarchive libtool pathfix \
>> + pkgconfig tar:xz
>>   USE_GNOME= gdkpixbuf2 glib20 gtk30 intlhack introspection:build \
>> libxml2:build pango
>>   USE_LDCONFIG= yes
>> @@ -44,10 +45,6 @@ MANPAGES_USE= GNOME=libxslt:build
>>  
>>   .include <bsd.port.options.mk>
>>  
>> -.if !exists(/usr/libdata/pkgconfig/libarchive.pc)
>> -LIB_DEPENDS+= libarchive.so.13:${PORTSDIR}/archivers/libarchive
>> -.endif
>> -
>>   .if ${OSVERSION} < 1000000 && ${OPSYS} == FreeBSD
>>   post-patch:
>>   ${REINPLACE_CMD} -e 's|-Wtype-limits||g' \
>>
> (snip)
>
>
>
>
> _______________________________________________
> [hidden email] mailing list
> https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
> To unsubscribe, send any mail to "[hidden email]"

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: svn commit: r402209 - in head: devel/appstream-glib games/aisleriot x11/gnome-terminal

Tomoaki AOKI
Confirmed reverted and goes OK. Thanks!

On Sun, 22 Nov 2015 13:08:06 +0100
Koop Mast <[hidden email]> wrote:

> On 22/11/2015 11:03, Tomoaki AOKI wrote:
> > devel/appstream-glib fails configure with glib-2.0 version mismatch.
> >
> > Updating devel/glib20 to sufficient version or reverting
> > devel/appstream-glib is required.
>
> Yes my bad, I already reverted the aptstream-glib update.
> Please update your ports tree and try again.
>
> -Koop
> >
> > (snip)
> >> checking for GLIB... no
> >> configure: error: Package requirements (glib-2.0 >= 2.45.8 gio-2.0
> >> gobject-2.0 gthread-2.0 gio-unix-2.0 gmodule-2.0) were not met:
> >>
> >> Package dependency requirement 'glib-2.0 >= 2.45.8' could not be
> >> satisfied. Package 'glib-2.0' has version '2.44.1', required version is
> >> '>= 2.45.8'
> >> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> >> installed software in a non-standard prefix.
> >>
> >> Alternatively, you may set the environment variables GLIB_CFLAGS
> >> and GLIB_LIBS to avoid the need to call pkg-config.
> >> See the pkg-config man page for more details.
> >> ===>  Script "configure" failed unexpectedly.
> >> Please report the problem to [hidden email] [maintainer] and attach
> >> the
> >> "/usr/ports/devel/appstream-glib/work/appstream-glib-0.5.4/config.log"
> >> including the output of the failure of your make command. Also, it
> >> might be a good idea to provide an overview of all packages installed
> >> on your system (e.g. a /usr/local/sbin/pkg-static info -g -Ea). ***
> >> Error code 1
> >>
> >> Stop.
> >> make[1]: stopped in /usr/ports/devel/appstream-glib
> >> *** Error code 1
> >>
> >> Stop.
> >> make: stopped in /usr/ports/devel/appstream-glib
> > config.log is attached. (tar + xz compressed)
> >
> >
> >> Author: kwm
> >> Date: Sun Nov 22 00:52:13 2015
> >> New Revision: 402209
> >> URL: https://svnweb.freebsd.org/changeset/ports/402209
> >>
> >> Log:
> >>    Update appstream-glib to 0.5.4.
> >>  
> >>    Switch from custom code to using USES=libarchive.
> >>    Adjust BUILD_DEPEND lines in where needed.
> >>
> >> Modified:
> >>    head/devel/appstream-glib/Makefile
> >>    head/devel/appstream-glib/distinfo
> >>    head/devel/appstream-glib/pkg-plist
> >>    head/games/aisleriot/Makefile
> >>    head/x11/gnome-terminal/Makefile
> >>
> >> Modified: head/devel/appstream-glib/Makefile
> >> ==============================================================================
> >> --- head/devel/appstream-glib/Makefile Sun Nov 22 00:51:14
> >> 2015 (r402208) +++ head/devel/appstream-glib/Makefile Sun
> >> Nov 22 00:52:13 2015 (r402209) @@ -2,7 +2,7 @@
> >>   # $FreeBSD$
> >>  
> >>   PORTNAME= appstream-glib
> >> -PORTVERSION= 0.4.1
> >> +PORTVERSION= 0.5.4
> >>   CATEGORIES= devel
> >>   MASTER_SITES=
> >> http://people.freedesktop.org/~hughsient/appstream-glib/releases/
> >> DIST_SUBDIR= gnome3 @@ -21,7 +21,8 @@ LIB_DEPENDS=
> >> libsoup-2.4.so:${PORTSDIR}/ libfreetype.so:${PORTSDIR}/print/freetype2
> >>   RUN_DEPENDS= gcab:${PORTSDIR}/archivers/gcab
> >>  
> >> -USES= gettext gperf gmake libtool pathfix pkgconfigtar:xz
> >> +USES= gettext gperf gmake libarchive libtool pathfix \
> >> + pkgconfig tar:xz
> >>   USE_GNOME= gdkpixbuf2 glib20 gtk30 intlhack introspection:build \
> >> libxml2:build pango
> >>   USE_LDCONFIG= yes
> >> @@ -44,10 +45,6 @@ MANPAGES_USE= GNOME=libxslt:build
> >>  
> >>   .include <bsd.port.options.mk>
> >>  
> >> -.if !exists(/usr/libdata/pkgconfig/libarchive.pc)
> >> -LIB_DEPENDS+= libarchive.so.13:${PORTSDIR}/archivers/libarchive
> >> -.endif
> >> -
> >>   .if ${OSVERSION} < 1000000 && ${OPSYS} == FreeBSD
> >>   post-patch:
> >>   ${REINPLACE_CMD} -e 's|-Wtype-limits||g' \
> >>
> > (snip)
> >
> >
> >
> >
> > _______________________________________________
> > [hidden email] mailing list
> > https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
> > To unsubscribe, send any mail to "[hidden email]"
>


--
Tomoaki AOKI    [hidden email]
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"