Spamassassin vs Perl

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

Spamassassin vs Perl

Jos Chrispijn-5
Dear list,

I have updated my Perl version yesterday but now my Spamd doesn't work
anymore.
Can someone hint me how to solve this?

thanks,
Jos Chrispijn

Pls see output:

Can't locate Net/DNS.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at /usr/local/bin/sa-update line 80.
BEGIN failed--compilation aborted at /usr/local/bin/sa-update line 80.

Can't locate Net/DNS.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at /usr/local/bin/sa-update line 80.
BEGIN failed--compilation aborted at /usr/local/bin/sa-update line 80.

Can't locate NetAddr/IP.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.

BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
Compilation failed in require at /usr/local/bin/spamassassin line 80.
BEGIN failed--compilation aborted at /usr/local/bin/spamassassin line 80.
ClamAV update process started at Thu Jun 23 15:43:00 2011
main.cld is up to date (version: 53, sigs: 846214, f-level: 53, builder:
sven)
daily.cld is up to date (version: 13231, sigs: 130699, f-level: 60,
builder: arnaud)
bytecode.cld is up to date (version: 143, sigs: 40, f-level: 60,
builder: edwin)
spamd not running? (check /var/run/spamd/spamd.pid).
Starting spamd.

Can't locate NetAddr/IP.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.

BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
Compilation failed in require at /usr/local/bin/spamd line 85.
BEGIN failed--compilation aborted at /usr/local/bin/spamd line 85.

Can't locate NetAddr/IP.pm in @INC (@INC contains:
/usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
/usr/local/lib/perl5/site_perl/5.14.1/mach
/usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach
/usr/local/lib/perl5/5.14.1) at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.

BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
Compilation failed in require at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
Compilation failed in require at /usr/local/bin/spamassassin line 80.
BEGIN failed--compilation aborted at /usr/local/bin/spamassassin line 80.

--- cut ---
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Spamassassin vs Perl

Ruslan Makhmatkhanov
23.06.2011 18:00, Jos Chrispijn пишет:
> Dear list,
>
> I have updated my Perl version yesterday but now my Spamd doesn't work anymore.
> Can someone hint me how to solve this?
>
> thanks,
> Jos Chrispijn

Did you run perl-after-upgrade command after update?

>
> Pls see output:
>
> Can't locate Net/DNS.pm in @INC (@INC contains:
> /usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
> /usr/local/lib/perl5/site_perl/5.14.1/mach /usr/local/lib/perl5/site_perl/5.14.1
> /usr/local/lib/perl5/5.14.1/mach /usr/local/lib/perl5/5.14.1) at
> /usr/local/bin/sa-update line 80.
> BEGIN failed--compilation aborted at /usr/local/bin/sa-update line 80.
>
> Can't locate Net/DNS.pm in @INC (@INC contains:
> /usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
> /usr/local/lib/perl5/site_perl/5.14.1/mach /usr/local/lib/perl5/site_perl/5.14.1
> /usr/local/lib/perl5/5.14.1/mach /usr/local/lib/perl5/5.14.1) at
> /usr/local/bin/sa-update line 80.
> BEGIN failed--compilation aborted at /usr/local/bin/sa-update line 80.
>
> Can't locate NetAddr/IP.pm in @INC (@INC contains:
> /usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
> /usr/local/lib/perl5/site_perl/5.14.1/mach /usr/local/lib/perl5/site_perl/5.14.1
> /usr/local/lib/perl5/5.14.1/mach /usr/local/lib/perl5/5.14.1) at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
>
> BEGIN failed--compilation aborted at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
> Compilation failed in require at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
> BEGIN failed--compilation aborted at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
> Compilation failed in require at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
> BEGIN failed--compilation aborted at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
> Compilation failed in require at /usr/local/bin/spamassassin line 80.
> BEGIN failed--compilation aborted at /usr/local/bin/spamassassin line 80.
> ClamAV update process started at Thu Jun 23 15:43:00 2011
> main.cld is up to date (version: 53, sigs: 846214, f-level: 53, builder: sven)
> daily.cld is up to date (version: 13231, sigs: 130699, f-level: 60, builder:
> arnaud)
> bytecode.cld is up to date (version: 143, sigs: 40, f-level: 60, builder: edwin)
> spamd not running? (check /var/run/spamd/spamd.pid).
> Starting spamd.
>
> Can't locate NetAddr/IP.pm in @INC (@INC contains:
> /usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
> /usr/local/lib/perl5/site_perl/5.14.1/mach /usr/local/lib/perl5/site_perl/5.14.1
> /usr/local/lib/perl5/5.14.1/mach /usr/local/lib/perl5/5.14.1) at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
>
> BEGIN failed--compilation aborted at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
> Compilation failed in require at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
> BEGIN failed--compilation aborted at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
> Compilation failed in require at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
> BEGIN failed--compilation aborted at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
> Compilation failed in require at /usr/local/bin/spamd line 85.
> BEGIN failed--compilation aborted at /usr/local/bin/spamd line 85.
>
> Can't locate NetAddr/IP.pm in @INC (@INC contains:
> /usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN
> /usr/local/lib/perl5/site_perl/5.14.1/mach /usr/local/lib/perl5/site_perl/5.14.1
> /usr/local/lib/perl5/5.14.1/mach /usr/local/lib/perl5/5.14.1) at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
>
> BEGIN failed--compilation aborted at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
> Compilation failed in require at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
> BEGIN failed--compilation aborted at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
> Compilation failed in require at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
> BEGIN failed--compilation aborted at
> /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
> Compilation failed in require at /usr/local/bin/spamassassin line 80.
> BEGIN failed--compilation aborted at /usr/local/bin/spamassassin line 80.
>
> --- cut ---
> _______________________________________________
> [hidden email] mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-ports
> To unsubscribe, send any mail to "[hidden email]"
>
>

--
Regards,
Ruslan
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Spamassassin vs Perl

Chip Camden
Quoth Ruslan Mahmatkhanov on Thursday, 23 June 2011:

> 23.06.2011 18:00, Jos Chrispijn пишет:
> >Dear list,
> >
> >I have updated my Perl version yesterday but now my Spamd doesn't work
> >anymore.
> >Can someone hint me how to solve this?
> >
> >thanks,
> >Jos Chrispijn
>
> Did you run perl-after-upgrade command after update?
>
FWIW, I don't think perl-after-upgrade does the job for the latest 5.14.
The perl extensions for rxvt-unicode wouldn't work afterwards.
Rebuilding rxvt-unicode didn't help either.  I had to do the more
draconian and lengthy process of

portupgrade -fr perl

Then the extensions came back to life.  Might want to try the same for
your problem.

--
.O. | Sterling (Chip) Camden      | http://camdensoftware.com
..O | [hidden email] | http://chipsquips.com
OOO | 2048R/D6DBAF91              | http://chipstips.com

attachment0 (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Spamassassin vs Perl

Kurt Jaeger-14
In reply to this post by Ruslan Makhmatkhanov
Hi!

> > I have updated my Perl version yesterday but now my Spamd doesn't work anymore.

> Did you run perl-after-upgrade command after update?

Same perl upgrade, yes, I ran perl-after-upgrade after the upgrade, similar
problem:

fa8# /usr/local/etc/rc.d/sa-spamd start
Starting spamd.
Can't locate NetAddr/IP.pm in @INC (@INC contains: /usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN /usr/local/lib/perl5/site_perl/5.14.1/mach /usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach /usr/local/lib/perl5/5.14.1) at /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm line 25.
Compilation failed in require at /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm line 86.
Compilation failed in require at /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line 71.
Compilation failed in require at /usr/local/bin/spamd line 85.
BEGIN failed--compilation aborted at /usr/local/bin/spamd line 85.
/usr/local/etc/rc.d/sa-spamd: WARNING: failed to start spamd

--
[hidden email]            +49 171 3101372                         9 years to go !
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Spamassassin vs Perl

Sergey V. Dyatko
On Thu, 23 Jun 2011 18:29:20 +0200
Kurt Jaeger <[hidden email]> wrote:

> Hi!
>
> > > I have updated my Perl version yesterday but now my Spamd doesn't
> > > work anymore.
>
> > Did you run perl-after-upgrade command after update?
>
> Same perl upgrade, yes, I ran perl-after-upgrade after the upgrade,
> similar problem:
>
> fa8# /usr/local/etc/rc.d/sa-spamd start
> Starting spamd.
> Can't locate NetAddr/IP.pm in @INC (@INC
> contains: /usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.1/BSDPAN /usr/local/lib/perl5/site_perl/5.14.1/mach /usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/mach /usr/local/lib/perl5/5.14.1)
> at /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm
> line 25. BEGIN failed--compilation aborted
> at /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/NetSet.pm
> line 25. Compilation failed in require
> at /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm
> line 86. BEGIN failed--compilation aborted
> at /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin/Conf.pm
> line 86. Compilation failed in require
> at /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line
> 71. BEGIN failed--compilation aborted
> at /usr/local/lib/perl5/site_perl/5.14.0/Mail/SpamAssassin.pm line
> 71. Compilation failed in require at /usr/local/bin/spamd line 85.
> BEGIN failed--compilation aborted at /usr/local/bin/spamd line
> 85. /usr/local/etc/rc.d/sa-spamd: WARNING: failed to start spamd
>
reinstall net-mgmt/p5-NetAddr-IP



--
wbr, tiger

_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Spamassassin vs Perl

timp
In reply to this post by Jos Chrispijn-5
I think we need update spamassassin in ports tree to latest version
From http://spamassassin.apache.org/
> 2011-06-16: SpamAssassin 3.3.2 has been released, a minor new release primarily to support perl-5.12 and later.

Reply | Threaded
Open this post in threaded view
|

Re: Spamassassin vs Perl

Kurt Jaeger-14
In reply to this post by Sergey V. Dyatko
Hi!

> > > Did you run perl-after-upgrade command after update?
> >
> > Same perl upgrade, yes, I ran perl-after-upgrade after the upgrade,
> > similar problem:
[...]
> > fa8# /usr/local/etc/rc.d/sa-spamd start
> > Starting spamd.
> > Can't locate NetAddr/IP.pm in @INC (@INC
[...]

> reinstall net-mgmt/p5-NetAddr-IP

It's not only net-mgmt/p5-NetAddr-IP, there are approx. 20+ dependencies
which also did not work due to the upgrade.

Interestingly, approx. 4000 manual pages are still in

/usr/local/lib/perl5/5.14.0

and approx. 8000 other 5.14.0 files are in

/usr/local/lib/perl5/site_perl/5.14.0

I assume that short of a full rebuild nothing helps if the perl
version increases. This is a bit painful 8-(

How can one reconstruct a good dependency tree of all perl related ports
which allows to cleanly rebuild them all ?

portupgrade -fr perl seems to have issues, as well.

I'll start one and report back.

--
[hidden email]            +49 171 3101372                         9 years to go !
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Spamassassin vs Perl

Matthew D. Fuller
On Fri, Jun 24, 2011 at 09:09:00AM +0200 I heard the voice of
Kurt Jaeger, and lo! it spake thus:
>
> How can one reconstruct a good dependency tree of all perl related
> ports which allows to cleanly rebuild them all ?

I always just start with `portupgrade -f p5-\*`.  Then look around in
the old site_perl dir for stragglers (usually fairly few).

Of course, that won't catch non-modules that depend tightly on the
version, but those are rare enough that I've always just dealt with
them when they came to notice.


--
Matthew Fuller     (MF4839)   |  [hidden email]
Systems/Network Administrator |  http://www.over-yonder.net/~fullermd/
           On the Internet, nobody can hear you scream.
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Spamassassin vs Perl

Ruslan Makhmatkhanov
In reply to this post by Kurt Jaeger-14
24.06.2011 11:09, Kurt Jaeger пишет:

> Hi!
>
>>>> Did you run perl-after-upgrade command after update?
>>>
>>> Same perl upgrade, yes, I ran perl-after-upgrade after the upgrade,
>>> similar problem:
> [...]
>>> fa8# /usr/local/etc/rc.d/sa-spamd start
>>> Starting spamd.
>>> Can't locate NetAddr/IP.pm in @INC (@INC
> [...]
>
>> reinstall net-mgmt/p5-NetAddr-IP
>
> It's not only net-mgmt/p5-NetAddr-IP, there are approx. 20+ dependencies
> which also did not work due to the upgrade.
>
> Interestingly, approx. 4000 manual pages are still in
>
> /usr/local/lib/perl5/5.14.0
>
> and approx. 8000 other 5.14.0 files are in
>
> /usr/local/lib/perl5/site_perl/5.14.0
>
> I assume that short of a full rebuild nothing helps if the perl
> version increases. This is a bit painful 8-(
>
> How can one reconstruct a good dependency tree of all perl related ports
> which allows to cleanly rebuild them all ?

I use portmaster p5-.
git and ImageMagic should be also
rebuilded if installed (they install stuff into site_perl)

If after that you have more man-pages and files in 5.14.0, then
use pkg_info -W filename to discover which port it belong
and rebuild it too.

>
> portupgrade -fr perl seems to have issues, as well.
>
> I'll start one and report back.
>

--
Regards,
Ruslan
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Spamassassin vs Perl

Jerry
In reply to this post by Kurt Jaeger-14
On Fri, 24 Jun 2011 09:09:00 +0200
Kurt Jaeger articulated:

> Hi!
>
> > > > Did you run perl-after-upgrade command after update?
> > >
> > > Same perl upgrade, yes, I ran perl-after-upgrade after the
> > > upgrade, similar problem:
> [...]
> > > fa8# /usr/local/etc/rc.d/sa-spamd start
> > > Starting spamd.
> > > Can't locate NetAddr/IP.pm in @INC (@INC
> [...]
>
> > reinstall net-mgmt/p5-NetAddr-IP
>
> It's not only net-mgmt/p5-NetAddr-IP, there are approx. 20+
> dependencies which also did not work due to the upgrade.
>
> Interestingly, approx. 4000 manual pages are still in
>
> /usr/local/lib/perl5/5.14.0
>
> and approx. 8000 other 5.14.0 files are in
>
> /usr/local/lib/perl5/site_perl/5.14.0
>
> I assume that short of a full rebuild nothing helps if the perl
> version increases. This is a bit painful 8-(
>
> How can one reconstruct a good dependency tree of all perl related
> ports which allows to cleanly rebuild them all ?
>
> portupgrade -fr perl seems to have issues, as well.
>
> I'll start one and report back.

This has always worked well for me. In fact, better than the other
packages for maintaining ports:

        portmanager lang/perl5.14 -l -f

You could then run:

        portmanager mail/spamd -p -l

if the port still did not work correctly, although that would be highly
unlikely.

--
Jerry ✌
[hidden email]

Disclaimer: off-list followups get on-list replies or get ignored.
Please do not ignore the Reply-To header.
__________________________________________________________________
Don't be overly suspicious where it's not warranted.
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Spamassassin vs Perl

Jos Chrispijn-5
In reply to this post by Ruslan Makhmatkhanov
Yes, I did.
Strangely enough, the problem was solved after I did a 'portupgrade -fr
perl'.
Normally this only goes for 15.3 to 15.4 (full version upgrade) or do I
miss something here?

best regards,
Jos Chrispijn

Ruslan Mahmatkhanov:

> 23.06.2011 18:00, Jos Chrispijn пишет:
>> Dear list,
>>
>> I have updated my Perl version yesterday but now my Spamd doesn't
>> work anymore.
>> Can someone hint me how to solve this?
>>
>> thanks,
>> Jos Chrispijn
>
> Did you run perl-after-upgrade command after update?
>
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: Spamassassin vs Perl

Kurt Jaeger-14
In reply to this post by Kurt Jaeger-14
Hi!

> > > > Did you run perl-after-upgrade command after update?
[yes...]
> I assume that short of a full rebuild nothing helps if the perl
> version increases. This is a bit painful 8-(
>
> How can one reconstruct a good dependency tree of all perl related ports
> which allows to cleanly rebuild them all ?
>
> portupgrade -fr perl seems to have issues, as well.
>
> I'll start one and report back.

After an portupgrade -fr perl run, I still have approx. 4200 files
in /usr/local/lib/perl5/site_perl/5.14.0.

This is a huge amount of files, much larger than I expected.

What went wrong ? I can provide a copy of the portupgrade -fr perl run.

--
[hidden email]            +49 171 3101372                         9 years to go !
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"