Trying to install on Dell Latitude 7390 (UEFI, NVMe)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Trying to install on Dell Latitude 7390 (UEFI, NVMe)

Scott I. Remick
(originally posted on the FreeBSD forums, was advised to post to this mailing list instead)

So it's been a while since I tried setting up FreeBSD from scratch on bare metal, but I wanted to set up a laptop again. For this, I grabbed a Dell Latitude 7390 with an NVMe SSD so UEFI is required. However, I have Secure Boot disabled and Legacy boot ROMs enabled in the BIOS. I'm not trying to dual-boot or anything... wiped the SSD clean and starting bare.

I installed the USB installer image (11.2-RELEASE) on a USB flash drive and I boot from it via UEFI. I get as far as the partition step and its confirmation, and then get "Device busy".

I realize UEFI w/ FreeBSD is tricky (buggy?) but I'm hoping there's a way through this and that I'm doing a simple something incorrectly. I've never tried setting up FreeBSD w/ UEFI before.

Screenshot available at:
https://forums.freebsd.org/threads/trying-to-install-on-dell-latitude-7390-uefi-nvme.67468/
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-hardware
To unsubscribe, send any mail to "[hidden email]"