UPDATING entry needed for MATE update from 1.12 to 1.18

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

UPDATING entry needed for MATE update from 1.12 to 1.18

Kevin Oberman-4
To successfully update from mate-1.12 to 1.18, the port mate-control-center
must first be deleted (pkg delete -f mate-control-center) as some files for
installed by mate-menus were previously part of mate-control-center.

I believe that a note to this effect should be made to ports/UPDATING.
--
Kevin Oberman, Part time kid herder and retired Network Engineer
E-mail: [hidden email]
PGP Fingerprint: D03FB98AFA78E3B78C1694B318AB39EF1B055683
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: UPDATING entry needed for MATE update from 1.12 to 1.18

Koop Mast-2
On Wed, 2017-07-05 at 10:17 -0700, Kevin Oberman wrote:
> To successfully update from mate-1.12 to 1.18, the port mate-control-
> center
> must first be deleted (pkg delete -f mate-control-center) as some
> files for
> installed by mate-menus were previously part of mate-control-center.
>
> I believe that a note to this effect should be made to
> ports/UPDATING.

Is this with portmaster by chance? I just did a update with pkg default
packages and it worked fine.

-Koop

> --
> Kevin Oberman, Part time kid herder and retired Network Engineer
> E-mail: [hidden email]
> PGP Fingerprint: D03FB98AFA78E3B78C1694B318AB39EF1B055683
> _______________________________________________
> [hidden email] mailing list
> https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
> To unsubscribe, send any mail to "[hidden email]
> rg"
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: UPDATING entry needed for MATE update from 1.12 to 1.18

Kevin Oberman-4
On Sat, Jul 8, 2017 at 7:56 AM, Koop Mast <[hidden email]> wrote:

> On Wed, 2017-07-05 at 10:17 -0700, Kevin Oberman wrote:
> > To successfully update from mate-1.12 to 1.18, the port mate-control-
> > center
> > must first be deleted (pkg delete -f mate-control-center) as some
> > files for
> > installed by mate-menus were previously part of mate-control-center.
> >
> > I believe that a note to this effect should be made to
> > ports/UPDATING.
>
> Is this with portmaster by chance? I just did a update with pkg default
> packages and it worked fine.
>
> -Koop
>

This is true of any attempt to upgrade from ports, whether using
portmaster, portupgrade or manually running "make install". Until the ports
Mk files develop the ability to check the pkg database for conflicts (not
likely any tie soon), I think it is important to note these in UPDATING.
Especially since the command to deal with the issue (pkg delete -f) is not
tool specific.

I will admit that most people who build from ports are not newbies and know
how to deal with these issues, but it will help some and, after all, this
is the sort of thing UPDATING is for.
--
Kevin Oberman, Part time kid herder and retired Network Engineer
E-mail: [hidden email]
PGP Fingerprint: D03FB98AFA78E3B78C1694B318AB39EF1B055683
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"