USE_PACKAGE_DEPENDS failed at meson-0.48.0

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

USE_PACKAGE_DEPENDS failed at meson-0.48.0

KIRIYAMA Kazuhiko-2
Hi lists,

I've upgraded to 13.0-CURRENT and ports (revision 482838)
then build all stuffs but failed at installing
meson-0.48.0.txz package:

===>   atk-2.28.1 depends on executable: g-ir-scanner - found
===>   Returning to build of atk-2.28.1
===>   atk-2.28.1 depends on executable: meson - not found
===>   Installing existing package /var/ports/packages/All/meson-0.48.0.txz
Installing meson-0.48.0...
`-- Installing ninja-1.8.2,2...
`-- Extracting ninja-1.8.2,2: ....... done
pkg-static: Missing dependency 'py36-setuptools'

Failed to install the following 1 package(s): /var/ports/packages/All/meson-0.48.0.txz
*** Error code 70

Stop.
make[2]: stopped in /var/ports/jdtpkx/accessibility/atk
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/japanese/w3m-img
*** Error code 1

Stop.
make: stopped in /usr/ports/japanese/w3m-img

But removed /var/ports/packages/All/meson-0.48.0.txz and
then rebuild, all done fine.  What happened ? All logs for
failed one and successed one are up to [1] and [2]
respectivelly. My installing environments are as follows:

admin@jdtpkx:~ % uname -a
FreeBSD jdtpkx 13.0-CURRENT FreeBSD 13.0-CURRENT #0 r339677M: Fri Oct 26 14:56:49 JST 2018     root@msrvkx:/usr/obj/usr/src/amd64.amd64/sys/XIJ  amd64
admin@jdtpkx:~ % cat /etc/make.conf
PORTSDIR=               /var/ports/jdtpkx
INDEXDIR=               /var/ports/jdtpkx
WRKDIRPREFIX=           /var/ports/work
PACKAGES=               /var/ports/packages
DISTDIR=                /var/ports/distfiles
BATCH=                  yes
DEFAULT_VERSIONS+=      linux=c7 perl5=5.28 ruby=25
COMPILER_TYPE=          clang
USE_PACKAGE_DEPENDS=    yes
DISABLE_VULNERABILITIES=yes
admin@jdtpkx:~ %

Best regards.

[1] http://ds.truefc.org/~kiri/freebsd/ports/w3m_build_error.log
[2] http://ds.truefc.org/~kiri/freebsd/ports/w3m_build.log

---
KIRIYAMA Kazuhiko
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: USE_PACKAGE_DEPENDS failed at meson-0.48.0

KIRIYAMA Kazuhiko-2
Hi all,

At Wed, 07 Nov 2018 08:05:46 +0900,
私 wrote:

>
> Hi lists,
>
> I've upgraded to 13.0-CURRENT and ports (revision 482838)
> then build all stuffs but failed at installing
> meson-0.48.0.txz package:
>
> ===>   atk-2.28.1 depends on executable: g-ir-scanner - found
> ===>   Returning to build of atk-2.28.1
> ===>   atk-2.28.1 depends on executable: meson - not found
> ===>   Installing existing package /var/ports/packages/All/meson-0.48.0.txz
> Installing meson-0.48.0...
> `-- Installing ninja-1.8.2,2...
> `-- Extracting ninja-1.8.2,2: ....... done
> pkg-static: Missing dependency 'py36-setuptools'
>
> Failed to install the following 1 package(s): /var/ports/packages/All/meson-0.48.0.txz
> *** Error code 70

I've built py36-setuptools with python-3.6:

# make DEFAULT_VERSIONS='python=3.6' PYTHON_PKGNAMEPREFIX='py36-' -C /var/ports/jdtpkx/devel/py-setuptools

and then trying to build ohter package (at-spi2-core-2.28.0):

===>   at-spi2-core-2.28.0 depends on executable: g-ir-scanner - found
===>   Returning to build of at-spi2-core-2.28.0
===>   at-spi2-core-2.28.0 depends on executable: meson - not found
===>   Installing existing package /var/ports/packages/All/meson-0.48.0.txz
Installing meson-0.48.0...
`-- Installing py36-setuptools-40.4.3...
pkg-static: py36-setuptools-40.4.3 conflicts with py27-setuptools-40.4.3 (installs files into the sa
me place).  Problematic file: /usr/local/bin/easy_install

Failed to install the following 1 package(s): /var/ports/packages/All/meson-0.48.0.txz
*** Error code 70

Stop.
make[5]: stopped in /var/ports/jdtpkx/accessibility/at-spi2-core
*** Error code 1

Stop.
make[4]: stopped in /var/ports/jdtpkx/accessibility/at-spi2-atk
*** Error code 1

Stop.
make[3]: stopped in /var/ports/jdtpkx/x11-toolkits/gtk30
*** Error code 1

Stop.


This means at-spi2-core should be created with python-2.7
but meson python-3.6. Actually USES=python:3.5+ in
devel/meson/Makefile. These conflicts occures every port in
case of python use. Nothing happened at least in
12.0-CURRENT/ports(revision 471092). Now ports system about
python version control collapsed ?

>
> Stop.
> make[2]: stopped in /var/ports/jdtpkx/accessibility/atk
> *** Error code 1
>
> Stop.
> make[1]: stopped in /usr/ports/japanese/w3m-img
> *** Error code 1
>
> Stop.
> make: stopped in /usr/ports/japanese/w3m-img
>
> But removed /var/ports/packages/All/meson-0.48.0.txz and
> then rebuild, all done fine.  What happened ? All logs for
> failed one and successed one are up to [1] and [2]
> respectivelly. My installing environments are as follows:
>
> admin@jdtpkx:~ % uname -a
> FreeBSD jdtpkx 13.0-CURRENT FreeBSD 13.0-CURRENT #0 r339677M: Fri Oct 26 14:56:49 JST 2018     root@msrvkx:/usr/obj/usr/src/amd64.amd64/sys/XIJ  amd64
> admin@jdtpkx:~ % cat /etc/make.conf
> PORTSDIR=               /var/ports/jdtpkx
> INDEXDIR=               /var/ports/jdtpkx
> WRKDIRPREFIX=           /var/ports/work
> PACKAGES=               /var/ports/packages
> DISTDIR=                /var/ports/distfiles
> BATCH=                  yes
> DEFAULT_VERSIONS+=      linux=c7 perl5=5.28 ruby=25
> COMPILER_TYPE=          clang
> USE_PACKAGE_DEPENDS=    yes
> DISABLE_VULNERABILITIES=yes
> admin@jdtpkx:~ %
>
> Best regards.
>
> [1] http://ds.truefc.org/~kiri/freebsd/ports/w3m_build_error.log
> [2] http://ds.truefc.org/~kiri/freebsd/ports/w3m_build.log
>
> ---
> KIRIYAMA Kazuhiko
> _______________________________________________
> [hidden email] mailing list
> https://lists.freebsd.org/mailman/listinfo/freebsd-ports
> To unsubscribe, send any mail to "[hidden email]"
>

Regards

---
KIRIYAMA Kazuhiko
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: USE_PACKAGE_DEPENDS failed at meson-0.48.0

Mathieu Arnold-2
On Fri, Nov 09, 2018 at 07:30:41AM +0900, KIRIYAMA Kazuhiko wrote:

> Hi all,
>
> At Wed, 07 Nov 2018 08:05:46 +0900,
> 私 wrote:
> >
> > Hi lists,
> >
> > I've upgraded to 13.0-CURRENT and ports (revision 482838)
> > then build all stuffs but failed at installing
> > meson-0.48.0.txz package:
> >
> > ===>   atk-2.28.1 depends on executable: g-ir-scanner - found
> > ===>   Returning to build of atk-2.28.1
> > ===>   atk-2.28.1 depends on executable: meson - not found
> > ===>   Installing existing package /var/ports/packages/All/meson-0.48.0.txz
> > Installing meson-0.48.0...
> > `-- Installing ninja-1.8.2,2...
> > `-- Extracting ninja-1.8.2,2: ....... done
> > pkg-static: Missing dependency 'py36-setuptools'
> >
> > Failed to install the following 1 package(s): /var/ports/packages/All/meson-0.48.0.txz
> > *** Error code 70
>
> I've built py36-setuptools with python-3.6:
>
> # make DEFAULT_VERSIONS='python=3.6' PYTHON_PKGNAMEPREFIX='py36-' -C /var/ports/jdtpkx/devel/py-setuptools
>
> and then trying to build ohter package (at-spi2-core-2.28.0):
>
> ===>   at-spi2-core-2.28.0 depends on executable: g-ir-scanner - found
> ===>   Returning to build of at-spi2-core-2.28.0
> ===>   at-spi2-core-2.28.0 depends on executable: meson - not found
> ===>   Installing existing package /var/ports/packages/All/meson-0.48.0.txz
> Installing meson-0.48.0...
> `-- Installing py36-setuptools-40.4.3...
> pkg-static: py36-setuptools-40.4.3 conflicts with py27-setuptools-40.4.3 (installs files into the sa
> me place).  Problematic file: /usr/local/bin/easy_install
You cannot have both py27-setuptools and py36-setuptools built with two
different default python versions.  The default python version is UNIQUE
and MUST NOT be changed mid flight.  If you want the Python 3.6 flavor
if that port, you run:

make FLAVOR=py36 -C /var/ports/jdtpkx/devel/py-setuptools

--
Mathieu Arnold

signature.asc (981 bytes) Download Attachment