ZFS Beaglebone 11.0 vs 11.1

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

ZFS Beaglebone 11.0 vs 11.1

ArnoB
Hi there,

I've been running FreeBSD 11.0 RC1 on a Beaglebone black
for a bit too long, and tried updating to 11.1-RELEASE.
I managed to successfully do a clean install, but ran into
system crash when trying to mount ZFS volumes from an
external mmc card. The card was created on 11.0RC1 and
has worked without any issues.
Importing it crashed the board, yet made it appear ONLINE
after the reboot. I still couldn't mount it though.

As a test I created a pool on a USB stick,with the same results.
A system crash, reboot, pool is online but i can't mount any of
the volumes. Scrubbing works fine and finishes without an error.

I connected with a serial cable and found this error:
zpool panic: thread 0xc2f71000 terminating with rrw lock 0xc36fae98 held

I tried raising the KSTACK_PAGES to 4, and even 6 without
any result (and zpool keeps reporting i should raise it from 2 to 4).
I've also lowered vm.kmem_size and vm.kmem_size_max.
Same results.


After this I did a fresh install of FreeBSD 11.0-RELEASE-p1 and
to my surprise thee whole pool is showing up and all volumes are
mounted without a single error.

Is there anything I can do to make 11.1-RELEASE work?

thanks in advance,

Arno
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-arm
To unsubscribe, send any mail to "[hidden email]"