chromium 37 up for testing (and polishing)

classic Classic list List threaded Threaded
23 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Re: chromium 37 up for testing (and polishing)

mikec
On Wed, Aug 27, 2014 at 11:56 PM, Carlos Jacobo Puga Medina <[hidden email]>
wrote:

> On Wed, 27 Aug 2014 23:49:35 +0100
> Miguel Clara <[hidden email]> wrote:
>
> > Thanks for the info but I get the same result (I had that in make.conf
> > already btw)
>
> Please, see comment#6:
> https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=192685#c6
>
> >
> > Maybe I'm missing a patch, I'll try to build live and see what I get!
>
> The chromium port has 2 extra-patches which depends on the choose compiler.
>
> I've cleaned the poudriere ports dir and I'll re-fetch, but for now I left
it building live and it took ages ofc, debug doesn't really speed it up :)

However It completed in a very strange way... I got no errors
building/installing but the chrome bin looks like this:

-r-xr-xr-x  1 root  wheel   2.1G Aug 28 04:47 chrome

2.1 GB???

When I try to execute it I get:
/usr/local/bin/chrome: /usr/local/share/chromium/chrome: Exec format error

Have you ever seen this?

 >
> > I'm building with debug btw, not sure if relevant.
>
> To get useful backtraces is necessary :)
>

Yeah that's what I'm looking for cause the output from the crash on the
extension install is close to none and porbably won't help Rene or anyone
figure out what causes it but It seems that I'm not having any luck
building with debug :|


> >
> > I wan to see if I can understand why I can not install the Google Cast
> > Extension!
>
> --
> Carlos Jacobo Puga Medina <[hidden email]>
>
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: chromium 37 up for testing (and polishing)

mikec
https://www.mail-archive.com/freebsd-ports@.../msg59085.html

Seems related to debug indeed, it did take a very long time to link chrome
and all my memory and some good amount of swap, but I expected that since
it with debug on!


I'll have to do it with debug off then :(
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: chromium 37 up for testing (and polishing)

Carlos J Puga Medina
In reply to this post by mikec
On Thu, 28 Aug 2014 17:24:59 +0100
Miguel Clara <[hidden email]> wrote:

> On Wed, Aug 27, 2014 at 11:56 PM, Carlos Jacobo Puga Medina <[hidden email]>
> wrote:
>
> > On Wed, 27 Aug 2014 23:49:35 +0100
> > Miguel Clara <[hidden email]> wrote:
> >
> > > Thanks for the info but I get the same result (I had that in make.conf
> > > already btw)
> >
> > Please, see comment#6:
> > https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=192685#c6
> >
> > >
> > > Maybe I'm missing a patch, I'll try to build live and see what I get!
> >
> > The chromium port has 2 extra-patches which depends on the choose compiler.
> >
> > I've cleaned the poudriere ports dir and I'll re-fetch, but for now I left
> it building live and it took ages ofc, debug doesn't really speed it up :)
>
> However It completed in a very strange way... I got no errors
> building/installing but the chrome bin looks like this:
>
> -r-xr-xr-x  1 root  wheel   2.1G Aug 28 04:47 chrome
>
> 2.1 GB???
>
> When I try to execute it I get:
> /usr/local/bin/chrome: /usr/local/share/chromium/chrome: Exec format error
>
> Have you ever seen this?

Nope, but this [1] will bring some light. So if you don't build it with debug enabled, chrome should work.

[1] http://comments.gmane.org/gmane.os.freebsd.chromium/1107

>
>  >
> > > I'm building with debug btw, not sure if relevant.
> >
> > To get useful backtraces is necessary :)
> >
>
> Yeah that's what I'm looking for cause the output from the crash on the
> extension install is close to none and porbably won't help Rene or anyone
> figure out what causes it but It seems that I'm not having any luck
> building with debug :|
>
>
> > >
> > > I wan to see if I can understand why I can not install the Google Cast
> > > Extension!
> >
> > --
> > Carlos Jacobo Puga Medina <[hidden email]>
> >


--
Carlos Jacobo Puga Medina <[hidden email]>
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-chromium
To unsubscribe, send any mail to "[hidden email]"
12