failed upgrading eclipse-3.7.1_2 (and/or openjdk6)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

failed upgrading eclipse-3.7.1_2 (and/or openjdk6)

pe-4
After upgrading openjdk6-b25_2 and eclipse-3.7.1_2 from previous
versions, eclipse no more start. The log files attached are:
1347541596351.log  -->  The first log after update
1347545372393.log  -->  All logs after the first (this is the last one)

I'm not a java developers, I don't know how to solve this or if this is
related to something during jdk/eclipse installation.

The directory
     $HOME/.swt/lib/FreeBSD/x86_64
is empty, I don't know if there was something in there before. The
libraries libswt-gtk-3738.so and libswt-gtk.so are not present in any
directories on the disk.

I upgraded both jdk and eclipse while in KDE in console with portmaster,
I don't have installation log files but despite the jdk installation was
succesful I saw some errors and 'file not found' here and there while
compiling but thought it was nothing to worry to.

In the previous version I installed the CDT pluging from within eclipse
download manager.

I can continue my work (C++ with eclipse CDT) in an editor and compile
the project by hand for a couple of days, if there is something you like
I test with this broken installation. After that I will reinstall jdk
and eclipse (and CDT) if I don't hear you.

In the past eclipse versions there was a file in the eclipse port three
directory that stated to run a command for each users that use it, no
more exists (pkg-message?). Is still needed that command? if yes, can
you tell me what it was (I don't remember, something like 'eclipse
update $username').

Sorry for my english.

regards, paul


_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-eclipse
To unsubscribe, send any mail to "[hidden email]"

1347541596351.log (169K) Download Attachment
1347545372393.log (3K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: failed upgrading eclipse-3.7.1_2 (and/or openjdk6)

kron
On 2012/09/13 16:47, freethread wrote:

> After upgrading openjdk6-b25_2 and eclipse-3.7.1_2 from previous
> versions, eclipse no more start. The log files attached are:
> 1347541596351.log  -->  The first log after update
> 1347545372393.log  -->  All logs after the first (this is the last one)
>
> I'm not a java developers, I don't know how to solve this or if this is
> related to something during jdk/eclipse installation.
>
> The directory
>      $HOME/.swt/lib/FreeBSD/x86_64
> is empty, I don't know if there was something in there before. The
> libraries libswt-gtk-3738.so and libswt-gtk.so are not present in any
> directories on the disk.
>
> I upgraded both jdk and eclipse while in KDE in console with portmaster,
> I don't have installation log files but despite the jdk installation was
> succesful I saw some errors and 'file not found' here and there while
> compiling but thought it was nothing to worry to.
>
> In the previous version I installed the CDT pluging from within eclipse
> download manager.
>
> I can continue my work (C++ with eclipse CDT) in an editor and compile
> the project by hand for a couple of days, if there is something you like
> I test with this broken installation. After that I will reinstall jdk
> and eclipse (and CDT) if I don't hear you.
>
> In the past eclipse versions there was a file in the eclipse port three
> directory that stated to run a command for each users that use it, no
> more exists (pkg-message?). Is still needed that command? if yes, can
> you tell me what it was (I don't remember, something like 'eclipse
> update $username').

Two hints:

1. The port of Eclipse 3.7.1 had an issue with permissions
    on some directories/files which broke plugins. Not sure if
    it still persists - check /usr/local/lib/eclipse/plugins
    and below. Something like
      d=/usr/local/lib/eclipse/plugins
      find $d -type d -exec chmod 755 {} +
      find $d -type f -exec chmod 644 {} +
    could help...

2. Few days ago I posted to few lists (I think to ports
    and then to questions) that the last upgrade of www/libxul
    broke some programs - chmsee  and gecko-mediaplayer in my
    case but eclipse may be affected, too. If you have libxul
    10 then try to go back to 1.9 (see /usr/ports/UPDATING of
    20120910) and rebuild eclipse.

HTH
Oli
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-eclipse
To unsubscribe, send any mail to "[hidden email]"