icu 62.1_2,1 compile error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

icu 62.1_2,1 compile error

Alexander Evdokimov
Hello,

We can't update any packagies depended on ICU, because of icu compile
error. Please, help.
uname -a
FreeBSD db.x-pro.ru 10.0-RELEASE FreeBSD 10.0-RELEASE #0 r260789 amd64

...

c++ -DICU_NO_USER_DATA_OVERRIDE -D_REENTRANT -DU_HAVE_ELF_H=1
-DU_HAVE_ATOMIC=1 -DU_HAVE_TIMEZONE=0 -DU_HAVE_STRTOD_L=1
-DU_HAVE_XLOCALE_H=1 -DU_DISABLE_RENAMING=1 -I. -I../common
-DU_ATTRIBUTE_D
EPRECATED= -DU_I18N_IMPLEMENTATION -O2 -pipe -fstack-protector
-fno-strict-aliasing -W -Wall -pedantic -Wpointer-arith -Wwrite-strings
-Wno-long-long -std=c++11 -c -o number_patternmodifier.ao nu
                                      mber_patternmodifier.cpp
number_formatimpl.cpp:168:37: error: object of type
'icu::number::impl::CurrencySymbols' cannot be assigned because its copy
assignment operator is implicitly deleted
        fWarehouse.fCurrencySymbols = {currency, macros.locale, status};
                                    ^
./number_currencysymbols.h:43:16: note: copy assignment operator of
'CurrencySymbols' is implicitly deleted because field 'fLocaleName' has an
inaccessible copy assignment operator
    CharString fLocaleName;
               ^
1 error generated.
gmake[2]: *** [../config/mh-bsd-gcc:49: number_formatimpl.ao] Error 1
gmake[2]: *** Waiting for unfinished jobs....
gmake[2]: Leaving directory '/usr/ports/devel/icu/work/icu/source/i18n'
gmake[1]: *** [Makefile:149: all-recursive] Error 2
gmake[1]: Leaving directory '/usr/ports/devel/icu/work/icu/source'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/icu
** Command failed [exit code 1]: /usr/bin/script -qa
/tmp/portupgrade20180825-30263-1eucfbn env UPGRADE_TOOL=portupgrade
UPGRADE_PORT=icu-61.1,1 UPGRADE_PORT_VER=61.1,1 make
** Fix the problem and try again.


--
regards,
Alexander Evdokimov
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: icu 62.1_2,1 compile error

Jan Beich-5
Alexander Evdokimov <[hidden email]> writes:

> Hello,
>
> We can't update any packagies depended on ICU, because of icu compile
> error. Please, help.
> uname -a
> FreeBSD db.x-pro.ru 10.0-RELEASE FreeBSD 10.0-RELEASE #0 r260789 amd64

10.0-RELEASE reached EOL on 2015-02-28. As of /stable/10 in-base toolchain
remains one of major contributors to planned obsolescence. Not much you can
do other than upgrade to a supported FreeBSD version[1] or switch the ports
tree to a revision close to the EOL date.

[1] https://www.freebsd.org/security/#sup
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-office
To unsubscribe, send any mail to "[hidden email]"