[package - head-i386-default][devel/anjuta-extras] Failed for anjuta-extras-3.10.0 in build

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[package - head-i386-default][devel/anjuta-extras] Failed for anjuta-extras-3.10.0 in build

pkg-fallout
You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     [hidden email]
Last committer: [hidden email]
Ident:          $FreeBSD: head/devel/anjuta-extras/Makefile 412346 2016-04-01 14:00:51Z mat $
Log URL:        http://beefy11.nyi.freebsd.org/data/head-i386-default/p436460_s315527/logs/anjuta-extras-3.10.0.log
Build URL:      http://beefy11.nyi.freebsd.org/build.html?mastername=head-i386-default&build=p436460_s315527
Log:

====>> Building devel/anjuta-extras
build started at Mon Mar 20 22:29:04 UTC 2017
port directory: /usr/ports/devel/anjuta-extras
building for: FreeBSD head-i386-default-job-08 12.0-CURRENT FreeBSD 12.0-CURRENT r315527 i386
maintained by: [hidden email]
Makefile ident:      $FreeBSD: head/devel/anjuta-extras/Makefile 412346 2016-04-01 14:00:51Z mat $
Poudriere version: 3.1.15-2-g0a86c900
Host OSVERSION: 1200020
Jail OSVERSION: 1200025
Job Id: 08




!!! Jail is newer than host. (Jail: 1200025, Host: 1200020) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
OSVERSION=1200025
UNAME_v=FreeBSD 12.0-CURRENT r315527
UNAME_r=12.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/head-i386-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=anjuta-extras-3.10.0
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/head-i386-default/ref/.p/pool
MASTERNAME=head-i386-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.15-2-g0a86c900
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake PKG_CONFIG=pkgconf XDG_DATA_HOME=/wrkdirs/usr/ports/devel/anjuta-extras/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/anjuta-extras/work  HOME=/wrkdirs/usr/ports/devel/anjuta-extras/work TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/anjuta-extras/work  XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/anjuta-extras/work  HOME=/wrkdirs/usr/ports/devel/anjuta-extras/work TMPDIR="/tmp" NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe  -fstack-protector -fno-strict-aliasing"  CPP="cpp" CPPFLAGS="-I/usr/local/include"  LDFLAGS=" -L/usr/local/lib -fstack-protector" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector -fno-strict-aliasing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
OSREL=12.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/anjuta-extras"
EXAMPLESDIR="share/examples/anjuta-extras"
DATADIR="share/anjuta-extras"
WWWDIR="www/anjuta-extras"
ETCDIR="etc/anjuta-extras"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/anjuta-extras
DOCSDIR=/usr/local/share/doc/anjuta-extras
EXAMPLESDIR=/usr/local/share/examples/anjuta-extras
WWWDIR=/usr/local/www/anjuta-extras
ETCDIR=/usr/local/etc/anjuta-extras
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
ARCH=i386
CONFIGURE_MAX_CMD_LEN=262144
OPSYS=FreeBSD
OSREL=12.0
OSVERSION=1200025
PYTHONBASE=/usr/local
UID=0
_JAVA_OS_LIST_REGEXP=native\|linux
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
_OSRELEASE=12.0-CURRENT
#### Misc Poudriere ####
GID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  524288
stack size              (kbytes, -s)  65536
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   anjuta-extras-3.10.0 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.10.0_2.txz
[head-i386-default-job-08] Installing pkg-1.10.0_2...
[head-i386-default-job-08] Extracting pkg-1.10.0_2: .......... done
===>   anjuta-extras-3.10.0 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of anjuta-extras-3.10.0
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by anjuta-extras-3.10.0 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by anjuta-extras-3.10.0 for building
=> SHA256 Checksum OK for anjuta-extras-3.10.0.tar.xz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by anjuta-extras-3.10.0 for building
===>  Extracting for anjuta-extras-3.10.0
=> SHA256 Checksum OK for anjuta-extras-3.10.0.tar.xz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for anjuta-extras-3.10.0
===>  Applying FreeBSD patches for anjuta-extras-3.10.0
===========================================================================
=======================<phase: build-depends  >============================
===>   anjuta-extras-3.10.0 depends on executable: itstool - not found
===>   Installing existing package /packages/All/itstool-2.0.2_1.txz
[head-i386-default-job-08] Installing itstool-2.0.2_1...
[head-i386-default-job-08] `-- Installing py27-libxml2-2.9.4...
[head-i386-default-job-08] |   `-- Installing gettext-runtime-0.19.8.1_1...
[head-i386-default-job-08] |   | `-- Installing indexinfo-0.2.6...
[head-i386-default-job-08] |   | `-- Extracting indexinfo-0.2.6: .... done
[head-i386-default-job-08] |   `-- Extracting gettext-runtime-0.19.8.1_1: .......... done
[head-i386-default-job-08] |   `-- Installing libxml2-2.9.4...
[head-i386-default-job-08] |   `-- Extracting libxml2-2.9.4: .......... done
[head-i386-default-job-08] |   `-- Installing py27-setuptools-32.1.0_1...
[head-i386-default-job-08] |   | `-- Installing python27-2.7.13_1...
[head-i386-default-job-08] |   |   `-- Installing libffi-3.2.1...
[head-i386-default-job-08] |   |   `-- Extracting libffi-3.2.1: .......... done
[head-i386-default-job-08] |   |   `-- Installing readline-6.3.8...
[head-i386-default-job-08] |   |   `-- Extracting readline-6.3.8: .......... done
[head-i386-default-job-08] |   | `-- Extracting python27-2.7.13_1: .......... done
[head-i386-default-job-08] |   `-- Extracting py27-setuptools-32.1.0_1: .......... done
[head-i386-default-job-08] |   `-- Installing python2-2_3...
[head-i386-default-job-08] |   `-- Extracting python2-2_3: ...... done
[head-i386-default-job-08] `-- Extracting py27-libxml2-2.9.4: .......... done
[head-i386-default-job-08] Extracting itstool-2.0.2_1: .......... done
Message from python27-2.7.13_1:
<snip>
                 ^
gtk/PlatGTK.cxx:118:5: warning: macro expansion producing 'defined' has undefined behavior [-Wexpansion-to-defined]
gtk/PlatGTK.cxx:39:49: note: expanded from macro 'USE_LOCK'
#define USE_LOCK defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
                                                ^
gtk/PlatGTK.cxx:132:5: warning: macro expansion producing 'defined' has undefined behavior [-Wexpansion-to-defined]
#if USE_LOCK
    ^
gtk/PlatGTK.cxx:39:18: note: expanded from macro 'USE_LOCK'
#define USE_LOCK defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
                 ^
gtk/PlatGTK.cxx:132:5: warning: macro expansion producing 'defined' has undefined behavior [-Wexpansion-to-defined]
gtk/PlatGTK.cxx:39:49: note: expanded from macro 'USE_LOCK'
#define USE_LOCK defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
                                                ^
gtk/PlatGTK.cxx:146:5: warning: macro expansion producing 'defined' has undefined behavior [-Wexpansion-to-defined]
#if USE_LOCK
    ^
gtk/PlatGTK.cxx:39:18: note: expanded from macro 'USE_LOCK'
#define USE_LOCK defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
                 ^
gtk/PlatGTK.cxx:146:5: warning: macro expansion producing 'defined' has undefined behavior [-Wexpansion-to-defined]
gtk/PlatGTK.cxx:39:49: note: expanded from macro 'USE_LOCK'
#define USE_LOCK defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
                                                ^
gtk/PlatGTK.cxx:152:5: warning: macro expansion producing 'defined' has undefined behavior [-Wexpansion-to-defined]
#if USE_LOCK
    ^
gtk/PlatGTK.cxx:39:18: note: expanded from macro 'USE_LOCK'
#define USE_LOCK defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
                 ^
gtk/PlatGTK.cxx:152:5: warning: macro expansion producing 'defined' has undefined behavior [-Wexpansion-to-defined]
gtk/PlatGTK.cxx:39:49: note: expanded from macro 'USE_LOCK'
#define USE_LOCK defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
                                                ^
gtk/PlatGTK.cxx:1312:13: warning: 'gdk_cursor_new' is deprecated [-Wdeprecated-declarations]
                gdkCurs = gdk_cursor_new(GDK_XTERM);
                          ^
/usr/local/include/gtk-3.0/gdk/gdkcursor.h:228:12: note: 'gdk_cursor_new' has been explicitly marked deprecated here
GdkCursor* gdk_cursor_new                (GdkCursorType    cursor_type);
           ^
gtk/PlatGTK.cxx:1315:13: warning: 'gdk_cursor_new' is deprecated [-Wdeprecated-declarations]
                gdkCurs = gdk_cursor_new(GDK_LEFT_PTR);
                          ^
/usr/local/include/gtk-3.0/gdk/gdkcursor.h:228:12: note: 'gdk_cursor_new' has been explicitly marked deprecated here
GdkCursor* gdk_cursor_new                (GdkCursorType    cursor_type);
           ^
gtk/PlatGTK.cxx:1318:13: warning: 'gdk_cursor_new' is deprecated [-Wdeprecated-declarations]
                gdkCurs = gdk_cursor_new(GDK_CENTER_PTR);
                          ^
/usr/local/include/gtk-3.0/gdk/gdkcursor.h:228:12: note: 'gdk_cursor_new' has been explicitly marked deprecated here
GdkCursor* gdk_cursor_new                (GdkCursorType    cursor_type);
           ^
gtk/PlatGTK.cxx:1321:13: warning: 'gdk_cursor_new' is deprecated [-Wdeprecated-declarations]
                gdkCurs = gdk_cursor_new(GDK_WATCH);
                          ^
/usr/local/include/gtk-3.0/gdk/gdkcursor.h:228:12: note: 'gdk_cursor_new' has been explicitly marked deprecated here
GdkCursor* gdk_cursor_new                (GdkCursorType    cursor_type);
           ^
gtk/PlatGTK.cxx:1324:13: warning: 'gdk_cursor_new' is deprecated [-Wdeprecated-declarations]
                gdkCurs = gdk_cursor_new(GDK_HAND2);
                          ^
/usr/local/include/gtk-3.0/gdk/gdkcursor.h:228:12: note: 'gdk_cursor_new' has been explicitly marked deprecated here
GdkCursor* gdk_cursor_new                (GdkCursorType    cursor_type);
           ^
gtk/PlatGTK.cxx:1327:13: warning: 'gdk_cursor_new' is deprecated [-Wdeprecated-declarations]
                gdkCurs = gdk_cursor_new(GDK_RIGHT_PTR);
                          ^
/usr/local/include/gtk-3.0/gdk/gdkcursor.h:228:12: note: 'gdk_cursor_new' has been explicitly marked deprecated here
GdkCursor* gdk_cursor_new                (GdkCursorType    cursor_type);
           ^
gtk/PlatGTK.cxx:1330:13: warning: 'gdk_cursor_new' is deprecated [-Wdeprecated-declarations]
                gdkCurs = gdk_cursor_new(GDK_LEFT_PTR);
                          ^
/usr/local/include/gtk-3.0/gdk/gdkcursor.h:228:12: note: 'gdk_cursor_new' has been explicitly marked deprecated here
GdkCursor* gdk_cursor_new                (GdkCursorType    cursor_type);
           ^
gtk/PlatGTK.cxx:1480:3: warning: 'gtk_widget_override_color' is deprecated [-Wdeprecated-declarations]
                gtk_widget_override_color(w, GTK_STATE_FLAG_ACTIVE, &colourForeSelected);
                ^
/usr/local/include/gtk-3.0/gtk/gtkwidget.h:1133:14: note: 'gtk_widget_override_color' has been explicitly marked deprecated here
void         gtk_widget_override_color            (GtkWidget     *widget,
             ^
gtk/PlatGTK.cxx:1487:2: warning: 'gtk_style_context_get_background_color' is deprecated [-Wdeprecated-declarations]
        gtk_style_context_get_background_color(styleContext, GTK_STATE_FLAG_SELECTED, &colourBaseSelected);
        ^
/usr/local/include/gtk-3.0/gtk/gtkstylecontext.h:1160:6: note: 'gtk_style_context_get_background_color' has been explicitly marked deprecated here
void gtk_style_context_get_background_color (GtkStyleContext *context,
     ^
gtk/PlatGTK.cxx:1489:2: warning: 'gtk_style_context_get_background_color' is deprecated [-Wdeprecated-declarations]
        gtk_style_context_get_background_color(styleContext, GTK_STATE_FLAG_ACTIVE, &colourBaseActive);
        ^
/usr/local/include/gtk-3.0/gtk/gtkstylecontext.h:1160:6: note: 'gtk_style_context_get_background_color' has been explicitly marked deprecated here
void gtk_style_context_get_background_color (GtkStyleContext *context,
     ^
gtk/PlatGTK.cxx:1491:3: warning: 'gtk_widget_override_background_color' is deprecated [-Wdeprecated-declarations]
                gtk_widget_override_background_color(w, GTK_STATE_FLAG_ACTIVE, &colourBaseSelected);
                ^
/usr/local/include/gtk-3.0/gtk/gtkwidget.h:1137:14: note: 'gtk_widget_override_background_color' has been explicitly marked deprecated here
void         gtk_widget_override_background_color (GtkWidget     *widget,
             ^
gtk/PlatGTK.cxx:1569:3: warning: 'gtk_widget_override_font' is deprecated [-Wdeprecated-declarations]
                gtk_widget_override_font(PWidget(list), PFont(scint_font)->pfd);
                ^
/usr/local/include/gtk-3.0/gtk/gtkwidget.h:1142:14: note: 'gtk_widget_override_font' has been explicitly marked deprecated here
void         gtk_widget_override_font             (GtkWidget                  *widget,
             ^
22 warnings generated.
libtool: compile:  c++ -DHAVE_CONFIG_H -I. -I../../.. -I./include -I./src -I./lexlib -I/usr/local/include/libanjuta-3.0 -I/usr/local/include/gtk-3.0 -I/usr/local/include/pango-1.0 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include -I/usr/local/include/cairo -I/usr/local/include/pixman-1 -I/usr/local/include/freetype2 -I/usr/local/include/libdrm -I/usr/local/include/libpng16 -I/usr/local/include/harfbuzz -I/usr/local/include/gdk-pixbuf-2.0 -D_THREAD_SAFE -I/usr/local/include/gio-unix-2.0/ -D_THREAD_SAFE -I/usr/local/include/atk-1.0 -pthread -I/usr/local/include/at-spi2-atk/2.0 -I/usr/local/include/at-spi-2.0 -I/usr/local/include/dbus-1.0 -I/usr/local/lib/dbus-1.0/include -I/usr/local/include/libgdl-3.0 -D_THREAD_SAFE -pthread -D_THREAD_SAFE -D_THREAD_SAFE -pthread -pthread -I/usr/local/include/libxml2 -pthread -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include -pthread -I/usr/local/include/glib-2.0 -I/usr/local/lib/gl
 ib-2.0/include -I/usr/local/include -DGTK -DSCI_LEXER -DUSE_XIM -I/usr/local/include -DGTK -DSCI_LEXER -DUSE_XIM -O2 -pipe -fstack-protector -fno-strict-aliasing -MT PlatGTK.lo -MD -MP -MF .deps/PlatGTK.Tpo -c gtk/PlatGTK.cxx -o PlatGTK.o >/dev/null 2>&1
mv -f .deps/PlatGTK.Tpo .deps/PlatGTK.Plo
/bin/sh ../../../libtool  --tag=CXX   --mode=compile c++ -DHAVE_CONFIG_H -I. -I../../..  -I./include -I./src -I./lexlib -I/usr/local/include/libanjuta-3.0 -I/usr/local/include/gtk-3.0 -I/usr/local/include/pango-1.0 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include -I/usr/local/include/cairo -I/usr/local/include/pixman-1 -I/usr/local/include/freetype2 -I/usr/local/include/libdrm -I/usr/local/include/libpng16 -I/usr/local/include/harfbuzz -I/usr/local/include/gdk-pixbuf-2.0 -D_THREAD_SAFE -I/usr/local/include/gio-unix-2.0/ -D_THREAD_SAFE -I/usr/local/include/atk-1.0 -pthread -I/usr/local/include/at-spi2-atk/2.0 -I/usr/local/include/at-spi-2.0 -I/usr/local/include/dbus-1.0 -I/usr/local/lib/dbus-1.0/include -I/usr/local/include/libgdl-3.0 -D_THREAD_SAFE -pthread -D_THREAD_SAFE -D_THREAD_SAFE -pthread -pthread -I/usr/local/include/libxml2  -pthread -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include  -pthread -I/usr/local
 /include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include  -DGTK -DSCI_LEXER -DUSE_XIM -I/usr/local/include -DGTK -DSCI_LEXER -DUSE_XIM -O2 -pipe -fstack-protector -fno-strict-aliasing  -MT ScintillaGTK.lo -MD -MP -MF .deps/ScintillaGTK.Tpo -c -o ScintillaGTK.lo `test -f 'gtk/ScintillaGTK.cxx' || echo './'`gtk/ScintillaGTK.cxx
libtool: compile:  c++ -DHAVE_CONFIG_H -I. -I../../.. -I./include -I./src -I./lexlib -I/usr/local/include/libanjuta-3.0 -I/usr/local/include/gtk-3.0 -I/usr/local/include/pango-1.0 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include -I/usr/local/include/cairo -I/usr/local/include/pixman-1 -I/usr/local/include/freetype2 -I/usr/local/include/libdrm -I/usr/local/include/libpng16 -I/usr/local/include/harfbuzz -I/usr/local/include/gdk-pixbuf-2.0 -D_THREAD_SAFE -I/usr/local/include/gio-unix-2.0/ -D_THREAD_SAFE -I/usr/local/include/atk-1.0 -pthread -I/usr/local/include/at-spi2-atk/2.0 -I/usr/local/include/at-spi-2.0 -I/usr/local/include/dbus-1.0 -I/usr/local/lib/dbus-1.0/include -I/usr/local/include/libgdl-3.0 -D_THREAD_SAFE -pthread -D_THREAD_SAFE -D_THREAD_SAFE -pthread -pthread -I/usr/local/include/libxml2 -pthread -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include -pthread -I/usr/local/include/glib-2.0 -I/usr/local/lib/gl
 ib-2.0/include -I/usr/local/include -DGTK -DSCI_LEXER -DUSE_XIM -I/usr/local/include -DGTK -DSCI_LEXER -DUSE_XIM -O2 -pipe -fstack-protector -fno-strict-aliasing -MT ScintillaGTK.lo -MD -MP -MF .deps/ScintillaGTK.Tpo -c gtk/ScintillaGTK.cxx  -fPIC -DPIC -o .libs/ScintillaGTK.o
gtk/ScintillaGTK.cxx:439:22: warning: 'gdk_cursor_new' is deprecated [-Wdeprecated-declarations]
        GdkCursor *cursor = gdk_cursor_new(GDK_XTERM);
                            ^
/usr/local/include/gtk-3.0/gdk/gdkcursor.h:228:12: note: 'gdk_cursor_new' has been explicitly marked deprecated here
GdkCursor* gdk_cursor_new                (GdkCursorType    cursor_type);
           ^
gtk/ScintillaGTK.cxx:448:3: warning: 'gtk_style_context_get_background_color' is deprecated [-Wdeprecated-declarations]
                gtk_style_context_get_background_color(styleContext, GTK_STATE_FLAG_NORMAL, &colourBackWidget);
                ^
/usr/local/include/gtk-3.0/gtk/gtkstylecontext.h:1160:6: note: 'gtk_style_context_get_background_color' has been explicitly marked deprecated here
void gtk_style_context_get_background_color (GtkStyleContext *context,
     ^
gtk/ScintillaGTK.cxx:492:11: warning: 'gdk_cursor_new' is deprecated [-Wdeprecated-declarations]
        cursor = gdk_cursor_new(GDK_XTERM);
                 ^
/usr/local/include/gtk-3.0/gdk/gdkcursor.h:228:12: note: 'gdk_cursor_new' has been explicitly marked deprecated here
GdkCursor* gdk_cursor_new                (GdkCursorType    cursor_type);
           ^
gtk/ScintillaGTK.cxx:496:11: warning: 'gdk_cursor_new' is deprecated [-Wdeprecated-declarations]
        cursor = gdk_cursor_new(GDK_LEFT_PTR);
                 ^
/usr/local/include/gtk-3.0/gdk/gdkcursor.h:228:12: note: 'gdk_cursor_new' has been explicitly marked deprecated here
GdkCursor* gdk_cursor_new                (GdkCursorType    cursor_type);
           ^
gtk/ScintillaGTK.cxx:500:11: warning: 'gdk_cursor_new' is deprecated [-Wdeprecated-declarations]
        cursor = gdk_cursor_new(GDK_LEFT_PTR);
                 ^
/usr/local/include/gtk-3.0/gdk/gdkcursor.h:228:12: note: 'gdk_cursor_new' has been explicitly marked deprecated here
GdkCursor* gdk_cursor_new                (GdkCursorType    cursor_type);
           ^
gtk/ScintillaGTK.cxx:761:2: warning: 'gtk_widget_set_double_buffered' is deprecated [-Wdeprecated-declarations]
        gtk_widget_set_double_buffered(widtxt, FALSE);
        ^
/usr/local/include/gtk-3.0/gtk/gtkwidget.h:876:23: note: 'gtk_widget_set_double_buffered' has been explicitly marked deprecated here
void                  gtk_widget_set_double_buffered    (GtkWidget    *widget,
                      ^
gtk/ScintillaGTK.cxx:844:2: warning: 'gtk_drag_begin' is deprecated [-Wdeprecated-declarations]
        gtk_drag_begin(GTK_WIDGET(PWidget(wMain)),
        ^
/usr/local/include/gtk-3.0/gtk/gtkdnd.h:196:17: note: 'gtk_drag_begin' has been explicitly marked deprecated here
GdkDragContext *gtk_drag_begin (GtkWidget         *widget,
                ^
gtk/ScintillaGTK.cxx:1143:3: warning: 'gtk_adjustment_changed' is deprecated [-Wdeprecated-declarations]
                gtk_adjustment_changed(GTK_ADJUSTMENT(adjustmentv));
                ^
/usr/local/include/gtk-3.0/gtk/gtkadjustment.h:87:12: note: 'gtk_adjustment_changed' has been explicitly marked deprecated here
void       gtk_adjustment_changed               (GtkAdjustment   *adjustment);
           ^
gtk/ScintillaGTK.cxx:1174:3: warning: 'gtk_adjustment_changed' is deprecated [-Wdeprecated-declarations]
                gtk_adjustment_changed(GTK_ADJUSTMENT(adjustmenth));
                ^
/usr/local/include/gtk-3.0/gtk/gtkadjustment.h:87:12: note: 'gtk_adjustment_changed' has been explicitly marked deprecated here
void       gtk_adjustment_changed               (GtkAdjustment   *adjustment);
           ^
gtk/ScintillaGTK.cxx:1557:33: error: ordered comparison between pointer and zero ('GdkAtom' (aka '_GdkAtom *') and 'int')
                if (TypeOfGSD(selection_data) > 0) {
                    ~~~~~~~~~~~~~~~~~~~~~~~~~ ^ ~
gtk/ScintillaGTK.cxx:1668:2: warning: 'gtk_widget_get_requisition' is deprecated [-Wdeprecated-declarations]
        gtk_widget_get_requisition(PWidget(scrollbarv), &requisition);
        ^
/usr/local/include/gtk-3.0/gtk/gtkwidget.h:937:23: note: 'gtk_widget_get_requisition' has been explicitly marked deprecated here
void                  gtk_widget_get_requisition        (GtkWidget     *widget,
                      ^
gtk/ScintillaGTK.cxx:1670:2: warning: 'gtk_widget_get_requisition' is deprecated [-Wdeprecated-declarations]
        gtk_widget_get_requisition(PWidget(scrollbarh), &requisition);
        ^
/usr/local/include/gtk-3.0/gtk/gtkwidget.h:937:23: note: 'gtk_widget_get_requisition' has been explicitly marked deprecated here
void                  gtk_widget_get_requisition        (GtkWidget     *widget,
                      ^
11 warnings and 1 error generated.
gmake[7]: *** [Makefile:1236: ScintillaGTK.lo] Error 1
gmake[7]: Leaving directory '/wrkdirs/usr/ports/devel/anjuta-extras/work/anjuta-extras-3.10.0/plugins/scintilla/scintilla'
gmake[6]: *** [Makefile:1899: all-recursive] Error 1
gmake[6]: Leaving directory '/wrkdirs/usr/ports/devel/anjuta-extras/work/anjuta-extras-3.10.0/plugins/scintilla/scintilla'
gmake[5]: *** [Makefile:743: all] Error 2
gmake[5]: Leaving directory '/wrkdirs/usr/ports/devel/anjuta-extras/work/anjuta-extras-3.10.0/plugins/scintilla/scintilla'
gmake[4]: *** [Makefile:785: all-recursive] Error 1
gmake[4]: Leaving directory '/wrkdirs/usr/ports/devel/anjuta-extras/work/anjuta-extras-3.10.0/plugins/scintilla'
gmake[3]: *** [Makefile:404: all-recursive] Error 1
gmake[3]: Leaving directory '/wrkdirs/usr/ports/devel/anjuta-extras/work/anjuta-extras-3.10.0/plugins'
gmake[2]: *** [Makefile:450: all-recursive] Error 1
gmake[2]: Leaving directory '/wrkdirs/usr/ports/devel/anjuta-extras/work/anjuta-extras-3.10.0'
gmake[1]: *** [Makefile:381: all] Error 2
gmake[1]: Leaving directory '/wrkdirs/usr/ports/devel/anjuta-extras/work/anjuta-extras-3.10.0'
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/anjuta-extras
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Loading...