pkg install package size mismatch

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

pkg install package size mismatch

Karel Gardas
Hello,

I'm running up-to-date 13.0-current on PowerKVM and while trying to
install cmake I've hit "size mismatch" error. My guess is that pkg tries
to contact repo mirror not fully updated yet or not fully in-sync.
However I'm just FreeBSD beginner so I'd like to ask if there are other
explanations for this error, especially if there may be some mistake on
user side. Whole error output is provided below.

Thanks,
Karel


# pkg install cmake
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
The following 9 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
         cmake: 3.13.4
         rhash: 1.3.5
         curl: 7.64.0_1
         libnghttp2: 1.36.0
         libuv: 1.26.0
         jsoncpp: 1.8.1_6
         libarchive: 3.3.3,1
         lzo2: 2.10_1
         liblz4: 1.8.3,1

Number of packages to be installed: 9

The process will require 38 MiB more space.
7 MiB to be downloaded.

Proceed with this action? [y/N]: y
[1/9] Fetching cmake-3.13.4.txz: 100%    4 MiB   2.3MB/s    00:02
pkg: cached package cmake-3.13.4: size mismatch, fetching from remote
[2/9] Fetching cmake-3.13.4.txz: 100%    4 MiB   2.3MB/s    00:02
pkg: cached package cmake-3.13.4: size mismatch, cannot continue

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-ppc
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: pkg install package size mismatch

Sean Bruno-7


On 3/15/19 4:17 PM, Karel Gardas wrote:

> Hello,
>
> I'm running up-to-date 13.0-current on PowerKVM and while trying to
> install cmake I've hit "size mismatch" error. My guess is that pkg tries
> to contact repo mirror not fully updated yet or not fully in-sync.
> However I'm just FreeBSD beginner so I'd like to ask if there are other
> explanations for this error, especially if there may be some mistake on
> user side. Whole error output is provided below.
>
> Thanks,
> Karel
>
>
> # pkg install cmake
> Updating FreeBSD repository catalogue...
> FreeBSD repository is up to date.
> All repositories are up to date.
> The following 9 package(s) will be affected (of 0 checked):
>
> New packages to be INSTALLED:
>         cmake: 3.13.4
>         rhash: 1.3.5
>         curl: 7.64.0_1
>         libnghttp2: 1.36.0
>         libuv: 1.26.0
>         jsoncpp: 1.8.1_6
>         libarchive: 3.3.3,1
>         lzo2: 2.10_1
>         liblz4: 1.8.3,1
>
> Number of packages to be installed: 9
>
> The process will require 38 MiB more space.
> 7 MiB to be downloaded.
>
> Proceed with this action? [y/N]: y
> [1/9] Fetching cmake-3.13.4.txz: 100%    4 MiB   2.3MB/s    00:02
> pkg: cached package cmake-3.13.4: size mismatch, fetching from remote
> [2/9] Fetching cmake-3.13.4.txz: 100%    4 MiB   2.3MB/s    00:02
> pkg: cached package cmake-3.13.4: size mismatch, cannot continue
>
> _______________________________________________
> [hidden email] mailing list
> https://lists.freebsd.org/mailman/listinfo/freebsd-ppc
> To unsubscribe, send any mail to "[hidden email]"

If you do a "pkg update -f" and then a "pkg install cmake" does this fix
your problem?

sean


signature.asc (631 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: pkg install package size mismatch

Karel Gardas


On 3/16/19 5:53 PM, Sean Bruno wrote:

>
> On 3/15/19 4:17 PM, Karel Gardas wrote:
>> Proceed with this action? [y/N]: y
>> [1/9] Fetching cmake-3.13.4.txz: 100%    4 MiB   2.3MB/s    00:02
>> pkg: cached package cmake-3.13.4: size mismatch, fetching from remote
>> [2/9] Fetching cmake-3.13.4.txz: 100%    4 MiB   2.3MB/s    00:02
>> pkg: cached package cmake-3.13.4: size mismatch, cannot continue
>>
>> _______________________________________________
>> [hidden email] mailing list
>> https://lists.freebsd.org/mailman/listinfo/freebsd-ppc
>> To unsubscribe, send any mail to "[hidden email]"
>
> If you do a "pkg update -f" and then a "pkg install cmake" does this fix
> your problem?
>
> sean
>
Thanks for the help, this indeed helps!

Karel

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-ppc
To unsubscribe, send any mail to "[hidden email]"