pkg issues: files not registered as installed, breaks pkg check

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

pkg issues: files not registered as installed, breaks pkg check

paul beard-2
Checking all packages: 100%
gtk-update-icon-cache has require a missing libraries: libgdk_pixbuf-2.0.so.0
gtk2 has require a missing libraries: libgdk_pixbuf-2.0.so.0
gutenprint-base has require a missing libraries: libgdk_pixbuf-2.0.so.0

# locate libgdk_pixbuf-2.0.so.0
/usr/local/lib/compat/pkg/libgdk_pixbuf-2.0.so.0.3100.2
/usr/local/lib/compat/pkg/libgdk_pixbuf-2.0.so.0.3100.5
/usr/local/lib/compat/pkg/libgdk_pixbuf-2.0.so.0.3100.6
/usr/local/lib/compat/pkg/libgdk_pixbuf-2.0.so.0.3100.7
/usr/local/lib/libgdk_pixbuf-2.0.so.0
/usr/local/lib/libgdk_pixbuf-2.0.so.0.3200.3

# pkg which /usr/local/lib/libgdk_pixbuf-2.0.so.0
/usr/local/lib/libgdk_pixbuf-2.0.so.0 was installed by package gdk-pixbuf2-2.32.3

# pkg info gdk-pixbuf2 | grep libgdk_pixbuf-2.0.so.0
#

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: pkg issues: files not registered as installed, breaks pkg check

Koop Mast-2
On Wed, 2016-03-23 at 18:22 -0700, Paul Beard wrote:
> Checking all packages: 100%
> gtk-update-icon-cache has require a missing libraries: libgdk_pixbuf-
> 2.0.so.0
> gtk2 has require a missing libraries: libgdk_pixbuf-2.0.so.0
> gutenprint-base has require a missing libraries: libgdk_pixbuf-
> 2.0.so.0

This doesn't make sense, since graphics/gtk-update-icon-cache has
USE_GNOME=gdk-pixbuf2. So gdk-pixbuf2 should be always be there.

-Koop

>
> # locate libgdk_pixbuf-2.0.so.0
> /usr/local/lib/compat/pkg/libgdk_pixbuf-2.0.so.0.3100.2
> /usr/local/lib/compat/pkg/libgdk_pixbuf-2.0.so.0.3100.5
> /usr/local/lib/compat/pkg/libgdk_pixbuf-2.0.so.0.3100.6
> /usr/local/lib/compat/pkg/libgdk_pixbuf-2.0.so.0.3100.7
> /usr/local/lib/libgdk_pixbuf-2.0.so.0
> /usr/local/lib/libgdk_pixbuf-2.0.so.0.3200.3
>
> # pkg which /usr/local/lib/libgdk_pixbuf-2.0.so.0
> /usr/local/lib/libgdk_pixbuf-2.0.so.0 was installed by package gdk-
> pixbuf2-2.32.3
>
> # pkg info gdk-pixbuf2 | grep libgdk_pixbuf-2.0.so.0
> # 
>
> _______________________________________________
> [hidden email] mailing list
> https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
> To unsubscribe, send any mail to "[hidden email]
> rg"
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: pkg issues: files not registered as installed, breaks pkg check

Kevin Oberman-4
On Fri, Mar 25, 2016 at 2:02 AM, Koop Mast <[hidden email]> wrote:

> On Wed, 2016-03-23 at 18:22 -0700, Paul Beard wrote:
> > Checking all packages: 100%
> > gtk-update-icon-cache has require a missing libraries: libgdk_pixbuf-
> > 2.0.so.0
> > gtk2 has require a missing libraries: libgdk_pixbuf-2.0.so.0
> > gutenprint-base has require a missing libraries: libgdk_pixbuf-
> > 2.0.so.0
>
> This doesn't make sense, since graphics/gtk-update-icon-cache has
> USE_GNOME=gdk-pixbuf2. So gdk-pixbuf2 should be always be there.
>
> -Koop
>
>
Not sure that this has any relevance, but what version of pkg is installed?
That mangled error message should have been fixed several months ago.
--
Kevin Oberman, Part time kid herder and retired Network Engineer
E-mail: [hidden email]
PGP Fingerprint: D03FB98AFA78E3B78C1694B318AB39EF1B055683
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: pkg issues: files not registered as installed, breaks pkg check

paul beard-2

> On Mar 25, 2016, at 5:55 PM, Kevin Oberman <[hidden email]> wrote:
>
> Not sure that this has any relevance, but what version of pkg is installed? That mangled error message should have been fixed several months ago.

1.6.4

I update ports regularly so pkg should be up to date.
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: pkg issues: files not registered as installed, breaks pkg check

Kevin Oberman-4
Sounds like the fix Bapt made somehow got lost. Not relevant to this
problem, so I'll open a new ticket.

Sorry for the red herring.
On Mar 25, 2016 6:09 PM, "Paul Beard" <[hidden email]> wrote:

>
> On Mar 25, 2016, at 5:55 PM, Kevin Oberman <[hidden email]> wrote:
>
> Not sure that this has any relevance, but what version of pkg is
> installed? That mangled error message should have been fixed several months
> ago.
>
>
> 1.6.4
>
> I update ports regularly so pkg should be up to date.
>
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: pkg issues: files not registered as installed, breaks pkg check

paul beard-2


> On Mar 25, 2016, at 6:14 PM, Kevin Oberman <[hidden email]> wrote:
>
> Sounds like the fix Bapt made somehow got lost. Not relevant to this problem, so I'll open a new ticket.

Odd that no one on the pkg team saw the malformed messages that would indicate this. What version are they using?
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: pkg issues: files not registered as installed, breaks pkg check

Kevin Oberman-4
Pail,

It was reported and fixed in the git repo where pkg development is done,
but that source file had no other fixes and merging it into the port was
overlooked.

Poor language in error messages is common since people most likely don't
see them often and even more seldom actually report them.

Again, this is not related to your problem.

Kevin Oberman, Part time kid herder and retired Network Engineer
E-mail: [hidden email]
PGP Fingerprint: D03FB98AFA78E3B78C1694B318AB39EF1B055683

On Sat, Mar 26, 2016 at 8:59 AM, Paul Beard <[hidden email]> wrote:

>
>
> > On Mar 25, 2016, at 6:14 PM, Kevin Oberman <[hidden email]> wrote:
> >
> > Sounds like the fix Bapt made somehow got lost. Not relevant to this
> problem, so I'll open a new ticket.
>
> Odd that no one on the pkg team saw the malformed messages that would
> indicate this. What version are they using?
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: pkg issues: files not registered as installed, breaks pkg check

paul beard-2
In reply to this post by Koop Mast-2

On Mar 25, 2016, at 2:02 AM, Koop Mast <[hidden email]> wrote:

> This doesn't make sense, since graphics/gtk-update-icon-cache has
> USE_GNOME=gdk-pixbuf2. So gdk-pixbuf2 should be always be there.
>

I thought I had tried this before but tonight I deinstalled gdk-pixbuf2
and then ran pkg check -Bdrs. It noted the missing dependency and
offered to fix it. A re-run of pkg check -Bdrs shows the all clear.

gtk and gutenprint-cups were updated tonight so maybe that triggered
something.


Checking all packages: 100%
gtk-update-icon-cache has a missing dependency: gdk-pixbuf2
gtk-update-icon-cache has require a missing libraries:
libgdk_pixbuf-2.0.so.0
gtk2 has a missing dependency: gdk-pixbuf2
gtk2 has require a missing libraries: libgdk_pixbuf-2.0.so.0
gutenprint-base has require a missing libraries: libgdk_pixbuf-2.0.so.0

>>> Missing package dependencies were detected.
>>> Found 1 issue(s) in the package database.
>>>
The following packages will be installed:

New packages to be INSTALLED:
        gdk-pixbuf2: 2.32.3

The process will require 3 MiB more space.
466 KiB to be downloaded.

>>> Try to fix the missing dependencies? [y/N]: y
Fetching gdk-pixbuf2-2.32.3.txz: 100%  466 KiB 159.2kB/s    00:03    
Checking integrity... done (0 conflicting)
Installing gdk-pixbuf2-2.32.3...
Extracting gdk-pixbuf2-2.32.3: 100%
>>> Summary of actions performed:
>>>
gdk-pixbuf2 dependency has been fixed

>>> Missing dependencies were fixed successfully.
[root@www /usr/ports/graphics/gdk-pixbuf2]# pkg check -Bdrs
Checking all packages: 100%

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[hidden email]"