ports/92400: emulators/linux-ePSXe marked for i386 only, but also runs on amd64

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

ports/92400: emulators/linux-ePSXe marked for i386 only, but also runs on amd64

Yuri Pankov

>Number:         92400
>Category:       ports
>Synopsis:       emulators/linux-ePSXe marked for i386 only, but also runs on amd64
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-ports-bugs
>State:          open
>Quarter:        
>Keywords:      
>Date-Required:
>Class:          change-request
>Submitter-Id:   current-users
>Arrival-Date:   Fri Jan 27 02:50:02 GMT 2006
>Closed-Date:
>Last-Modified:
>Originator:     Yuri Pankov
>Release:        7.0-CURRENT/amd64
>Organization:
none
>Environment:
FreeBSD hpc.crsd.org.ru 7.0-CURRENT FreeBSD 7.0-CURRENT #0: Thu Jan 26 08:25:56 MSK 2006 [hidden email]:/usr/obj/usr/src/sys/CRSD  amd64
>Description:
    Sony Playstation emulator, located in /usr/ports/emulator/linux-ePSXe is marked for i386 only, but runs pretty well on amd64 also (tested on Final Fantasy IX, Valkyrie Profile, etc.). Changing Makefile to be ONLY_FOR_ARCHS= i386 amd64 makes for a successfull install on amd64. Also the following ports should be changed: emulators/linux-peops-softgpu, emulators/linux-peops-spu, emulators/linux-pete-mesagpu, emulators/linux-pete-xgl2gpu (last two are not tested due to lack of nvidia-driver for amd64).
    Some notes: at least linux_base-8 and linux-gtk have to be installed prior to this port installation, because when they are installed as dependency, they try to fetch amd64 rpms, which is obviously wrong. Also it should be mentioned that mounted linprocfs is required to run linux-ePSXe.
>How-To-Repeat:
---
>Fix:
---
>Release-Note:
>Audit-Trail:
>Unformatted:
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports-bugs
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: ports/92400: emulators/linux-ePSXe marked for i386 only, but also runs on amd64

Edwin Groothuis-2
Synopsis: emulators/linux-ePSXe marked for i386 only, but also runs on amd64

Responsible-Changed-From-To: freebsd-ports-bugs->jylefort
Responsible-Changed-By: edwin
Responsible-Changed-When: Fri Jan 27 02:56:45 UTC 2006
Responsible-Changed-Why:
Over to maintainer

http://www.freebsd.org/cgi/query-pr.cgi?pr=92400
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports-bugs
To unsubscribe, send any mail to "[hidden email]"