revision higher than 250508 breaks webcam support

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

revision higher than 250508 breaks webcam support

Jože Zobec
Sorry, for waiting this long to post this problem, I thought it would be dealt with this week, but since it wasn't better to report it now. I hope this is the right mailing list for this particular problem.

I am running FreeBSD 9.1-STABLE and using Logitech Webcam C525. I it's not listed amongst the supported hardware, but it was working perfectly until the updates that came this Sunday, 2013-05-12.

The problem I'm getting is this:

I keep getting this error message from the kernel, if I'm using 9.1-STABLE r250707

...
pcm6: detached
ugen7.2: <vendor 0x046d> at asbus7
uaudio0: <vendor 0x046d HD Webcam C525, class 239/2, rev 2.00/0.10, addr 2> on usbus7
uaudio0: No playback.
uaudio0: Record: 48000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Record: 32000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Record: 24000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Record: 16000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio: No MIDI squencer.
pcm6: <USB audio> on uaudio0
uaudio0: No HID volume keys found.
ugen7.2: <vendor 0x046d> at usbus7 (disconnected)
uaudio0: at uhub7, port4, addr 2 (disconnected)
pcm6: detached
...

This message is displayed periodically "ad infinitum" or at least until I unplug the webcam. It stays this way, even if I use the GENERIC kernel. In a "healthy" case, revision 250508, kernel message upon plugging the webcam, is

...
ugen7.2: <vendor 0x046d> at usbus7
uaudio0: <vendor 0x046d HD Webcam C525, class 239/2, rev 2.00/1.00, addr2> on usbus7
uaudio: No playback.
uaudio: Record: 48000 Hz, 1 ch, 16 bit S-LE PCM format, 2x8ms buffer.
uaudio: No MIDI sequencer.
pcm6: <USB audio> on uaudio0
uaudio0: No HID volume keys found.

And there it stops, and the webcam works in Skype.
     
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-stable
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: revision higher than 250508 breaks webcam support

Adrian Chadd-2
Are you able to narrow down the specific commit along 9-stable that broke it?

Thanks!



Adrian

On 16 May 2013 18:00, Jože Zobec <[hidden email]> wrote:

> Sorry, for waiting this long to post this problem, I thought it would be dealt with this week, but since it wasn't better to report it now. I hope this is the right mailing list for this particular problem.
>
> I am running FreeBSD 9.1-STABLE and using Logitech Webcam C525. I it's not listed amongst the supported hardware, but it was working perfectly until the updates that came this Sunday, 2013-05-12.
>
> The problem I'm getting is this:
>
> I keep getting this error message from the kernel, if I'm using 9.1-STABLE r250707
>
> ...
> pcm6: detached
> ugen7.2: <vendor 0x046d> at asbus7
> uaudio0: <vendor 0x046d HD Webcam C525, class 239/2, rev 2.00/0.10, addr 2> on usbus7
> uaudio0: No playback.
> uaudio0: Record: 48000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
> uaudio0: Record: 32000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
> uaudio0: Record: 24000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
> uaudio0: Record: 16000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
> uaudio: No MIDI squencer.
> pcm6: <USB audio> on uaudio0
> uaudio0: No HID volume keys found.
> ugen7.2: <vendor 0x046d> at usbus7 (disconnected)
> uaudio0: at uhub7, port4, addr 2 (disconnected)
> pcm6: detached
> ...
>
> This message is displayed periodically "ad infinitum" or at least until I unplug the webcam. It stays this way, even if I use the GENERIC kernel. In a "healthy" case, revision 250508, kernel message upon plugging the webcam, is
>
> ...
> ugen7.2: <vendor 0x046d> at usbus7
> uaudio0: <vendor 0x046d HD Webcam C525, class 239/2, rev 2.00/1.00, addr2> on usbus7
> uaudio: No playback.
> uaudio: Record: 48000 Hz, 1 ch, 16 bit S-LE PCM format, 2x8ms buffer.
> uaudio: No MIDI sequencer.
> pcm6: <USB audio> on uaudio0
> uaudio0: No HID volume keys found.
>
> And there it stops, and the webcam works in Skype.
>
> _______________________________________________
> [hidden email] mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-stable
> To unsubscribe, send any mail to "[hidden email]"
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-stable
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: revision higher than 250508 breaks webcam support

Jeremy Chadwick-4
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-stable
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Fwd: revision higher than 250508 breaks webcam support

Jože Zobec-2
---------- Forwarded message ----------
From: Jože Zobec <[hidden email]>
Date: 2013/5/17
Subject: Re: revision higher than 250508 breaks webcam support
To: Jeremy Chadwick <[hidden email]>, Adrian Chadd <[hidden email]>


OK, I compiled and tried different revisions
r250559 -- OK
r250560 -- OK
r250561 -- error

Upon updating from r250560 to r250561, svn gave me

...
U       /usr/src/sys/dev/sound/usb/uaudio.c
 U      /usr/src/sys/dev
 U      /usr/src/sys
...

I tried

# svn diff -r 250560:250561 /usr/src | less

to see if I could localize the problem even further, but there are a lot of
changes so I don't know where it could go wrong, since I'm not the one who
wrote it.

I am looking forward to your fast reply,

Jože
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-stable
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: revision higher than 250508 breaks webcam support

Adrian Chadd-2
In reply to this post by Jeremy Chadwick-4
'ola!

Cool, you've nailed it down to a specific revision.

Can you create a PR (www.freebsd.org/send-pr.html) with all of this information?

Hans/USB folk - here's an interesting problem. The original email is below.

===

Sorry, for waiting this long to post this problem, I thought it would
be dealt with this week, but since it wasn't better to report it now.
I hope this is the right mailing list for this particular problem.

I am running FreeBSD 9.1-STABLE and using Logitech Webcam C525. I it's
not listed amongst the supported hardware, but it was working
perfectly until the updates that came this Sunday, 2013-05-12.

The problem I'm getting is this:

I keep getting this error message from the kernel, if I'm using
9.1-STABLE r250707

...
pcm6: detached
ugen7.2: <vendor 0x046d> at asbus7
uaudio0: <vendor 0x046d HD Webcam C525, class 239/2, rev 2.00/0.10,
addr 2> on usbus7
uaudio0: No playback.
uaudio0: Record: 48000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Record: 32000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Record: 24000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Record: 16000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio: No MIDI squencer.
pcm6: <USB audio> on uaudio0
uaudio0: No HID volume keys found.
ugen7.2: <vendor 0x046d> at usbus7 (disconnected)
uaudio0: at uhub7, port4, addr 2 (disconnected)
pcm6: detached
...

This message is displayed periodically "ad infinitum" or at least
until I unplug the webcam. It stays this way, even if I use the
GENERIC kernel. In a "healthy" case, revision 250508, kernel message
upon plugging the webcam, is

...
ugen7.2: <vendor 0x046d> at usbus7
uaudio0: <vendor 0x046d HD Webcam C525, class 239/2, rev 2.00/1.00,
addr2> on usbus7
uaudio: No playback.
uaudio: Record: 48000 Hz, 1 ch, 16 bit S-LE PCM format, 2x8ms buffer.
uaudio: No MIDI sequencer.
pcm6: <USB audio> on uaudio0
uaudio0: No HID volume keys found.

And there it stops, and the webcam works in Skype.

===


adrian

On 17 May 2013 04:14, Jože Zobec <[hidden email]> wrote:

> OK, I compiled and tried different revisions
> r250559 -- OK
> r250560 -- OK
> r250561 -- error
>
> Upon updating from r250560 to r250561, svn give me
>
> ...
> U       /usr/src/sys/dev/sound/usb/uaudio.c
>  U      /usr/src/sys/dev
>  U      /usr/src/sys
> ...
>
> I tried
>
> # svn diff -r 250560:250561 /usr/src | less
>
> to see if I could localize the problem even further, but there are a lot of
> changes so I don't know where it could go wrong, since I'm not the one who
> wrote it.
>
> I am looking forward to your fast reply,
>
> Jože
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-stable
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: revision higher than 250508 breaks webcam support

Matthias Apitz-4
In reply to this post by Jože Zobec-2
El día Friday, May 17, 2013 a las 01:51:08PM +0200, Jože Zobec escribió:

> ---------- Forwarded message ----------
> From: Jože Zobec <[hidden email]>
> Date: 2013/5/17
> Subject: Re: revision higher than 250508 breaks webcam support
> To: Jeremy Chadwick <[hidden email]>, Adrian Chadd <[hidden email]>
>
>
> OK, I compiled and tried different revisions
> r250559 -- OK
> r250560 -- OK
> r250561 -- error
>
> Upon updating from r250560 to r250561, svn gave me
>
> ...
> U       /usr/src/sys/dev/sound/usb/uaudio.c
>  U      /usr/src/sys/dev
>  U      /usr/src/sys
> ...
>

Hello,

I have the following set of laptops which are all running the same SVN
revision of the ports r315646 and only the last one was updated today to
a new base/head revision r250588:

| name         | kernel   | date         | ports (r or date) | remarks
+--------------+----------+--------------+-------------------+--------
| Aurora       | r235646  | May 19, 2012 | r315646 20130401  |
| tiny         | r235646  | May 19, 2012 | r315646 20130401  | cloned Aurora
| Perlach      | r235646  | May 19, 2012 | r315646 20130401  | cloned Aurora
| La-Habana    | r250588  | May 13, 2013 | r315646 20130401  |

the ports have been compiled on Aurora and moved via pkg_create(8) to
the other hosts (around 1200 ports); on 'La-Habana' where the new kernel
is running I have had to rebuild only cuse4bsd-kmod-0.1.27, because it's
a kmod and depends on the sources of the running kernel; on all systems
of r235646, Skype is fine with the cams I have, on r250588 my cams are
working with pwcview(1) but not with Skype.

What can we do to debug this?

We should move this thread to freebsd-multimedia only, I suggest.

Thanks

        matthias
--
Matthias Apitz               |  /"\ ASCII Ribbon Campaign: www.asciiribbon.org
E-mail: [hidden email]     |  \ / - No HTML/RTF in E-mail
WWW: http://www.unixarea.de/ |   X  - No proprietary attachments
phone: +49-170-4527211       |  / \ - Respect for open standards
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-stable
To unsubscribe, send any mail to "[hidden email]"