w/uptime broken in stable

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

w/uptime broken in stable

Christian Jachmann
Hello List,

seems that w and uptime are broken in 11.* since last week.


$uname -a
FreeBSD hurx.thc 11.1-STABLE FreeBSD 11.1-STABLE #16 r332505M: Sun Apr 15 14:22:38 CEST 2018     [hidden email]:/usr/obj/usr/src/sys/MY2  i386
$w
Segmentation fault
$uptime
Segmentation fau


maybe there is s.th. with libxo... no idea.

--
Christian Jachmann
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-stable
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: w/uptime broken in stable

David Wolfskill
On Mon, Apr 16, 2018 at 09:00:32AM +0200, Christian Jachmann wrote:

> Hello List,
>
> seems that w and uptime are broken in 11.* since last week.
>
>
> $uname -a
> FreeBSD hurx.thc 11.1-STABLE FreeBSD 11.1-STABLE #16 r332505M: Sun Apr 15 14:22:38 CEST 2018     [hidden email]:/usr/obj/usr/src/sys/MY2  i386
> $w
> Segmentation fault
> $uptime
> Segmentation fau
>
>
> maybe there is s.th. with libxo... no idea.
>
> --
> Christian Jachmann
> ....
That is not my experience:

albert(11.1-S)[1] uname -a
FreeBSD albert.catwhisker.org 11.1-STABLE FreeBSD 11.1-STABLE #614  r332507M/332511:1101515: Sun Apr 15 03:49:51 PDT 2018     [hidden email]:/common/S1/obj/usr/src/sys/ALBERT  amd64
albert(11.1-S)[2] uptime
 3:40AM  up 23:02, 21 users, load averages: 0.19, 0.15, 0.17
albert(11.1-S)[3] w | head -5
 3:40AM  up 23:02, 21 users, load averages: 0.16, 0.14, 0.17
USER       TTY      FROM                                      LOGIN@  IDLE WHAT
david      pts/1    g1-215.catwhisker.org                    Sun04AM     - tmu
david      pts/2    tmux(957).%0                             Sun04AM     - vi
david      pts/3    g1-215.catwhisker.org                    Sun04AM 17:18 tmu
albert(11.1-S)[4]

Peace,
david
--
David H. Wolfskill [hidden email]
Donald Trump's criticism of others comes across as psychological projection.

See http://www.catwhisker.org/~david/publickey.gpg for my public key.

signature.asc (631 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: w/uptime broken in stable

Christian Jachmann
Mon, Apr 16, 2018 at 03:41:44AM -0700, David Wolfskill :

> On Mon, Apr 16, 2018 at 09:00:32AM +0200, Christian Jachmann wrote:
> > Hello List,
> >
> > seems that w and uptime are broken in 11.* since last week.
> >
> >
> > $uname -a
> > FreeBSD hurx.thc 11.1-STABLE FreeBSD 11.1-STABLE #16 r332505M: Sun Apr 15 14:22:38 CEST 2018     [hidden email]:/usr/obj/usr/src/sys/MY2  i386
> > $w
> > Segmentation fault
> > $uptime
> > Segmentation fau
> >
> >
> > maybe there is s.th. with libxo... no idea.
> >
> > --
> > Christian Jachmann
> > ....
>
> That is not my experience:
>
> albert(11.1-S)[1] uname -a
> FreeBSD albert.catwhisker.org 11.1-STABLE FreeBSD 11.1-STABLE #614  r332507M/332511:1101515: Sun Apr 15 03:49:51 PDT 2018     [hidden email]:/common/S1/obj/usr/src/sys/ALBERT  amd64
> albert(11.1-S)[2] uptime
>  3:40AM  up 23:02, 21 users, load averages: 0.19, 0.15, 0.17
> albert(11.1-S)[3] w | head -5
>  3:40AM  up 23:02, 21 users, load averages: 0.16, 0.14, 0.17
> USER       TTY      FROM                                      LOGIN@  IDLE WHAT
> david      pts/1    g1-215.catwhisker.org                    Sun04AM     - tmu
> david      pts/2    tmux(957).%0                             Sun04AM     - vi
> david      pts/3    g1-215.catwhisker.org                    Sun04AM 17:18 tmu
> albert(11.1-S)[4]
>
> Peace,
> david

Jes :

On AMD64 everything is ok.

[jachmann@thematrix ~]$ w
 1:33PM  up 4 mins, 1 user, load averages: 0.23, 0.37, 0.19
USER       TTY      FROM                  LOGIN@  IDLE WHAT
jachmann   pts/0    hurx                  1:33PM     - w
[jachmann@thematrix ~]$ uptime
 1:33PM  up 4 mins, 1 user, load averages: 0.21, 0.36, 0.19
[jachmann@thematrix ~]$ uname -a
FreeBSD thematrix 11.1-STABLE FreeBSD 11.1-STABLE #19 r332554M: Mon Apr 16 11:03:31 CEST 2018     jachmann@thematrix:/usr/obj/usr/src/sys/MY  amd64
[jachmann@thematrix ~]$



But on i386.... it seems to be broken.

--
Christian
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-stable
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: w/uptime broken in stable

Eugene Grosbein-10
16.04.2018 18:35, Christian Jachmann wrote:

> But on i386.... it seems to be broken.

Why don't you rebuild src/usr/bin/w with debugging symbols, generate core and show backtrace?

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-stable
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: w/uptime broken in stable

Christian Jachmann
Mon, Apr 16, 2018 at 06:47:43PM +0700, Eugene Grosbein :
> 16.04.2018 18:35, Christian Jachmann wrote:
>
> > But on i386.... it seems to be broken.
>
> Why don't you rebuild src/usr/bin/w with debugging symbols, generate core and show backtrace?
>

Jes, here it is:

Core was generated by `w'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/libkvm.so.7...Reading symbols from /usr/lib/debug//lib/libkvm.so.7.debug...done.
done.
Loaded symbols for /lib/libkvm.so.7
Reading symbols from /lib/libsbuf.so.6...Reading symbols from /usr/lib/debug//lib/libsbuf.so.6.debug...done.
done.
Loaded symbols for /lib/libsbuf.so.6
Reading symbols from /lib/libxo.so.0...Reading symbols from /usr/lib/debug//lib/libxo.so.0.debug...done.
done.
Loaded symbols for /lib/libxo.so.0
Reading symbols from /lib/libutil.so.9...Reading symbols from /usr/lib/debug//lib/libutil.so.9.debug...done.
done.
Loaded symbols for /lib/libutil.so.9
Reading symbols from /lib/libc.so.7...Reading symbols from /usr/lib/debug//lib/libc.so.7.debug...done.
done.
Loaded symbols for /lib/libc.so.7
Reading symbols from /lib/libelf.so.2...Reading symbols from /usr/lib/debug//lib/libelf.so.2.debug...done.
done.
Loaded symbols for /lib/libelf.so.2
Reading symbols from /libexec/ld-elf.so.1...Reading symbols from /usr/lib/debug//libexec/ld-elf.so.1.debug...done.
done.
Loaded symbols for /libexec/ld-elf.so.1
#0  ifree (tsd=0x28000000) at arena.h:799
799             return (*mapbitsp);
(gdb) bt
#0  ifree (tsd=0x28000000) at arena.h:799
#1  0x28155316 in __free (ptr=0x280601ef) at tsd.h:716
#2  0x28095b07 in xo_do_emit_fields ()
    at /usr/src/contrib/libxo/libxo/libxo.c:6419
#3  0x28093a1c in xo_do_emit (xop=<value optimized out>,
    flags=<value optimized out>, fmt=0x804ad4d "")
    at /usr/src/contrib/libxo/libxo/libxo.c:6470
#4  0x28093b61 in xo_emit (fmt=0x804ad4d "")
    at /usr/src/contrib/libxo/libxo/libxo.c:6541
#5  0x08049f50 in main (argc=<value optimized out>, argv=<value optimized out>)
    at /usr/src/usr.bin/w/w.c:475
Current language:  auto; currently minimal
(gdb)


I see, this is somewhere in libxo...

and only on i386.


--
Christian
_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-stable
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|

Re: w/uptime broken in stable

Eugene Grosbein-10
16.04.2018 19:04, Christian Jachmann wrote:

> #0  ifree (tsd=0x28000000) at arena.h:799
> 799             return (*mapbitsp);
> (gdb) bt
> #0  ifree (tsd=0x28000000) at arena.h:799
> #1  0x28155316 in __free (ptr=0x280601ef) at tsd.h:716
> #2  0x28095b07 in xo_do_emit_fields ()
>     at /usr/src/contrib/libxo/libxo/libxo.c:6419
> #3  0x28093a1c in xo_do_emit (xop=<value optimized out>,
>     flags=<value optimized out>, fmt=0x804ad4d "")
>     at /usr/src/contrib/libxo/libxo/libxo.c:6470
> #4  0x28093b61 in xo_emit (fmt=0x804ad4d "")
>     at /usr/src/contrib/libxo/libxo/libxo.c:6541
> #5  0x08049f50 in main (argc=<value optimized out>, argv=<value optimized out>)
>     at /usr/src/usr.bin/w/w.c:475
> Current language:  auto; currently minimal
> (gdb)
>
>
> I see, this is somewhere in libxo...
>
> and only on i386.

Make a PR please.

_______________________________________________
[hidden email] mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-stable
To unsubscribe, send any mail to "[hidden email]"